


EASTMAN KODAK COMPANY SOFTWARE LICENSE AGREEMENT

Read the following terms and conditions carefully before using the enclosed software. Use of the software within this package indicates your 
acceptance of these terms and conditions. If you do not agree with them, you should promptly return the package in its entirety and your money 
will be refunded.

License

1. Grant of License. Eastman Kodak Company (“Kodak”) grants you a license to use one copy of the enclosed software program(s) (the 
“Software”) subject to the license restrictions set forth below.

2. Restrictions on Use. You may use the software only on one computer at a time. For each additional computer on which the Software is 
running at the same time, you will need an additional licensed copy of the software. You may copy the Software as necessary to use the 
Software as described above.

3. Transfer of the Software. You may permanently transfer the Software to another party if the other party agrees to accept the terms and 
conditions of this license and you retain no copies of the Software.

4. Copyright. The Software is owned by Kodak or its suppliers and protected by copyright laws and International treaties. You may not copy 
the Software other than as expressly provided in this license. You may not reverse engineer, decompile, or disassemble the Software.

5. Term. This license is effective until terminated. You may terminate it at any time by destroying the Software together with all copies in any 
form. It will also terminate if you fail to comply with any term or condition of this Agreement. You agree upon such termination to destroy the 
Software together with all copies in any form.

Limited Warranty

For a maximum period of up to one year, as evidenced by a copy of your purchase receipt, Kodak warrants (i) the Software will perform 
substantially in accordance with the accompanying written materials, and (ii) the media on which the Software is furnished will be free from 
defects in materials and workmanship under normal use.

Kodak does not warranty that the functions contained in the Software will meet your requirements or that the operation of the Software will be 
uninterrupted or error free. You assume responsibility for operation of the Software to achieve your intended results, and for installation, use, 
and results obtained from the Software.

KODAK MAKES NO OTHER WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING THE IMPLIED WARRANTIES 
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. Some states and countries do not allow the exclusion of implied 
warranties, so the above exclusion may not apply to you. This warranty gives you specific legal rights and you may also have other rights.

Limitations of Remedies

Kodak’s entire liability and your exclusive remedy shall be, at Kodak’s option either (a) the repair or replacement of the Software or any media 
not meeting Kodak’s “Limited Warranty” that is returned to Kodak or your dealer with a copy of your receipt, or (b) the return of the price you 
paid for the Software, provided you have proof of the purchase price you paid. These remedies are not available if the failure of the Software or 
media is the result of misuse, abuse, or a failure to follow the operating instructions in the accompanying written materials.

IN NO EVENT WILL KODAK OR ITS SUPPLIERS OR DEALERS BE LIABLE TO YOU FOR ANY INCIDENTAL OR CONSEQUENTIAL 
DAMAGES, INCLUDING ANY LOST PROFITS, LOST SAVINGS, OR OTHER DAMAGES ARISING OUT OF THE USE OR INABILITY TO 
USE THE SOFTWARE EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

Some states and countries do not allow the limitation or exclusion of liability for incidental or consequential damages, so the above limitation 
may not apply to you.

General

If the Software was purchased in the United States, this Agreement is governed by the laws of the State of New York. If purchased outside the 
United States, this agreement is governed by the laws of the country in which it was purchased.

If you have any questions concerning this Agreement, contact your local KODAK representative.

U. S. Government Restricted Rights

The SOFTWARE and documentation are provided with RESTRICTED RIGHTS. Use, duplication, or disclosure by the Government is subject to 
restrictions as set forth in subdivision (b)(3)(ii) of the Rights in Technical Data and Computer Software clause 252.227- 7013. Contractor/ 
manufacture is Eastman Kodak Company, 343 State Street, Rochester, New York, 14650.

European Community Provisions

If this Software is used within a county of the European Community, nothing in this Agreement shall be construed as restricting any rights 
available under the European Community Software Directive, OJ. Eur. Comm. (No. L. 122) 42 (1991).

EASTMAN KODAK COMPANY

ROCHESTER, NEW YORK 14650
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1   Overview 
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Kodak Capture Pro Software is an easy-to-install, easy-to-use production 
scanning application for electronic capture of documents. 

This software is ideal for imaging, forms processing and workflow applications, 
and as a standalone application. It manages one- and two-sided scanning, 
indexing and batching in color, black and white, and/or grayscale. Batches can 
be easily exported to many popular applications. Capture Pro Software allows 
you to fully utilize your scanner capabilities for maximum productivity. All 
functions are performed in the software; no special hardware acceleration is 
required.

Capture Pro Software is designed for speed, accuracy, and ease-of-use. It 
enables optimum scanner throughput and maximum productivity. A high-speed 
multi-page display presents the images and optional index data as documents 
are scanned. A complete set of icon-based tools is available to simplify 
scanning management. 

Scanner support Kodak Capture Pro Software supports most Kodak Scanners and almost any 
non-Kodak Scanner that has a certified ISIS driver. For a complete list of 
scanners that are supported by Capture Pro Software go to: www.kodak.com/
go/kcsscannersupport.

If your non-Kodak Scanner is not supported and you want to add your scanner 
to the supported list, provide your scanner information to your Kodak 
Authorized Reseller or local Kodak Representative.

• Capture Pro Software also supports Kofax VRS Version 4.x for any 
scanners that have been certified for use with VRS.

• Support for non-Kodak Scanners is certified only for Microsoft Windows XP 
and Microsoft Windows Vista operating systems. For more information see, 
Appendix B, System Requirements.
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Supporting 
documentation

In addition to this User’s Guide, the following documentation is also available:

• On-line Help — provides product information including detailed product 
setup, details about the user interface and many advanced features. To 
locate information in the Help file you can use the table of contents, the 
index, or the search feature. 

To access Help, press F1, select the Help button on a dialog box or click the 
? icon in the top right-hand corner of any window.

• On-line Tutorial — the Kodak Capture Pro Software Tutorial provides a 
product overview followed by detailed product setup examples designed to 
familiarize you with key Capture Pro Software features. The tutorial walks 
you through the basic steps for performing tasks such as job setup, 
scanning, indexing and outputting your scanned images.

The tutorial is an optional item within the Capture Pro Software installer. If it 
was installed, you can run it by selecting Help>Tutorial. If it was not 
installed, reinsert your Capture Pro Software installation DVD and install it or 
run it from the DVD.

The tutorial for each supported language is also available for download for 
the Capture Pro Software website at www.Kodak.com/go/kcsdownloads.

• Reference Guide — provides simple procedures for getting started quickly 
including installing and launching Kodak Capture Pro Software. Procedures 
are also provided for scanning using the default pre-defined job setups. A 
PDF for this guide can be found on the Kodak Capture Pro Software DVD. 

• Release Notes — contain information that may not have been available in 
other supporting documentation. To view the Release Notes, go to 
www.kodak.com/go/kcsdownloads and select the Capture Pro Software 
Upgrade for Version X.X link. The download page contains a link to the 
latest Release Notes. 

Kodak Capture Pro 
Software Demo 
Version

Kodak Capture Pro Software provides a demo version to demonstrate the 
unique features of the software. This demo version provides many of the same 
features as Kodak Capture Pro Software with the following exceptions:

• No hardware key (USB dongle) is required to run the Demo version.

• 25% of the images are stamped with the word 'Demo' (added as a bitmap to 
your images).

• 100% of all images will be stamped with a "DEMO" bitmap when batches 
are output.

• Changes to index data fields are only saved for the first 10 documents of 
each batch. After the 10th document, any changes to the index field values 
will not be saved.
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Virus scanning 
applications

If you are using a virus scanning application, system performance will improve 
if you exclude Kodak Capture Pro Software workgroup, scanned images and 
batch output folders and subfolders from the virus scanning application 
access. 

The default folder names are: 

c:\ScanPro

c:\BatchesPro

c:\Document and Settings\All Users\Shared Documents\KCSPro (on Windows 
XP Systems)

c:\Users\Public\Documents\KCSPro (on Windows Vista Systems)

c:\Program Files\Kodak\Capture Pro

NOTE: If you modified the default installation folders by selecting the 
Advanced installation option, exclude those folders when configuring 
your anti-virus software.
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2   Installing the Software and Getting Started 
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Installing the 
software

Before you begin, refer to the Appendix B, System Requirements to ensure 
your PC is suitable for Capture Pro Software. 

To complete the installation, you will need:

• The scanner driver CD provided by the scanner manufacturer and the 
Kodak Capture Pro Software installation DVD.

• The hardware key (USB dongle) and License code (located inside the DVD 
case) that came with the Capture Pro Software DVD. For Kodak Capture 
Desktop Software and the Demo version of Capture Pro Software, the 
hardware key is not required.

• Administrator rights on the PC where you are installing the software.

1. Install the scanner drivers by inserting the scanner driver CD into the CD 
drive and follow the prompts. 
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When you install the Kodak Scanner driver, the Kodak Scan Validation Tool 
will automatically be installed. This tool will be used to test that the scanner 
is connected properly and working.

NOTE: For non-Kodak manufactured scanners, follow the manufacturer’s 
recommendations for installing and testing the scanner on your PC.

2. Connect the scanner and test the connection using the Kodak Scan 
Validation Tool. See your scanner’s User’s Guide for more information.

3. Insert the Kodak Capture Pro installation Software DVD into the CD drive. 
Before installing, check the Release Notes for any additional information. 
The Release Notes are available in the root folder of the installation DVD 
or go to www.kodak.com/go/kcsdownloads and select the Capture Pro 
Software Upgrade for the Version X.X link.

NOTE: If the installation process does not start automatically, navigate to 
the drive where the DVD is installed and double-click Setup.exe 
which is found in the root folder of your Kodak Capture Pro 
Software installation DVD.

4. When the Installation Menu screen is displayed, select the desired 
language and click the Install Kodak Capture Pro Software option.

5. Click I Accept the terms of the license agreement after you have read 
the License Agreement and click Next.

6. At the License screen enter the License Code (include the dashes when 
entering your license code) for your hardware key and click Next.

NOTE: For Kodak Capture Desktop Software and the Demo version of 
Capture Pro Software, the hardware key and license code are not 
required.

7. At the Setup Type screen select the Typical installation for installing Kodak 
Capture Pro Software and click Next.

8. The Information screen will be displayed listing a summary of Kodak 
Capture Pro Software information. Click Next.

9. The Ready to Install the Program screen will be displayed. Click Install to 
start the installation. Progress screens will be displayed. Follow any 
prompts.

10. Click Finish.

11. Optionally, you can install the Tutorial from the DVD installation menu so it 
is available from the Help menu when running Capture Pro Software.

12. If prompted, select the option to restart your computer.

13. Insert the hardware key (USB dongle) in a USB port on your PC.

NOTE: If you are installing Kodak Capture Desktop Software, the hardware 
key is not required.
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Launching Kodak 
Capture Pro Software

Be sure your scanner is turned on and is attached properly to the PC. Your 
hardware key must be inserted into a USB port on your computer (unless you 
are using Kodak Capture Desktop Software). 

Selecting your 
scanner

The first time you start Capture Pro Software the message, Your scanner has 
not been selected. Do you want to set it up now? is displayed. Click Yes to 
display the Workstation Setup screen. From this screen you can select the 
scanner you will be using from the list of available scanners. Subsequent 
launches of the software will bypass these steps.

1. Click Select. The Select Scanner screen will be displayed.

2. Select the scanner you have installed on your PC and click OK.

3. Click OK on the Workstation Setup screen.

4. After selecting your scanner, the registration screens will be displayed. 
Register your copy of Kodak Capture Pro Software to continue using the 
software after the initial 14-day period.

NOTE: An Internet connection is required to complete the registration 
process. Follow the on-screen prompts and enter the required 
information. After submitting the registration, you have 14 days to 
use the software before you need to enter the code that will be sent 
to your registered e-mail address to fully unlock the software.

• Double-click the Kodak Capture Pro Software icon on your 
desktop, or

• go to: Start>Programs>Kodak>Kodak Capture Pro 
Software.
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Terminology Before you begin a basic understanding of some of the terminology used in 
Kodak Capture Pro Software is helpful. 

Kodak Capture Pro Software is “job” based. A job is a configuration that is 
setup to capture and process a set of documents that you want to scan. 

To scan documents in a job, you need to create a batch to hold the scanned 
documents, images and data before you output them.

Kodak Capture Pro Software organizes scanned documents in the following 
hierarchy:

• Batch: contains one or more scanned documents (similar to a folder or 
hanging file containing several separate documents).

• Document: contains one or more page(s) related to a single item (e.g., the 
contents of an envelope).

• Page: are physical sheets of paper that are fed through the scanner to 
produce images.

• Image: electronic representations of scanned pages.

Output is the process of sending the batch to the desired output system / 
location in the format that you chose.

NOTE: See Appendix A, Glossary for a full listing Kodak Capture Pro Software 
terminology.
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Batch Manager 
dialog box

When you log into Kodak Capture Pro Software, the Batch Manager dialog box 
will be displayed. The Batch Manager dialog box can also be displayed by 
selecting Batch>Open. Use this box to manage all the batches associated 
with your job setups.

Available jobs — lists all of your job setups. Select a batch from any of these 
job setups.

Batches of the selected job — displays the Job Name, Batch Name, Time 
Created, Batch Status, and Locked By fields for the selected jobs.

Show Options — displays the Show Options dialog box, which allows you to 
select what states (i.e., Available, Processing, etc.) to display in the Batch 
Status field on the Batch Manager dialog box.

Open — displays the batch that you selected on the list. The Open command 
will not open a batch listed as In Use. You must have read/write permission for 
the scanned image location to open an existing batch.
New — displays the New Batch dialog box, which allows you to create a new 
batch.
Rename — displays the Rename Batch dialog box, which allows you to 
rename the selected batch.
Delete — deletes the selected batch. A confirmation box will be displayed to 
confirm your deletion.
Output — sends the batch to be processed. 
Close — closes the dialog box.

Click to display all the batches in all of the job setups.

Click to hide all the batches in all of the job setups.
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Creating a new batch When you want to scan documents, you need to create a new batch or open 
an existing batch to scan the documents into. In most cases your system 
administrator has already configured the jobs you will use. These jobs will be 
listed in the Batch Manager dialog box.

To create a new batch:

1. Launch Kodak Capture Pro Software. The Batch Manager dialog box will 
be displayed.

1. Select New. The New Batch dialog box will be displayed.

2. Select a job setup from the Job name drop-down list. Your new batch will 
be captured and output as defined in this job setup.

3. If applicable, enter a new batch name in the Batch name field. By default, 
Kodak Capture Pro Software suggests a new batch name based upon the 
last batch name created for the job setup. For example, if the last batch 
name is Health030, then the new batch name default will be Health031.

4. If applicable, enter the starting document ID. The starting document ID is 
the ID you want to assign to the first document in a batch. In most cases, 
that ID is 1. By default, the software suggests a starting document number 
based upon the job setup.

5. Click OK. The Image Viewer will be displayed on the Main window with the 
batch name you assigned. The Image Viewer, Batch Explorer, and 
Thumbnail Viewer will remain blank until you start scanning.
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Opening an existing 
batch

To open an existing batch:

1. Select Batch>Open. The Batch Manager dialog box will be displayed. 
Depending on your settings, the batches from all of your job setups will be 
displayed.

2. Highlight the batch you want and click Open. The batch you selected will 
be displayed in the Image Viewer and the Batch Explorer. You can now 
work in this batch.

NOTE: If you are scanning in a multiple-scanner environment and the 
batch you selected is already opened at another workstation, 
Kodak Capture Pro Software will not allow you to open the batch. 
The message, The batch cannot be opened because it is 
currently in use by another user will be displayed. 

Deleting a batch Deleting a batch erases both the images and batch subdirectory structure of 
the selected batch.

1. Select Batch>Open. The Batch Manager dialog box will be displayed. 
Depending on your settings, the batches from all of your job setups will be 
displayed.

2. Highlight the batch you want to delete and click Delete. The message, Are 
you sure you want to delete the selected batch “XXXXX”? will be 
displayed.

3. Click OK.
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Using a job This section provides the basic steps for creating a new batch, scanning your 
documents and outputting a batch. Detailed information regarding indexing, 
setting up OCR zones, patch reading, selecting different output sources, etc. 
can be found in other chapters of this User’s Guide.

NOTE: There are several ways to complete an action when using Kodak 
Capture Pro Software. For example, if you want to open a batch, you 
can select Batch>Open from the menu bar, you can click the Open 
Batch toolbar button or you can press the F3 shortcut key. For the 
purpose of this manual, all actions are described by using the menu 
bar. For a complete list of menus, toolbar buttons and function keys 
see Chapter 3, The User Interface.

1. If you have not already started Capture Pro Software, do so now. The 
Batch Manager dialog box will be displayed.

2. Click New. The New Batch screen will be displayed.

3. Select the desired job setup from the Job name drop-down box. The Batch 
name and Starting document ID are automatically filled in. You may 
change these if desired. 
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4. Click OK. The main screen will be displayed and you are ready to start 
scanning. 

5. Place the stack of documents you want to scan in the input tray of your 
scanner.

6. Click Start. The scanner will feed the pages.

7. When your documents have been scanned, you can perform any 
necessary editing options (i.e., remove blank pages, rotate images, crop 
images, etc.). See the next section, “Editing options” for a brief description 
of some of the options available.

8. When your batch is how you want it, select Batch>Output. The batch 
output task begins and the New Batch screen will be displayed allowing 
you to start another scanning session while processing is being done in the 
background. 

Your scanned images will be delivered to the location designated on the 
Capture tab in Job Setup. 
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Editing options Before outputting your batch, review your images to be sure they are as you 
want them. If you need to make some adjustments, tools are available for your 
use. This section provides procedures for some of the more commonly used 
editing functions (i.e., rotating images, deleting images, cropping images, etc.). 
Procedures for splitting and merging images can be found in Chapter 7, Page 
Setup. 

All menu options and toolbar options are described in Chapter 3, The User 
Interface.

Rotating images Kodak Capture Pro Software allows you to automatically rotate your images as 
they are being scanned (this is setup using Page Setup before scanning) or 
manually rotate them after they are scanned. Images are rotated 90, 180 or 
270° clockwise.

To manually rotate images in an existing batch:

1. Click on individual (or groups of) images, pages, or documents from the 
Batch Explorer list or in the Image Viewer.

2. Select Tools>Rotate> 90, 180, or 270. The rotated images will be 
displayed in the Image Viewer.
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Drawing a region The Draw Region tool allows you to draw a rectangle around a portion of an 
image, then blank the area inside the rectangle using Blank or crop the image 
to the size of the rectangle using Crop.

1. Click on an image that you want to crop or blank in the Image Viewer.

2. Select Tools>Draw Region. 

3. Click and drag the draw region cursor to create a rectangle over the part of 
your image that you want to select. Release the cursor; the rectangle is 
now green.

4. You can now crop or blank the region.

To discard a region:
• Right-click on the image containing the green rectangle and select Deselect 

Region.

Cropping images You can crop an area outside a rectangular region that you create using the 
Draw Region tool and using the Crop option.

1. Click on the image in Batch Explorer that you want to crop. The image you 
selected will be outlined in red in the Image Viewer.

2. Select Tools>Draw Region. 
3. Click and drag the draw region cursor to create a rectangle over the part of 

your image that you want to save. Release the cursor; the rectangle is now 
green.

4. Select Tools>Crop. The image area outside of the green rectangle will be 
deleted and only the selected area will remain in the Image Viewer.

5. Click OK to save your setting.
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Blanking out part of an 
image

If you want to blank out part of an image, you can draw a region on the image 
and use the Blank tool. The area inside the rectangle will be blanked out. 

1. Click on an image in Batch Explorer that you want to blank.
2. Select Tools>Draw Region. 
3. Click and drag the draw region cursor to create a rectangle over the part of 

your image that you want to blank. Release the cursor; the rectangle is 
now green.

4. Select Tools>Blank. The image will now display a blank area where you 
positioned the green rectangle.

5. Click OK to save your setting. 

Attaching pages This option allows you to scan extra pages into an existing document. 

1. In the Batch Explorer, select the document that is to receive the 
attachment.

2. Click Document>Attach Page.
3. Scan the images. The new pages will be displayed at the end of the 

selected document. 

Rescanning images When reviewing your batch of scanned images, occasionally you may need to 
rescan some documents.

1. Highlight the page or pages you want to rescan.

2. Put the originals in the correct order in the scanner.

3. Click the Rescan icon. The images will be rescanned and placed in their 
original scanned positions.

Deleting images If you want to delete selected images from a batch:

1. Select the image you want to delete.

2. Select Edit>Delete. The message, Are you sure you want to delete the 
selected item(s)? will be displayed.

3. Click Yes to confirm the deletion.
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Deleting a range of 
documents

You can delete a range of documents in an existing batch.

1. Select Document>Delete Range. The Delete Documents in Range dialog 
box will be displayed.

2. Enter the beginning number of the document group you want to delete in 
the From Document Number field.

3. Enter the ending number of the document group in the To Document 
Number field.

4. Click OK.

Removing blank images 
from a batch

This option allows you to remove the blank back or front images produced by 
the scanner.

1. Select Batch>Remove Blank Images. The Remove Blank Images Setup 
dialog box will be displayed.

2. Enter the beginning document number in the batch where you want to 
search for blank images in the Start at document field. The default is the 
currently active document.

3. Define the byte-size threshold of the images to be verified in the Show 
Black and White images below and Show Color/Grayscale images fields. A 
good setting for typical business documents is 3000 bytes in 200 dpi black 
and white.

4. Click Check only back sides to remove only the blank back sides of the 
images in a batch.

5. Click Pre-select all if all images are candidates for deletion.
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6. Define the number of columns and rows you want to display in the Display 
layout field. On a 1024 x 768 SVGA screen, a matrix of 14 x 7 allows you to 
check 98 images per screen.

7. Click OK to accept the values you entered. 

After the batch is examined, Kodak Capture Pro Software displays all the 
images that match the criteria you set up (for example, back sides below 
5000 bytes) the Remove Blank Images window. These images are 
displayed in a red highlight color. All colored images are considered blank 
and ready to be deleted.

• If no blank images are displayed in the Remove Blank Images window, 
it means that Kodak Capture Pro Software cannot locate images in your 
batch that match your criteria. You can click Setup on the Remove 
Blank Images window to reopen the Remove Blank Images Setup 
dialog box and enter higher threshold numbers (in bytes) for the black 
and white and/or color/grayscale images.

8. By default, all the blank images are outlined in red and selected for 
deletion. Select any blank images you do not want to delete by clicking 
them individually. The red outline disappears on those images.

9. Use the First Screen, Previous Screen, Next Screen and Last Screen 
buttons to help you navigate through all the possible blank images in the 
batch.

10. Click Remove. The message Remove all selected images? will be 
displayed.

11. Select Yes to confirm the deletion of the blank images. Capture Pro 
Software removes the blank images still outlined in red, repaginates the 
documents, and updates the available batch and hard disk capacity.
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Outputting (processing) 
your batch

When all of your editing changes are complete, you are ready to output your 
batch.

Kodak Capture Pro Software allows you to output (or process) one batch at a 
time or output all available batches at once. 

To output the current batch in a job setup:

1. Select Batch>Output. 

When your batch is queued for output, the New Batch dialog box will be 
displayed allowing you to scan another batch of documents. 

2. Click OK to continue scanning images into the new batch. When you 
output a batch, it is processed according to the Batch Output Format 
selected in the Output tab of the Job Setup dialog box. This typically results 
in the batch being copied to an output subdirectory path.

To output all available batches in a current job setup:

• Select Batch>Output All. The Batch Manager dialog box will be displayed 
where you can select one or more batches to be outputted. 

To view the output progress:
• Select Batch>View Batch Output Status. The Kodak Capture Pro Batch 

Process Status window will be displayed. 

This window will update you on the progress of your batches as they are 
outputted. When outputting in the background, scanning takes higher 
priority. Output will be slowed until scanning is finished.

NOTE: If you experience issues when outputting your job, see Chapter 11, 
Troubleshooting for problem resolution. 
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This chapter provides descriptions of the Main window of Kodak Capture Pro 
Software, as well as descriptions of the menu bar, toolbars and viewers.
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Main window The Main window has the following components.

1 Program title bar — provides the name of the job setup.

2 Menu bar — provides the following menu items: File, Batch, View, 
Capture, Document, Edit, Tools, Index and Help.

3 Toolbars — provides the following toolbars: Capture, Batch, View, 
Document, Navigation, Flag, Edit and Index.

4 Batch Explorer — lists all the document folders, pages and image files in 
the batch. 

5 Image Viewer — displays the images in a batch. The Image Viewer can 
be configured to show 1, 2, 4, 8 or more images at a time.

6 Thumbnail Viewer — displays thumbnails of all the images in the batch.

7 Index tab — when you click the Index tab (located on the right-hand side 
of the Main window) the Index window is displayed which provides batch 
or document level indexes. 
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8 Information tab — when you click the Information tab (located on the 
right-hand side of the Main window) the Information window is displayed 
which provides detailed statistics on the batch, document, page and 
image.
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Menu bar The Menu bar provides the following menu items: File, Batch, View, Capture, 
Document, Edit, Tools, Index, and Help.

File menu The File menu contains the following options:

Job Setup — displays the Job Setup dialog box, which allows you to set up all 
the parameters for a job setup. See Chapter 4, Job Setup for more information. 
Keyboard shortcut: J.

Page Setup — displays the Page Setup dialog box, which allows you to select 
a predefined page setup or create your own custom page setup for your job 
setup. Kodak Capture Pro Software comes with several pre-defined page 
setups. The list of predefined page setups varies depending on the scanner 
being used. See Chapter 7, Page Setup for more information.

Workstation Setup — displays the Workstation Setup dialog box, which 
allows you to select the scanner attached to your PC for scanning documents 
into Kodak Capture Pro Software. See the next section entitled, “Setting up 
your workstation” for procedures.

Import Job Setup— displays the Import dialog box, which allows you to 
import a job setup. See Chapter 4, Job Setup for more information.

Export Job Setup — displays the Export dialog box, which allows you to 
export the job setup to a file. See Chapter 4, Job Setup for more information.

User Setup — displays the User Setup dialog box, which allows the 
administrator to set up and manage users of Kodak Capture Pro Software. See 
Chapter 9, User and Group Setup for more information.

Change Password — displays the Change Password dialog box, which 
allows you to change your password.

To change a password:

1. Select File>Change Password. The Change Password dialog box will be 
displayed.

2. Enter your Old Password, then enter your New Password.

3. Confirm your password by entering your new password in the Confirm 
Password field.

4. Click OK. 

Language — allows you to select the language in which the user interface is 
displayed. Supported languages are: English, French, Italian, German, 
Portuguese-Brazilian, Dutch, Spanish, Simplified Chinese, Traditional 
Chinese, Swedish, Korean, Turkish, Czech, Russian and Japanese.
To change the language:

1. Select File>Language. 

2. Select the desired language. The user interface will be displayed in the 
selected language.

NOTE: The Scanner Setup dialog box (TWAIN Driver) may display the wrong 
text characters when the default language is a Western language and 
the user changes to an Asian language. To solve this, use the system 
"Regional and Language options" to set the "Language for non-
Unicode Programs" to the desired Asian language.
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Measurement System — allows you to select US or Metric units.

Print — displays the Print Setting dialog box for the selected printer, which 
allows you to print scanned documents. Keyboard shortcut: Ctrl + P.

Save As PDF — displays the Save as PDF dialog box, which allows you to 
save scanned images to a searchable or unsearchable PDF format.

Logout — logs out the current user.

Minimize to System Tray — minimizes the Capture Pro Software application 
but does not close the software.

Exit — closes Kodak Capture Pro Software. Keyboard shortcut: Alt + F4.

Setting up your Workstation When you select File>Workstation Setup, the Workstation Setup screen is 
displayed. From this screen you can setup the workstation information and 
choose the scanner you want to use.

1. Enter the ID and Name of your workstation. In a multi-scanner environment 
the ID and name must be unique.

2. Click Select. The Select Scanner dialog box will be displayed listing the 
available scanners. 

3. Select the scanner you want to use and click OK. 

4. Enter the desired Disk Warning Level in megabytes (MBs). You will receive 
a warning if the free space on the disk falls below this level.

5. Check Enable job level batch numbering if you want the batch sequence 
number to be kept independently for each job. If this option is checked, 
numbering will be maintained at the job level. If not checked, numbering 
will be maintained at the system level. For example: 

6. When finished, click OK.

System Level Job Level
Invoices INV001 Invoices INV001
Claims CLM002 Claims CLM001
Records RCD003 Records RCD001
Invoices INV004 Invoices INV002
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Batch menu The Batch menu contains the following options:

New — displays the New Batch dialog box, which allows you to create a new 
batch. See Chapter 2, Installing the Software and Getting Started for 
procedures.

Open — displays the Batch Manager dialog box, which allows you to open an 
existing batch. Keyboard shortcut: F3. See Chapter 2, Installing the Software 
and Getting Started for procedures.

Rename — displays the Rename Batch dialog box, which allows you to 
rename a current batch.

Remove Blank Images — displays the Remove Blank Images Setup dialog 
box, which allows you to remove the blank back or front images produced by 
the scanner. See Chapter 2, Installing the Software and Getting Started for 
procedures.

Output — starts processing all images in the current batch. Keyboard 
shortcut: O. See Chapter 2, Installing the Software and Getting Started for 
procedures.

Output All — starts processing all images in all batches of the current job. 

View Batch Output Status — displays the Kodak Capture Pro Batch Status 
window, which provides information on the progress of your outputting 
commands.

Clear — erases all the images in a batch, but keeps the batch subdirectory 
structure intact.

Delete — erases both the images and batch subdirectory structure of the 
selected batch. See Chapter 2, Installing the Software and Getting Started for 
procedures.

Delete to End of Batch — erases all the images from the selected image to 
the last image in the batch.
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View menu The View menu contains the following options:

Image Viewer Display — allows you to select a grid of 1, 2, 4 or 8 images to 
display in the Main window. Selecting Customize displays the Custom Layout 
Setup dialog box, which allows you to specify another grid size.

Image Viewer Filter — allows you to specify one or more types of images that 
will be displayed in the Image Viewer of the Main window. You can select one 
or more of the following: Front, Back, Black & White, Grayscale, and Color.

Thumbnail Viewer Filter — allows you to specify one or more types of images 
that will be displayed in the Thumbnail Viewer of the Main window. You can 
select one or more of the following filters: Front, Back, Black & White, 
Grayscale and Color.

Thumbnail Image Size — displays the Thumbnail Image Size Setup dialog 
box, which allows you to specify the size of each thumbnail that will be 
displayed in the Main window.

Image Viewer, Batch Explorer, Thumbnail Viewer, Information, Index, 
Status Bar — these commands allow you to select whether the corresponding 
components are displayed in the Main window. The keyboard shortcut for 
Status Bar is Ctrl + S.

Toolbars — allows you to view or hide the following toolbars: Capture, Batch, 
View, Document, Navigation, Flag, Edit, and Index. Detailed information 
regarding the toolbars can be found later in this chapter.

Icon Size — allows you to specify Small, Medium or Large icons.

Icon Text — allows you to specify if icon labels will be displayed and, if so, on 
the right or below the icons.

Zoom — increases or decreases the displayed size of an image. 

• Actual: displays the image at actual size (one scanned pixel equals one 
pixel on the Image Viewer.)

• Zoom In: increases the image display by the increment specified in the 
Zoom Step Setup dialog box.

• Zoom Out: decreases the image display by the increment specified in the 
Zoom Step Setup dialog box.

• Zoom Step: displays the Zoom Step Setup dialog box, which allows you to 
specify the increment (15%, 20%, 25%, 30%, 35% or 40%) that the image 
size is changed when you use the Zoom In and Zoom Out commands.

Pan All Images to — enables you to move all images around the Image 
Viewer pane at once. You can pan to the Top, Bottom, Left or Right of the 
images.

Pan Step Setup — displays the Pan Step Setup dialog box, which allows you 
to specify the desired number of pixels (5, 10, 15, 25, 50 or 100) an image 
moves when you use the Pan commands.

Layout — allows you to change between the Classic and Enhanced layout 
modes.
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Capture menu The Capture menu contains the following options:

Start — enables the scanner and starts the transport. Keyboard shortcut: F7.

Stop — clears and stops the transport and disables the scanner. Keyboard 
shortcut: F6.

Page Setup List — displays the Page Setup List dialog box, which allows you 
to select from the defined page setups. Keyboard shortcut: F2.

Capture modes — determines how a batch is scanned by allowing you to 
select one of the following settings:
• Two-Sided: scans the front and back of a page.
• One-Sided Front: scans the front of a page.
• One-Sided Back: scans the back of a page.

Select Scanner — displays the Workstation Setup dialog box, which allows 
you to select the scanner you want to use.

Manual Import Images — allows you to import image files created from 
another source (e.g., an engineering drawing scanner) into the currently 
displayed document in Capture Pro Software. 

When you select Manual Import Images, the Open dialog box will be 
displayed. Navigate to the directory where you want to import images from and 
select the desired image file(s). BMP, JPEG and TIFF image files can be 
imported. The images that you selected to be imported will be inserted 
immediately before the image that is selected in the currently displayed 
document. If there are no selected images, the imported images will be 
appended to the end of the current document.

Both single- and multi-page TIFF files are supported. When importing a multi-
page TIFF file, each image in the file will be imported as a separate image into 
the document.

More than one image file can be selected for import. If more than one image 
file is selected, the images will be imported in alphabetical/numerical order 
according to their image file name.

Auto Import Images — allows you to import images into Kodak Capture Pro 
Software without the use of a local scanner or manual intervention. This is 
done by observing special directories called “watch folders”. Files to be 
imported will be copied into subfolders within a watch folder which are called 
Auto Import or AI batch folders. Auto Import will extract images from these files 
and stream them into the Capture Pro Software workstation just as if they had 
originated from a local scanner. See Chapter 10, Auto Import for more 
information.

Auto Import Setup — displays the Auto Import Setup dialog box which allows 
you to configure auto import “watch folders”. You can identify watch folders 
and assign them user friendly names using the Auto Image Setup dialog box. 
You can also identify directories for archiving and error handling, assign error 
threshold levels, specify auto import batch separation rules, and timeout 
intervals. See Chapter 10, Auto Import for more information.

Set Image Address — displays the Image Address dialog box, which allows 
you to change image address settings for your batch. This option becomes 
active only if you have a scanner capable of image addressing.

Set Counter — displays the Set Counter dialog box, which allows you to reset 
the sequential counter value assigned (and optionally printed) to the next page 
scanned. This option becomes active only if you have a scanner with a 
counter.
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Document menu The Document menu contains the following options:

New — creates a new document with a document number equal to the last 
document number plus "1". Keyboard shortcut: Ctrl + Enter.

NOTE: For some scanners, selecting New also enables the scanner and 
starts the scanner transport/feeder or flatbed.

Attach Page — allows you to scan extra images and add them as pages to an 
existing document. Keyboard shortcut: F4.

Insert Pages — inserts additional pages into a scanned document. Keyboard 
shortcut: Insert.

NOTE: If image address and patch detection are set, Insert Pages will not 
cause a document separation when a document patch is detected. 

Rescan Pages — repeats scanning of the document. Keyboard shortcut: R.

Split Document — splits the selected document into two documents. 

Merge into Previous — places the document currently being scanned into the 
previous document.

Delete — deletes the currently opened document. Keyboard shortcut: F8.

Delete Range — displays the Delete Documents in Range dialog box, which 
allows you to delete a range of documents in the batch.

Delete to End of Document — allows you to delete the selected image and 
all subsequent images of a document. This command removes images from 
your hard drive. You cannot undo this function.

Go to Document — allows you to select to go to the first, last, next or previous 
document in the batch, or you can select a Document Number to go to a 
specific document within a batch.

Go to Image — opens the Go to Image dialog box, which allows you to 
navigate to a specific image in the current document. Keyboard shortcut: I.
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Edit menu The Edit menu contains the following options:

Undo — reverts one level of the last action. If an action cannot be undone, a 
message will be displayed. Keyboard shortcut: Ctrl + Z.

Copy — copies a selected image for pasting to another location. Keyboard 
shortcut: Ctrl + C.

Copy Image Area — after using Draw Region to create a region on your 
image, this option allows you to copy this region to another location. Keyboard 
shortcut: Ctrl + I.

Copy Image to Job Setup — displays the Copy Image to Job Setup dialog 
box, which allows you to import images into the Bar Code window or the OCR 
window to create bar code or OCR zones.

Select All — selects all images in the current batch. Keyboard shortcut: 
Ctrl + A.

Select Document — selects all images in the current document.

Select Filtered — selects all images whose filtered parameters are selected.

Deselect All — deselects all images. Keyboard shortcut: Ctrl + D.

Select Flagged — selects all images that are flagged. Keyboard shortcut: 
Ctrl + F.

Delete — deletes the selected images from the batch. Keyboard shortcut: Del.
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Tools menu The Tools menu contains the following options:

Selector — displays the Pointer tool, which allows you to select images. 
Keyboard shortcut: S.

Selection mode — select Image, Page or Page Side. 

• If you select Image, you can click on an image in the Image Viewer and just 
the image will be selected.

• If you select Page, you can click on the image and the entire page, front and 
back, black and white and color/grayscale, will be selected.

• If you are scanning multiple images for a side (dual-stream scanning), when 
you select Page Side, and click on a front image, all front images will be 
selected. If you click on a back image, all back images will be selected.

Magnify — enlarges a portion of an image. When you select Magnify, the 
Magnify tool will be displayed. You can enlarge any area where you place the 
Magnify tool. (You must click and hold on the image.) Keyboard shortcut: M.

Pan — allows you to move the image around the Image Viewer pane when the 
image is larger than the pane. Keyboard shortcut: P.

Draw Region — allows you to draw a rectangle around a portion of an image, 
then blank the area inside the rectangle using Blank; or crop the image to the 
size of the rectangle using Crop (or copy it using Edit>Copy Image Area).

Magnification Ratio — displays the Magnification Ratio Setup dialog box, 
which allows you to select the desired magnification ratio of 100%, 150%, 
200%, 250% or 300%.

To magnify an existing image in the Image Viewer or Thumbnail Viewer:

1. Select Tools>Magnify.

2. Click on an image, then hold and drag the Magnify tool over the image.

Rotate — manually rotates the selected image 90, 180 or 270 degrees 
clockwise. Kodak Capture Pro Software allows you to automatically rotate your 
images as they are being scanned or manually rotate them after they are 
scanned.
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Flag Tool options — allows you to flag an image(s) that may need to be 
rescanned or adjusted in some way (e.g., contrast values may need to be 
adjusted to provide better image quality). When an image(s) is flagged, you 
can add any comments regarding the flagged page. Keyboard shortcut: C.

NOTE: If any page in a batch is flagged for rescan, the batch cannot be 
processed for output.

• Flag Tool: allows you to flag a page, image or both the front and back of an 
image.

• Flag All Selected: flags all selected images in the batch to be rescanned.

• Flag Document: flags all the images in the selected document.

• Flag Filtered: allows you to apply a filter to images currently displayed in 
the Image Viewer. Once you select which viewer you want to apply your 
filter to, you can select the Front Side or Back Side, Black and White, 
Grayscale or Color images.

• Unflag All Selected: removes the flags from the images currently selected.

• Unflag All: removes any of the previously flagged images in the current 
batch. 

Split Document — splits a document into two documents. For more 
information see Chapter 7, Page Setup.

Crop — allows you to crop out the area outside the rectangle you created 
using the Draw Region option. A confirmation box will be displayed when you 
select this option. Keyboard shortcut: Ctrl + R. 

Blank — allows you to blank out the area inside the rectangle that you created 
using the Draw Region option. A confirmation box will be displayed when you 
select this option. Keyboard shortcut: Ctrl + B. 
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Index menu The Index menu contains the following options:

Edit Index Fields — provides access to the index fields at the batch and 
document levels. Keyboard shortcut: E.

Previous Document — displays the index information for the previous 
document. Keyboard shortcut: F9.

Next Document — displays the index information for the next document. 
Keyboard shortcut: F10.

Next Invalid — displays the index information for the next document in which 
an index is invalid. Keyboard shortcut: F11.

Define Enter Key Behavior — allows you to assign an action that you want 
the software to take when you press Enter. Options are: go to the Next 
Document, go to the Next Invalid document or Save & Exit Indexing.

Zoom Zones — allows you to draw a rectangle around a portion of the image 
that you want zoomed for display when editing index fields. This zoom setting 
is saved per index field. As a result, you can define a zoom zone for each 
index field and the image display automatically zooms to the appropriate part 
of the image when that field is edited.

Drag-and-Drop OCR — allows you to populate an index field by drawing a 
region on the image. OCR is performed within the region, and the value is 
automatically put into that index field. After selecting the tool, draw a rectangle 
around the index data to be captured. 

NOTE: To properly create OCR special language-specific characters (e.g., « 
or ¸) or MICR code characters, select the appropriate language or 
MICR font from the drop-down list.

OCR Language — allows you to setup what language will be used for the 
OCR function.

Save & Exit Indexing — exits indexing and saves any changes you made to 
the batch. Keyboard shortcut: F12.

Cancel & Exit Indexing — exits indexing without saving any changes you 
made to the batch.
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Help menu The Help menu contains the following options:

Help — displays the on-line help for Kodak Capture Pro Software. Keyboard 
shortcut: F1.

Send Error Report — displays the Send Error Report dialog box, which allows 
you to enter a message describing your problem and send it to Kodak.

Tutorial — if you have installed the Tutorial for Kodak Capture Pro Software, 
this option will be on the Help menu. 

Enter License Code — displays the Enter License Code dialog box, which 
allows you to enter the license information necessary to use the software. The 
Request Code will be displayed at the top of the box. 

Register — displays the Product Registration dialog box which allows you to 
register your Kodak Capture Pro Software.

Kodak Capture Pro Online — displays the online help for Kodak Capture Pro 
Software.

About Kodak Capture Pro — displays the About Kodak Capture Pro 
Software dialog box, which provides information about the current version of 
the software. Use this box to view the following information:

• Copyright
• File extension
• File path
• Software serial number
• Software version number

This dialog box also allows you to access System Information which opens the 
Files Information window. This window provides information on individual files 
within the Capture Pro Software. The Files Information window is read-only.
• File name
• File size
• Creation date
• Version number
• Description

NOTE: Click "X" in the top right-corner to close the Files Information window.
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Toolbars

Capture toolbar The Capture toolbar contains the following commands:

Batch toolbar The Batch toolbar contains the following commands:

Document toolbar The Document toolbar contains the following commands:

Start — starts scanning images on the scanner.

Stop Scan — stops scanning images.

Page Setup name — select a page setup name from the drop-down list that 
best fits the job you are scanning.

Page Setup — displays the Page Setup dialog box, which 
allows you to set up scanning parameters.

Sides to Capture — allows you to select Two-sided, One-
Sided Front or One-Sided Back.

New batch — displays the New Batch dialog box, which allows 
you to create a new batch.

Open batch — displays the Batch Manager dialog box, which 
allows you to open an existing batch.

Output batch — starts outputting all the images in the current 
batch.

New document — allows you to add a new document.

Insert Pages — inserts additional pages into a scanned 
document. Highlight the first image in a page and the icon 
becomes active. Put the additional pages in the scanner and 
click this icon.
Rescan pages — repeats scanning of selected parts of the 
document. Highlight the page or pages you want rescanned, put 
the originals in the scanner and click this icon.
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View toolbar The View toolbar contains the following commands:

Navigation toolbar The Navigation toolbar contains the following commands:

Selector — displays the pointer tool, allowing you to select 
images.

Selection mode — select Image, Page or Page Side. 

• If you select Image, you can click on an image in the Image 
Viewer and just the image will be selected.

• If you select Page, you can click on the image and the entire 
page, front and back, black and white and color/grayscale, will 
be selected.

• If you are scanning multiple images for a side (dual-stream 
scanning), when you select Page Side, and click on a front 
image, all front images will be selected. If you click on a back 
image, all back images will be selected.

Magnify — allows you to enlarge a portion of an image. When 
you select Magnify, the Magnify tool will be displayed. You can 
enlarge any area where you place the tool. (You must click and 
hold on the image.)
Pan — allows you to move the image around the window when 
the image is larger than the window.

Image Viewer Display — allows you to use the down arrow to 
display 1, 2, 4 or 8 images or Customize your layout. When you 
select Customize, the Custom Layout Setup dialog box will be 
displayed, allowing you to enter the number of rows and 
columns you want to appear in the Image Viewer.
Zoom In — zooms in on all the images in the Image Viewer.

Zoom Out— zooms out on all the images in the Image Viewer.

First Document — displays the first document of the batch in 
the Image Viewer.

Last Document — displays the last document of the batch in 
the Image Viewer.

Previous Document — displays the previous document of the 
batch in the Image Viewer.

Next Document — displays the next document of the batch in 
the Image Viewer.
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Flag toolbar The Flag toolbar contains the following commands:

Edit toolbar The Edit toolbar contains the following commands:

Flag Tool — allows you to flag a page or image. For example, 
you may want to permanently identify images that need to be 
rescanned.
Flag All Selected — flags all selected images in the batch.

Flag Filtered — allows you to flag images currently displayed in 
the Image Viewer or Thumbnail Viewer. 

Unflag All — removes flags from any of the previously flagged 
images in the current batch.

Edit Index Fields — provides access to the index fields at the 
batch and document levels.

Rotate 90 — rotates the selected image(s) 90 degrees 
clockwise.

Rotate 180 — rotates the selected image(s) 180 degrees 
clockwise.

Rotate 270 — rotates the selected image(s) 270 degrees 
clockwise.

Draw Region — allows you to draw a rectangle around a portion 
of an image, then either remove the area inside the rectangle 
using Blank; or crop the image to the size of the rectangle using 
Crop.
Crop — allows you to remove the area outside the rectangle you 
created using the Draw Region option. 

Blank — allows you to blank out the area inside the rectangle 
that you created using the Draw Region option. A confirmation 
box will be displayed when you select this icon. 
Print — displays the Print Settings dialog box, which allows you 
to print a complete document or specific images within a 
document.
Save as PDF — displays the Save as PDF dialog box, which 
allows you to save a complete document or individual images as 
a searchable or unsearchable PDF file.
Delete Selected — deletes one or more images selected inside 
a document. For example, blank images can be deleted from a 
two-sided document; all remaining images are renumbered after 
the selected images are deleted. A confirmation box will be 
displayed when you select this icon.
Undo — reverts to the last crop, blank, or rotation of an image or 
set of images. The Undo option does not revert deletion 
commands.
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Index toolbar The Index toolbar contains the following commands:

Scanner Adjustments 
Toolbar

The Scanner Adjustments Toolbar allows you to change the following scanning 
options directly from the Capture Pro Software Main window:

NOTES:

• The Scanner Adjustments Toolbar is only available and can only be used 
with Kodak Document Scanners.

• Any changes made to the settings are temporary and will not modify the 
currently selected Page Setup that is being used for scanning.

• When a change is made to one of the settings on the toolbar, the setting will 
be highlighted in yellow to indicate that a change has been made.

• When the Page Setup to be used for scanning is changed, or if the same 
Page Setup is re-selected, the Scanner Adjustments Toolbar settings will be 
reset to the values that are defined in the Page Setup.

Previous document — moves to the previous document 
number containing images.

Next document — moves to the next document number 
containing images.

Next Invalid — goes to the next document that has an invalid 
index.

Zoom Zones — enlarges the display of the index data captured 
for the current field, allowing you to more clearly see difficult-to-
read special language-specific characters.
Drag-and-Drop OCR — allows you to drag-and-drop indexing 
via Optical Character Recognition (OCR) without entering the 
index value. After selecting the tool, draw a rectangle around the 
index data to be captured.
OCR Language — allows you to select an OCR language from 
the drop-down list. 

Save & Exit Indexing — saves the changes on the current 
batch and closes the Index window. 

Cancel & Exit Indexing — closes the Index window without 
saving any changes.

Threshold — controls the lightness and darkness of the 
background in an image. Valid values are 0 to 255. There is 
a separate Threshold setting for the front and back images.
Contrast — enhances the edges contained in a document. 
The higher the contrast level, the more the image edges will 
be enhanced. Valid values are 0 to 100 or -50 to 50 
depending on your scanner model. There is a separate 
Contrast setting for the front and back images.
iThresholding — when selected, the scanner automatically 
determines the optimal Threshold setting for each scanned 
page, thus improving overall scanning productivity and 
image quality. When selected, the Threshold setting for the 
front and back images are grayed out and unavailable for 
change.
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Keyboard shortcuts This section lists common keyboard shortcuts. Where available, the keyboard 
shortcuts are shown on the menu item for the function.

+ Zoom in image display
- Zoom out image display
1, 2, 4, 8 Allows you to change the image display between 1, 2, 4 or 8 

images
C Flag tool
E Edit index fields (enter Indexing Mode)
Enter New Document
F Fit image display size to the Image Viewer (best fit)
F1 Display on-line Help
F2 Display the Page Setup list (to select a different scanner settings 

profile)
F3 Open a batch
F4 Attach a page to the current document
F5 Display the Page Setup dialog box
F6 Stop scanning
F7 Start scanning
F8 Delete the selected document
F9 Move to Next document in indexing mode
F10 Move to Previous document in indexing mode
F11 Move to Next Invalid document in indexing mode
F12 Save index values and exit Indexing mode
I Go to image
J Display the Job Setup dialog box
O Output the current batch and automatically displays the New Batch 

dialog box
P Pan images
M Magnify tool (manual zoom tool)
R Rescan pages
S Selector tool (select images for post scan editing or for moving 

images / pages)
Z Draw region
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Batch Explorer The Batch Explorer displays all the document folders, page and image files for 
the batch that is currently open in the Image Viewer. It automatically appears 
on the left side of the Main window when the Enhanced layout is active.

• Click an image file in Batch Explorer and the image will be displayed in the 
Image Viewer.

• Drag an image file, page file, or document folder to a different location in 
Batch Explorer.

• Right-click an image file, page file, or document folder to display a context 
sensitive menu for more options.

Image Viewer The Image Viewer is the area where your images are displayed. You can view 
1, 2, 4 or 8 images at a time, or customize the Image Viewer layout.

The title bar contains the batch name and the document number for the 
images displayed in the Image Viewer. 

To move an image:
1. Select an image.
2. Drag the image to the desired location.

To delete an image:
1. Select an image. 
2. Select Edit>Delete. The image will be deleted from the document.

To change the number of images displayed:
1. Select View>Image Viewer Display.
2. Select 1, 2, 4, 8 or Customize. The Image Viewer displays the selected 

layout.

NOTE: If you select Customize the Custom Layout Setup dialog box will 
be displayed allowing you to enter the desired number of columns 
and rows you want to display.
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Image context-sensitive 
menu

When you right-click on an image in the Image Viewer, a menu provides the 
following options:

Selection mode — select Image, Page, or Page Side. 

• If you select Image, you can click on an image in the Image Viewer and just 
the image will be selected.

• If you select Page, you can click on the image and the entire page, front and 
back, black and white and color/grayscale, will be selected.

• If you are scanning multiple images for a side (dual-stream scanning), when 
you select Page Side, and click on a front image, all front images will be 
selected. If you click on a back image, all back images will be selected.

Copy — copies a selected image for pasting to another location.

Copy Image — after using Draw Region to create a region on your image, 
this option allows you to copy this region to another location.

Copy Image to Job Setup — displays the Copy Image to Job Setup dialog 
box, which allows you to import images into the Bar Code window or the OCR 
window to create bar code or OCR zones.

Rotate — rotates the selected image 90, 180 or 270 degrees clockwise.

Split Document — performs a manual document separation, which splits the 
selected document into two documents.

Merge into Previous — appends the selected document to the previous 
document to create one document.

Zoom — increases or decreases the displayed size of an image. 

• Fits Images to window: fits each image to its pane in the Image Viewer, 
regardless of its original size.

• Actual: enlarges an image to its actual physical size.

• Zoom in: enlarges an image by a fixed percentage according to the Zoom 
Step setting.

• Zoom out: reduces an image by a fixed percentage according to the Zoom 
Step setting.

• Zoom Step: accesses the Zoom Step dialog box, which allows you to 
specify a percentage to scale from 15 to 40% in increments of 5%.

Pan All Images to — allows you to move all images to the Top, Bottom, Left, 
Right or Same position.

Pan Step Setup — displays the Pan Step Setup dialog box, which allows you 
to change the pixel settings for the Pan tool.

Hide Front — hides all the front images in the batch. 

Hide Back — hides all the back images in the batch.

Hide Black and White — hides all the black and white images in the batch.

Hide Grayscale — hides all the grayscale images in the batch.

Hide Color — hides all the color images in the batch.
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If you select the Flag, Magnify or Draw Region tool before right-clicking on an 
image, additional options will appear on the menu.

• If the Flag tool is active, the flag options will be displayed. 

- Flag All Selected — places green checkmarks on all the selected 
images in the batch. To select more than one image, hold down the 
Control key while you click on images in the Image Viewer.

- Flag All — places green checkmarks on all the images in the batch.

- Unflag All — removes the green checkmarks from all the images in the 
batch.

- Flag Filtered — takes all the filtered (displayed) images and puts green 
checkmarks on them.

• If the Magnify tool is active, the Magnification Ratio option will be displayed. 
This option displays the Magnification Ratio Setup dialog box, which allows 
you to specify the image size displayed when you use the Magnify tool.

• If the Draw Region tool is active, the options related to this tool will be 
displayed. 

- Apply Region to Document — places the selected region on all the 
images in the document.

- Applies Region to Selected — places the selected region only on the 
images you selected.

- Crop — allows you to remove the area outside the rectangle you created 
using the Draw Region option. A confirmation box will be displayed when 
you select this option.

- Blank — allows you to blank out the area inside the rectangle that you 
created using the Draw Region option. A confirmation box will be 
displayed when you select this option.
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Thumbnail Viewer The Thumbnail Viewer provides thumbnail versions of all the images in the 
batch that is currently open.

To select an image in the Image Viewer:

• Click the thumbnail in the Thumbnail Viewer.

To magnify a thumbnail:

• Left-click on the image and hold it. You can move the magnified area by 
continuing to hold.

Thumbnail Viewer 
context-sensitive menu

When you right-click on a thumbnail image, the following menu options will be 
displayed:

Front or Back — hides all the front or back thumbnails. 

Black and White, Grayscale, or Color — hides all the black and white, 
grayscale, or color thumbnails.

Thumbnail Image Size —- the Thumbnail Image Size Setup dialog box will be 
displayed, allowing you to change the image size.

Index window For your convenience, the Index window on the right side of the Image Viewer 
displays the index data for each batch and document that has indexes defined. 
It is available as a pull-out tab on the right-hand side of the screen. The index 
data can be either shown briefly (hover over the tab stop) or optionally pinned 
to the Image Display to continuously view the index fields for all of your images 
as they are being scanned into Kodak Capture Pro Software. You can use this 
feature to view the index fields for a particular document or the entire batch 
and make any necessary corrections to the content within each field. 

To open the Index window:

• Click the Index window tab on the right side of the Image Viewer. To keep 
the window from closing, click the Pin icon once in the top-right corner of the 
window.

To close the Index window:

• Double-click the Pin icon or click anywhere outside the Index window. If the 
window is pinned open, click the Pin icon once to close it.
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Information window The Information window on the right side of the Image Viewer provides 
statistics on the batch that is currently open. You can pin open the Information 
window to continuously view batch statistics as your images are being 
scanned into Kodak Capture Pro Software.

Information in this window can be displayed for the batch, each document, 
each page, or each image. Image information includes the image sequence 
number, page ID, location on disk, compression, resolution, image size, and 
print string.

To open the Information window:
1. Highlight an image, page or document from the Batch Explorer, or highlight 

an image from the Image Viewer.

2. Click the Information window on the right side of the Image Viewer. To keep 
the window from closing, click the Pin icon once in the top-right corner of 
the window.

To close the Information window:
• Double-click the Pin icon or click anywhere outside the Information window. 

If the window is pinned open, click the Pin icon once to close it.
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Batch Status window The Kodak Capture Pro Batch Status window provides information on batches 
that you are preparing for output from Kodak Capture Pro Software.

Click Control to display the Control menu:

• Show Log — opens a Notepad window and displays the output log.

• Clear log — deletes all the entries in the output log. A confirmation box will 
be displayed to verify your choice.

• About — opens the About Kodak Capture Pro Software dialog box, which 
has a command for viewing all the files in Capture Pro Software.

• Exit — opens the Shutdown Options dialog box, which contains commands 
for exiting Capture Pro Software. Output processing is performed in the 
background and independently of Kodak Capture Pro Software. If you close 
Capture Pro Software, you will be prompted to continue or stop output 
processing.

The Kodak Capture Pro Batch Status window provides the following 
information on each batch that has been outputted or is being outputted: Job 
Name, Batch Name, Submit Time, Status, Progress, and Description.

• Click on the Job Name to Clear All Errors or Clear Selected Errors.

To view the Batch Status window:

• Select Batch>View Batch Output Status.



3-26 A-61635   July 2009 

Changing the Main 
window interface

As pages are scanned, the images appear in all the displayed viewers: the 
Image Viewer, Thumbnail Viewer and/or Batch Explorer. Capture Pro Software 
has two default screen layouts: Classic and Enhanced. 

Kodak Capture Pro Software allows you to customize the layout of the Main 
window by moving the toolbars, viewers, etc. around to suit your own 
preference and hide any unwanted components of the screen.

These options apply to the Image Viewer, the Batch Explorer, the Thumbnail 
Viewer, the Information window, and the Index window. These icons are 
located on the right-top corner of these windows:

The size of the images within the viewers can be set as required. The Image 
Viewer can be set to a fixed size or remain at the Best Fit default which 
displays the images at the best size for the screen. 

The toolbars and image windows can be moved or hidden as desired. Capture 
Pro Software remembers the settings for each job when exiting the job. This 
means different jobs can be displayed the way you want each job displayed. At 
any time you can select View>Layout>Classic (or Enhanced) and reset the 
screen back to the default layout.

If you are using the Classic layout and want to add a window from the 
Enhanced layout, display the View menu and select a window (i.e., Batch 
Explorer, Index window). The additional window will be displayed in the Classic 
layout.

Closes any window. To open the window again, select the 
window you want to display from the View menu.

Pins the window open. To auto-hide the window, click the Pin 
icon.

Auto-hides the window, leaving only the title bar open. To show 
the window, move your cursor over the title bar.

Anchor icons (represented by four vertical dots) are located on 
the left-top corner of the windows. When you select an anchor 
icon and hold the mouse button down, the image anchor is 
released and blue location arrows will be displayed. As you hold 
the mouse button down, you can move the window to a new 
location. When the window is where you want it, release the 
mouse button.
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• Classic layout — displays the Image Viewer only. The number of images 
displayed is selectable from 1, 2. 4, 8 or customizable up to 6 columns by 6 
rows.

• Enhanced Layout — displays the Image Viewer, Thumbnail Viewer and 
Batch Explorer. Each window can be resized as required.
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The Job Setup function allows you to set up all the parameters for a job. A job 
is a configuration that is setup to capture and process a set of documents that 
you want to scan. This chapter provides information and procedures on how to 
select options on the Capture, Index and Output tabs that allow you to setup 
a job to meet your scanning needs. Once a job is setup, you can select the job 
required to scan a batch of documents and output them the way you want.

To setup jobs for use with Kodak Capture Pro Software you need to access the 
Job Setup dialog box. From Job Setup you can select an already-defined Job 
Name and use it as a template to customize the jobs you need to use in your 
environment. 

There are three predefined jobs that come with Kodak Capture Pro Software:

Ready to Scan — allows you to start scanning documents without any setup 
using default settings. This job does not have any indexes defined and places 
all scanned images in a folder structure under the C:\ScanPro directory.

Scan to PDF — similar to Ready to Scan, except when you scan your 
document(s), the first page will be displayed in the Image Viewer and you will   
be prompted for a filename to be entered as index data. The index data is used 
as the filename when you output the documents.

Scan to e-mail — similar to the Scan to PDF except a PDF file will be created 
and will be included as an attachment to an e-mail. When the scan is 
complete, the e-mail software application will be opened with your scanned 
attachment and be ready to send to an e-mail address from your e-mail 
account.

Depending on what you want to do, you can select one of these job setups to 
use as a starting point to setup your job.

Accessing a job 
setup

• Click File>Job Setup. The Job Setup dialog box will be displayed.
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The Job Setup dialog 
box

The following information is common to all tabs on the Job Setup dialog box:

Job name — select a job setup name from the drop-down list. 

The Job Setup dialog box has three tabs: Capture, Index, and Output. 
Detailed information on how to use these tabs can be found in the following 
sections.

• The Capture tab allows you to make General, Batch, Bar Code & OCR, 
Separation and Scanner settings.

- General settings — define the way images will be stored after scanning.

- Batch settings — select the batch settings for the job setup and put 
limits on the number of batch documents and pages.

- Bar Code & OCR settings — create and modify bar code or OCR zones 
and set them up for use.

- Separation settings — set up separations by count, blank page, bar 
code zone, OCR zone, or patch code.

- Scanner settings — create settings for image addressing and printing 
on scanners with those capabilities. Scanner settings such as image 
address, printer, and patch settings should always be done in Job Setup 
and not in Page Setup. Conflicting settings will default to the Job Setup 
settings. 

• The Index tab allows you to define index fields at the batch and document 
levels. The Database Lookup tab allows you to specify the data source, 
define how the lookup is performed and what data is used to populate index 
fields or validate the contents of index fields.

• The Output tab allows you to select the System Output and Advanced 
Processing options for the job setup. 
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Icons

Add: allows you to add a new job setup. 
1. Click the New icon.

2. Enter a name for the new job setup and click Save.

3. Using the Capture, Index and Output tabs set up your 
criteria for this job setup. See the sections that follow for 
detailed information about each of these tabs.

4. Click OK when finished.

NOTE: The last character of the job setup name cannot be a 
period (.).

Rename: allows you to rename the currently selected job setup. 
You cannot rename a job that is open.
1. Select a job setup you want to rename from the Job Name 

drop-down list.

2. Click the Rename icon. 

3. Enter a new name for the job setup and click OK. 

NOTE: The last character of the job setup name cannot be a 
period (.)

Delete: allows you to delete the selected job setup. You cannot 
delete a job setup if it is open, or until all batches are processed 
or deleted.
1. Select a job setup you want to delete from the Job Name 

drop-down list.

2. Click the Delete icon. A confirmation box will be displayed.

3. Click Yes to confirm the deletion.
Export: allows you to export the job setup to a different location 
while still saving it in Capture Pro Software.
1. Select a job setup from the Job Name drop-down list.

2. Click the Export icon. The Export dialog box will be 
displayed.

3. Click Browse to navigate to the destination folder where you 
want the job setup exported.

4. The export name will be filled in with the job name that you 
are exporting. If you want to change that name, enter the 
new name in the Export name field.

NOTE: Directory and Files is the only Export type available at 
this time.

5. Click OK. A message will be displayed to notify you that the 
export was successful.
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After making all your job setup entries, click:

OK — closes the dialog box. All the entries you made are saved.

Cancel — closes the dialog box. Your entries are not saved. 

Apply — saves the changes made in the dialog box. The dialog box remains 
open.

Import: displays the Import Job dialog box, which allows you to 
import a job setup into Kodak Capture Pro Software from 
another location. 
1. Click the Import icon. The Import dialog box will be 

displayed.

2. Click Browse to navigate to an exported job setup you want 
to import. 

3. The import name will be filled in with the job name that you 
are importing. If you want to change that name, enter the 
new name in the Import name field.

NOTE: Directory and Files is the only Import type available 
at this time.

4. Click OK. A message will be displayed to notify you that the 
import was successful.

NOTE: If you are importing a job that uses a different scanner 
model than the one you are using, any scanner-specific 
settings (i.e., printer/counter settings) must be 
reconfigured.
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Job Setup:
Capture tab

The Capture tab allows you to make General, Batch, Bar Code & OCR, 
Separation and Scanner settings.

• General — allows you to define the way images will be stored after 
scanning.

• Batch Settings — allows you to define the batch name format for the job 
setup and put limits on the numbers of batch documents or document 
pages.

• Bar Code & OCR — allows you to create and modify bar code and OCR 
zones and set them up for use.

• Separation — allows you to set up batch and document separations by: 
count, blank page, bar code zone, OCR zone, or patch code.

• Scanner — allows you to create settings for image addressing and printing 
on scanners with those capabilities. Scanner settings such as image 
address, printer, and patch settings should always be done in Job Setup and 
not in Page Setup. Conflicting settings will default to Job Setup settings.
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General settings - 
Capture tab

Select General on the Capture tab to make or change the following settings:

Scanned image location — displays the current location where scanned 
images will be stored for the selected job. If you do not want images scanned 
into the displayed location, click Browse to select another location.

Output image location — allows you to select the final destination for your 
output images. If you do not want the images to go to the displayed location, 
click Browse to select another location.

Description — allows you to enter any important notes as a reminder of the 
settings for this job setup.

Automatically close batch after scanning is finished — if checked, closes 
the batch in Batch Explorer and the Image Viewer when the scanner transport 
stops.

Automatically output when batch is closed — if checked, processes the 
batch to output immediately after the batch is closed. 

Keep batch after output — if checked, saves the batch in the scanned image 
location and also creates the output batch.
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Batch settings — 
Capture tab

Select Batch Settings on the Capture tab to define the batch naming format 
for this job and set limits on the number of batch documents or document 
pages. For example, if you know that all of your batches contain 100 
documents, setting limits will alert you if your batch does not match the number 
of documents you are expecting in a batch.

• Batch naming — make the following selections:

- Batch name — select a batch name from the drop-down list. The 
Standard batch name is “BatchXXX”. If you want to change your batch 
name to “Invoices” and the date, you would click Setup to open the 
Standard Setup dialog box. From this dialog box, you can make these 
settings. See the next section “Changing the Batch naming settings” for 
procedures.

- Next batch number — enter the desired next batch number.

• Limits - Documents per Batch — make the following selections:

- Numbers: enter or select the minimum and maximum number of 
documents that you want to allow in a batch.

- Warn: enter a document number to serve as a warning that the batch is 
approaching its maximum number of documents. When scanning 
exceeds this limit (by one or two documents), scanning will stop.

• Limits - Pages per Document — make the following settings:

- Numbers: enter or select the minimum and maximum number of pages 
that you want to allow in a document.

- Warn: enter a page number to serve as a warning that the document is 
approaching its maximum number of pages. When scanning exceeds this 
limit (by one or two pages), scanning will stop.

• Reset document ID: check this box to reset the document counter to 0.



A-61635  July 2009 4-9

Changing the Batch naming 
settings

When you select Setup from the Batch naming box, the Standard Setup dialog 
box will be displayed where you can add or delete values to the batch name.

The Predefined values list provides values that you can select to add to the 
text formula currently in use. You can add any number of items to the batch 
name by selecting the item you want from the Predefined values list.

For example, if you want your batch to be labeled with the User name, date 
and time you would enter the following: 

User name, Date (dd), Date (yy), Time24 (HHmmss) 
The result would be: John Smith0409115503.

To add a value:

1. Select the value you want to add from the Predefined values list.

2. Click Add Item. The item will be added to the formula.

NOTE: When specifying a path name, the limit is 248 characters in length. 

3. If you want to add more values, repeat Steps 1 and 2.

NOTE: The Add leading zeros and Number length fields become available 
when you select the Batch counter value.

4. If applicable, click Add leading zeros to add zeroes the left side of your 
sequence number. 

5. If applicable, enter a value in the Number length field to limit the number of 
Predefined values allowed in the text formula. 

6. Click OK when finished.

NOTES:

• Clicking Delete Item will remove the last predefined value from the text 
formula.

• Clicking Delete Formula will remove the text formula.

Bar Code & OCR settings 
— Capture tab

See Chapter 6, Bar Code and OCR Setup for information on configuring your 
bar code and OCR settings.
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Separation settings — 
Capture tab

The Separation option on the Capture tab allows you to identify how you want 
to separate batches and documents for this job. There are several ways to add 
separators to your batches. The following list provides the options you can use 
to create separation settings in Kodak Capture Pro Software:

• with a bar code zone (see Chapter 6, Bar Code and OCR Setup)
• with an OCR zone (see Chapter 6, Bar Code and OCR Setup)
• with Patch codes 2, 3 or T (see Chapter 5, Patch Code Setup)

• by automatically counting pages in a document(s) in a batch (set this option 
up using the By Count option)

• with a blank page (set this option up using the By Blank Page option) 

• by selecting Document>New or Batch>Next
• by pressing Enter during scanning
• by right-clicking on a page file in the Batch Explorer and clicking Split

The sections that follow provide information and procedures for using Kodak 
Capture Pro Software to automatically separate documents or batches by 
counting pages and how to use blank page separation.

By Count The By Count separation setting on the Capture tab allows you to enter the 
number of documents that each batch will contain, and the number of pages 
each document will contain. 

1. Choose Batch Level and/or Document Level.

2. Click Every at the Batch Level and enter the number of documents that 
the batch must contain before a new batch is created.

3. Click Every at the Document Level and enter the number of pages that a 
document must contain before a new document is created.
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By Blank page When scanning images, you can insert blank pages to serve as separators. 
Kodak Capture Pro Software can recognize blank pages and use them to start 
new batches, start new documents, or create attachments to documents.

To use this method enable the By blank page option and select the desired 
settings.

When you are simultaneously scanning black and white and color/grayscale 
images, Capture Pro Software can use either black and white or the color 
image to determine a blank page. When the software detects a blank page, all 
four images (Color front; Color back; Black and White front; and Black and 
White back) of the page are either deleted or attached to the new/current 
document, depending on the settings you created.

The size (in bytes) of both the front and rear images of a page must fall below 
the entered byte value for Capture Pro Software to recognize the page as 
blank. If the software does not recognize a blank page, it will ignore it as a 
separator. 

NOTE: It is recommended that you test these values to ensure that the 
software will detect your blank pages as a separator. See the next 
section “Testing your settings” for procedures.

Blank Page Image Separator when — activates blank page separation.

• Image size (byte) is below — creates blank page separations based on the 
size (in bytes) of the blank page image. Specify the maximum amount of 
data (bytes) an image can contain and still be considered blank for each 
image type (Black & White, Color/Grayscale) that you will be scanning. 

The image size is checked against the raw image coming from the scanner 
before operations are performed. 

- Black and White: enter the maximum image size in bytes for black and 
white. By default, 3000 bytes is suggested for black and white images.

- Color/Grayscale: enter the maximum image size in bytes for color or 
grayscale. The maximum image size that can be specified is 1,000,000 
bytes (1 MB) to allow for blank page separation when color scanning. 
100,000 bytes is recommended.
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• Image content (%) is below — creates blank page separations based on 
the percentage of image content in the blank page image.

NOTE: If the pages you will scan are different sizes, a small page may fall 
below your blank image byte count even though it contains data. 
In this case, you may prefer to describe a blank image by 
specifying % content rather than byte size.

- Black & White: enter the percentage limit for black and white images.

- Color/Grayscale: enter the percentage limit for color and grayscale 
images.

Test — opens the Test Image dialog box, which allows you to scan and test 
the blank page that is being used as a separator that will be considered blank 
when compared against the Image content (%) settings. Use this option to 
verify that the software considers the page to be blank. See the next section 
“Testing your settings” for more information.

What to do if a page is blank — select one of the options as the next step 
after the software recognizes a blank page separation. 
• Create a new batch — creates a new batch when a blank page is detected. 
• Create a new document — creates a new document when a blank page is 

detected.
• Next page stays in current document — deletes the blank page. 
• Delete page — when checked, the blank page will not be included in the 

batch or document that you are separating on. 

Testing your settings 1. Place a document in the scanner that is representative of the document 
you want to test for blank page separation.

2. Click Test to display the Test Image dialog box. 

 The results will be displayed in the Test result box.
• The image is: indicates if the image is Blank or Not Blank.
• Image size is - (bytes): the size of the test image in bytes.
• Content is - %: the percentage of content in the test image.

3. Evaluate the values displayed in the Image size is - (bytes) and/or 
Content is - % test result area and click Close.

4. Based on the results, readjust your entered values as needed and click 
OK.
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Job Setup:
Index tab

Indexing is a sophisticated feature that allows you to add data processing 
functions to your scanning, capturing and outputting of images at the 
document and batch level.

You can set up indexing formulas that check the accuracy of metadata 
contained in OCR zones and bar code zones. If OCR or barcode reading 
misinterprets data, the indexing formula can catch the errors and stop the 
scan. 

You can setup indexing formulas that output your images to different locations 
based on metadata.

• For information on creating input formats, see “Input formats” later in this 
section.

• For information on creating output formats, see “Output formats” later in this 
section.

The Index tab on the Job Setup dialog box allows you to define an index field 
at the Batch level and Document level. Index fields are setup the same way 
for Batch level and Document level.

Following are descriptions of the fields on the Index tab: 

Action when audit fails — select the action you want the scanner to take 
when an audit fails. 

• Continue scanning: keep scanning even when the audit finds illegal index 
values. 

• Stop scanning: stop scanning and automatically enter Index Editing mode 
when the audit finds illegal index values. 

Bypass audit during navigation — when checked, disables the audit 
function when navigating through documents in the Batch Explorer. The term 
"audit" refers to the verification system that verifies all index values comply 
with the input/output format.
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The Indexes field displays the values that are set up for each index: Name, 
Type, Default Value, Input Format, Output Format, Read-only, and Hidden. 
You can edit, delete, move a value up or down in the list or add a new value by 
using the following buttons:

• Add: opens the Document Add Index Field dialog box to create a new index 
field in a document or the Batch Add Index Field dialog box to create a new 
field in a batch.

• Edit: opens the Document Edit Index Field dialog box to modify an index 
field in a document or the Batch Edit Index Field dialog box to modify an 
index field in a batch.

• Delete: click to remove the selected index field. 

• Move up: click to move the selected index field up one position in the index 
list. 

• Move down: click to move the selected index field down one position in the 
index list.

Adding a document 
index field

To add a document index field:

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select a job from the Job Name drop-down list and open the Index tab.

3. Open the Document tab.

4. Click Add. The Document Add Index Field dialog box will be displayed.

5. Enter the name of your index in the Label field. 

6. Enter any notes or comments in the Description field.



A-61635  July 2009 4-15

7. Select either Single Value, Drop-down list or an index API (if available) 
from the Type field. Single Value allows to you enter any value. Drop-
down list allows you to set up a fixed list of values to choose from (e.g., if 
you want to provide a list of countries to choose from). 

NOTE: If you created your own index API it will appear in the Type drop-
down list. When you select an index API, the Setup button will 
become available. Click the Setup button to make any 
configuration changes. 

8. If you selected Single Value, you can check Read only to make this index 
non-writable. This protects crucial information from being deleted by 
operators.

9. Check Required to make this index a must-have check item.

10. If you selected Single Value, you can check Hidden to hide this index 
from users. This protects sensitive information.

11. Enter a number to define the shortest valid length of the index field in the 
Minimum index field length field. 

12. Check the Check field during scanning box if you want the system to 
check index fields when scanning pages. 

13. Enter a predefined value in the Default value field or click Setup to display 
the Default Value Setup dialog box. 

NOTE: If you created a bar code or OCR zone, it will be displayed in the 
Predefined values list (e.g., BC_[zonename] or OCR_[zonename]. 
To use a bar code/OCR zone for an Index field, you must assign 
the appropriate BC_[zonename]/OCR_[zonename] as a default 
value for the Index field. You may need to scroll to the bottom of 
the Predefined value list to see the Bar code/OCR index fields.
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Use the Default Value Setup dialog box to create or revise a formula for the 
default value of the index field. 

• Select a predefined value from the Predefined Values list. The Default 
Value Formula (if any) will be displayed on the right side of the box.

• Click Add Item.

NOTE: Delete Item removes the last predefined value that was added 
to the Default Value Formula; Delete Formula removes the 
entire Default Value Formula. 

• Click OK when finished. The revised formula will be populated into the 
Default Value text box. 

14. Enter your input format. See the section entitled “Input formats” later in this 
chapter for more information. 

15. Enter your output format. See the section entitled “Output formats” later in 
this chapter for more information. 

16. If you want to define Substitute Characters, click Setup to define 
character pairs for automatic substitution. The Substitute Characters Setup 
dialog box will be displayed. 

• Original column — lists the old characters to be replaced. Select an 
original character from the drop-down list at the bottom of the column. 
Select <Space>, <Linefeed> or <Tab>. An original character can appear 
only once in the Original column.

• Substitute column — lists the new characters to be put in. Select a 
substitute character from the drop-down list at the bottom of the column. 
Select <Space>, <Linefeed>, <Tab> or <Replace>. A substitute 
character may appear more than once in the Substitute column.

• Add — click to add the original and substitute character pair that you 
selected from the two drop-down lists. If you only selected an original 
character, Kodak Capture Pro Software will default to <Replace> as the 
substitute character. 

• Delete — deletes the highlighted original and substitute character pair 
from the Original and Substitute columns.
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17. If you want to define a value list for the index field, click Setup next to the 
List box. The List Setup dialog box will be displayed. 

• Enter the desired value in the text box under the Value column.
• Enter a description of the value in the text box under the Description 

column.
• Click Add to add the value and description pair that you entered in the 

two text fields. If you did not create a description, that row in the 
Description column will be blank. 
NOTE: Click Delete if you want to remove a value.

• Check Allow any value if you want to set no limitation on index values. 

• Select an Indexing action from the drop-down list: Use value only, 
Use description only or Use value and description.

• Click OK when finished and return to the Document Add Index Field 
dialog box.

18. Click OK on the Document Add Index Field dialog box. The new document 
index information will be displayed in the table in the Document tab.

19. Click OK to save and exit the Job Setup dialog box. 
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Editing a document 
index field

To edit a document index field:

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select a job from the Job Name drop-down list and open the Index tab.

3. Open the Document tab.

4. Click Edit. The Document Edit Index Field dialog box will be displayed.

5. Change the information in the dialog box as desired and click OK. 
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Adding a batch index 
field

To add a batch index field:

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select a job from the Job Name drop-down list and open the Index tab.

3. Open the Batch tab. 

4. Click Add. The Batch Add Index Field dialog box will be displayed.

5. Complete the information in the dialog box and click OK. See the section 
entitled, “Adding a document index field” earlier in this chapter for detailed 
field descriptions.

6. Click OK to save and exit the Job Setup dialog box.
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Input formats An Input Format is a text expression used to audit the user input for a 
particular index field. Its purpose is to prevent incorrect data from being 
entered into index fields. The syntax of the input format can be one or 
combination of the following formats:
• Text formats
• Number formats
• Time formats 
• Fixed string formats

Input Text formats #
#<maxlength>
#<minlength, maxlength>

# — used to represent a single character of a specific type. # may be one of 
the following character types:

9: valid input character set includes '0', '1', ..., '9'
Z: valid input character set includes 'A', 'B', ..., 'Z'
z: valid input character set includes 'a', 'b', ..., 'z'
A: valid input character set includes all characters in Z and z type
C: valid input character set includes all characters in Z and 9 type
c: valid input character set includes all characters in z and 9 type
X: valid input character set includes all characters in Z, z and 9 type
?: valid input character set includes any characters

Examples
999999
Description — 6 numeric characters

Valid input examples
123456
888888

Invalid input examples
ABCDEF wrong character type
1234567 too long
12345 too short

ZZZ999?
Description — 7 characters, first three characters are alphabetic letters, next 
three characters are numeric, last character is any character.

Valid input examples
BAT001%
BOX123a

Invalid input examples
BAT12b3 sixth character must be a numeric
Bat123a second and third letters must be upper case alphabetic

characters
BAT12345 too long
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#<maxlength> — used to represent a variable length text value that has no 
minimum length but may have a maximum length.

• If maxlength is 0, there is no limitation on the length of the input value.

• If maxlength is greater than 0, the length of the input value length must be 
less than or equal to maxlength.

The maxlength may not be less than 0.

Examples
A<6>
Description — a string that may contain 6 or less alphabetic characters.

Valid input examples
A
ABCDEF

Invalid input examples
ABC123 last three characters must be alphabetic characters
ABCDEFG too long

?<0>
Description – any text value.

#<minlength, maxlength> — used to represent a fixed or variable length 
input value that may have a minimum and maximum length.

• If minlength is 0, the input string may be empty.

• If minlength is greater than 0, the input value length must greater than or 
equal to minlength.

• The minlength may not be less than 0.

• If minlength is equal to maxlength, the input value must have the specified 
number of characters.

Examples
X<2,10>
Description — an input value that contains 2 to 10, upper or lower case 
alphabetic or numeric characters.

Valid input examples
Batch0001
1234abcABC
A1
Invalid input examples
Batch-001 The ‘-‘ character is not a valid ‘X’ character
A too short
1234abcdABCD too long
AB Inc space character is not a valid ‘X’ character
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?<3,0>
Description – a string that contains 3 or more characters of any type

Valid input examples

ABC
+%=
ABC Company
jsmith@ABC.com

Invalid input examples
A1 too short

A<4,4>
Description — a string of exactly 4 alphabetic characters. The same format as 
AAAA.

9<0,3>
Description — a string of 3 or less numeric characters. String may be empty. 

A<3,2>
Description — invalid input format, maxlength must be greater or equal to 
minlength if maxlength is greater than 0.

Input Number formats #
#(min, max)
#(min, max]
#[min, max}
#[min, max]

# — used to represent one of the following number types:

i : integer number that may be positive or negative, does not contain a decimal 
point
n : any number, positive or negative and may contain a decimal point.

The value range or precision of the number is limited by the operating system.

The valid number range is typically:

i : -2,147,483,648 to 2,147,483,647
n : 1.7 E +/- 308 ( 15 digits )

The min and max values define the range of the number value.

The value of min and max must be consistent with the number type. For 
example if the number type is i, both min and max must be a valid integer 
number.

The character * may be used in place of min or max and represents an infinite 
value or no limit.

The max value must be greater or equal to the min value.

( : input value must be greater than min.
) : input value must be less than max.
[ : input value must be greater than or equal to min.
] : input value must be less than or equal to max.
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Examples

i
Description — any integer number.

Valid input examples

123
-456

Invalid input examples
123.456 must be integer. Decimal values are not allowed
-123. integer values cannot have a decimal point

n 
Description – any integer or decimal number

Valid input examples
123
123.456
-123.

#(min, max) — used to specify a value that is greater than min and less than 
max.

Examples
i(-100, 100)
Description — any integer number greater than –100 and less than 100

Valid input examples
-99
0
99

Invalid input examples
-100 too small, must be greater than –100
-99.9 must be an integer (decimal not allowed)
100 too large, must be less than 100

#(min, max] — used to specify a value that is greater than min and less than 
or equal to max.

Examples
i(-100, 100]
Description — any integer number greater than –100 and less than or equal 
to 100

Valid input examples
-99
0
100

Invalid input examples
-100 too small, must be greater than –100
-99.9 must be an integer (decimal not allowed)
101 too large, must be less than or equal to 100
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#[min, max) — used to specify a value that is greater than or equal to min 
and less than max.

Examples
n[-100, 100)
Description — any number greater than or equal to –100 and less than 100

Valid input examples
-100
-99.9
99.9999

Invalid input examples
-100.1 too small, must be greater than –100
100 too large, must be less than 100

#[min, max] — used to specify a value that is greater than or equal to min 
and less than or equal to max.

Examples
n[-100, 100]
Description — any integer number greater than or equal to –100 and less 
than or equal to 100

Valid input examples
-100
0
100

Invalid input examples
-100.1 too small, must be greater or equal to –100
100.001 too large, must be less than or equal to 100

i[100, *)
Description — any integer number greater than or equal to 100

Valid input examples
100
1000

Invalid input examples
99 too small, must be greater than or equal to 100
100.5 integer values cannot have a decimal point

i(-1.0, +1.0)
Description — this is an invalid input format because the min and max are not 
integer values as the “i” specifies.

n(+1.0, -1.0)
Description — this is an invalid input format because max is less than min.
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Input time formats T<timeformat> 

timeformat is a text string expression of the date/time value. The syntax can be 
one or combination of the following elements:

The following date/time elements cannot be repeated in the timeformat. For 
example, if you have selected yyyy for year date format, you cannot use yy or 
another yyyy in the timeformat. This limitation includes:
yyyy and yy
dd and DDD
HH and hh
HH, TT, T, tt and t

Examples

T<yyyyMMdd>
Description — a full date.

Valid input examples
20051025
19000101

Invalid input examples
2005/10/25 unexpected character /
20051032 invalid date
20050229 invalid date (because the year 2005 was not a leap year)
00990101 date is earlier than 1000

yyyy year (1000-9999)
yy year (00-99, for 00-79, it means 2000-2079, for 80-99, it means 

1980-1999)
MM month (01-12)
dd day of month (00-31, validate date when year and month are available)
DDD day of year (001-366, validate date when year and month are available)
HH hour (00-23)
hh hour (01-12)
mm minute (00-59)
ss second (00-59)
TT AM/PM
T A/P
tt am/pm
t a/p
"text" text is a fixed text string.
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T<MMdd>
Description — a date without a year specified.

Valid input examples
1201
1231
0229 

Invalid input examples
0001 invalid month
0230 invalid date of February regardless if it is a leap year
ABCDEF invalid text

T<HH":"mm":"ss>
Description — a time with : as separator. 

Valid input examples
23:59:59
00:00:00

Invalid input examples
99:59:00 invalid hour
120000 no separator

T<hhmmsst>
Description — a full time.

Valid input examples
010000a
120000p

Invalid input examples
010000A A should be lower case
000000a invalid time
1355101 invalid hour must be 00-12 

T<HHmmssTT>
Description — this is an invalid input format because HH represents 00 to 23 
hours and TT represents AM/PM which is not valid with a 24-hour time string.

T<yyyyMMyyyy>
Description — this is an invalid input format for yyyy because it was used more 
than once in a timeformat.
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Input fixed string formats “text”
text is any text string. Because the start and end of the text string is defined by 
the character “ (double quote), the double quote character is not allowed in the 
text string. A text string format is normally used in combination with other input 
formats.

Examples

999”-”99”-”999
Description — fixed string (to define a United States Social Security number) 

"ID"
Description — fixed string.

Valid input examples
ID

Invalid input examples
XX does not match text in format. Input must be: ID

“Text”ABC””
Description — this is an invalid input format because it includes two extra “ 
characters in the format.

Combination input 
formats

An Input Format can consist of multiple formats that are used in combination. 
To use multiple formats to define an Input Format connect the format 
expressions together with or without a blank space.

No format expression may follow format that is of variable length. For example: 
A<1,0>”-Comment” is not valid because A<1,0> may be any length. The 
format: “Comment-“A<1,0> is valid because the variable length format is at the 
end of the combination input format.

Following are valid and invalid combination formats.

Examples

"ID"999999
Description — combined formats: "ID" and 999999.

Valid input examples
ID123456

Invalid input examples
IDabcdef the letters abcdef must be numbers

id123456 the first two letters id do not match format which is ID

“DATE”T<yyyyMMdd>
Description — combined formats “DATE” and T<yyyyMMdd>

T<“DATE”yyyyMMdd> is equivalent to the above format.

Valid input example

DATE20051025
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Invalid input examples
n?<0>
Description — this is an invalid input format for the number specified. n is a 
variable length and no additional format can follow it.

A<2,3>”XX”
Description — this is an invalid input format because A<2,3> specified a 
variable length and no additional format can follow it.

A<3,3>”XX”
Description — combined with formats: A<3,3> and “XX”.

Valid input example

XYZXX

Invalid input examples
XXXXXX unexpected X at the end of the text string.

20051025 the text DATE must proceed the date

DATE20051032 October does not have 32 days

XXXXXXX too long, extra X at end of string
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Index Default value 
specification

Default value expression is a text expression to set the default value for a 
particular index field. In default value expression, you need to define the 
default value by using one or more predefined tags (i.e., system, barcode/OCR 
value) or a fixed string. You can also define multiple options of the default 
value by connecting tags with the OR keyword. 

Tags
<tagname>
<tagname:transformexpression> 

tagname is a pre-defined system, OCR or barcode zone data expression. 
System data expressions include date, time, Station ID and name, Job and 
User name, batch and workgroup path, document and page ID and Last Value.

transformexpression is used to transform the format of the system or 
barcode/OCR value. For example the date is expressed as MMddyy, the 
transform expression may change the format to MM/dd/yyyy. See the next 
section for a description of transform expression.

Fixed string formats "text"
text is a fixed text string. The string delimiter character " (double quote) is not 
allowed in the format. A fixed text string format is normally used in combination 
with other formats. 

Using multiple tags A default value may include more than one tag expression used in 
combination. For example you may want the Default value to include the date, 
time and Station ID separated by a dash. To do this concatenate them 
together.

For example:
<sys.date:ddMMyy>"-"<sys.time:hhmmss> "-“ <sys.stationid>

Using the OR keyword The OR keyword may also be included in the default value expression. This 
may be useful when a value may not always be present. You may want to set 
the default value to the value of a barcode that appears on the document.

For example:
 <barcode.UPI ID Number>

If no barcode is found on the document, the index field will be empty. The OR 
keyword can be used to provide an alternate value.

For example:
<barcode.UPI ID Number> OR “Barcode not found on document:” 
<app.documentid>

As many expressions as needed may be OR’d 

Default Value Option #1 OR Default Value Option #2 OR ... OR Default Value 
Option #n

The system will check the Default Value Option # one by one from left to right, 
and use the first valid data to initialize the index data.
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Available Tags — the following displays the available default value tags:

NOTE: Barcode/OCR zones will be displayed at the bottom of the default 
value list.

Default value using 
LASTVALUE

When lastvalue is selected as the default value, Capture Pro Software 
automatically uses the last assigned value for an index field from the previous 
document (for document indexes) or previous batch (for batch indexes) 
whenever a new document or batch is created. This is useful, for example, in a 
backlog application, when you scan folders of documents with the same date. 
When you start scanning into a new batch, and no index value has yet to be 
assigned, enter the date once and it remains the same for every new 
document after that until you change it. 

lastvalue is also very useful when performing bar code indexing but not every 
document scanned will have a bar code attached to it. For example, a default 
value expression of:

<barcode.Patient ID> OR <app.lastvalue>

means that when a new document is scanned, assign the index field value to 
the value of the bar code zone "Patient ID" <barcode.Patient ID>. However, if 
the document did not have a bar code on it, assign the index field instead to 
the value of the previous document OR <app.lastvalue>.
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Transform Expressions A Transform Expression is a text expression to format or transform the data of 
a particular field into a default or output value. Transform Expressions are used 
to define default values and output format for an index field. 

Default value specification: when a new batch or document is created, the 
index field will be populated with a value based on the default value 
specification. The default value specification is entered on the Index tab and 
takes the form <tagname> or <tagname:transform expression>. The transform 
expression is described below.

Examples: 
<sys.date:ddMMyy>
<sys.stationid:[1,5]>

Output format: when a batch is output, the index data for the batch and for 
each document in the batch will be reformatted based on the output format. 
For instance, a date index with a value of MMddyy can be reformatted to: 
MM/dd/yyyy.

The output format is entered on the Index tab and takes the form: 
transform expression.

Examples:
ddMMyy
[1, 5]

The syntax can be one or a combination of the following formats:

• Text formats
• Number formats
• Time formats
• Fixed string formats

Transform text formats [start]
[start, end]
[index, ‘delimiter’]
[start; len]

These formats are used to extract a sub-string from the original index value.

[start] — used to extract a sub-string starting at the position start to the end of 
the original value.

• If start is a positive number, the start position will be counted from the 
beginning of the original value.

• If start is a negative number, the start position will be counted from the end 
of the original value.

• If start is 0 or *, the start position will be the beginning of the original value.
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Examples
[5]
Description — get sub-string from the 5th character to the end of the original 
value.

“ABCDEFGHIJKL”  “EFGHIJKL”

“1234567890”  “567890”

“1234”  “”

[*]
Description — get full string

“ABCEDFG”  “ABCDEFG”

“1234567”  “1234567”

[start, end] — used to extract a sub-string starting at the position start and 
ending at the position end of the original value.

• If end is a positive number, the end position will be counted from the 
beginning of the original value.

• If end is a negative number, the end position will be counted from the end of 
the original value.

• If end is 0 or *, the end position will be the end the original value.

• If the start position is after the end position, the sub-string will have the 
reverse order of the original value.

Examples
[1, 2]
Description — get sub-string from the 1st character to the 2nd character of the 
original value.

“ABCDEFG”  “AB”

“123456”  “12”

[-4, -1]
Description — get sub-string from the 4th from the last character to the last 
character of the original value.

“ABCDEFGHIJK”  “HIJK”

“1234567890”  “7890”

[*, 5]
Description — get sub-string from the 1st character to the 5th character of the 
original value.

“ABCDEFGHIJK”  “ABCDE”

[5,2]
Description — get sub-string from the 5th to the 2nd character in reverse order 
of the original value.

“ABCDEFGHIJK”  “EDCB”

“1234567890”  “5432”
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[2, -2]
Description — get sub-string from the 2nd character to the 2nd from the last 
character of the original value.

“ABCDEFGHIJ”  “BCDEFGHI”

“1234567890”  “23456789”

“AB”  “BA”

“A”  “A”

[index, ‘delimiter’] — used to extract the element at the position specified by 
index where each element in the index data is separated by the character 
delimiter. The first element is index 1.

NOTE: This transform expression is especially useful when assigning data 
elements in a PDF417 bar code to different index fields. It is also 
useful when assigning different lines of multi-line OCR results to 
different index fields. The delimited produced by multi-line OCR is the 
carat (^) character.

Examples
[2, ‘^’]
Description — get the 2nd element in the multi-line OCR where elements are 
separated by the character ‘^’

“John Smith^123 Main Street^Some City”  “123 Main Street”

[3, ‘*’]
Description — get the 3rd element from the PDF417 barcode where elements 
are separated by the character ‘*’

“John Smith*123 Main Street*Some City”  “Some City”

[start; len] – used to extract a sub-string for the position start for len 
characters.

Examples
[2;3]
Description — get sub-string from 2nd character with a length of 3 characters.

“ABCDEFGHIJ”  “BCD”

“1234567890”  “234”

“AB”  “B”

“A”  “”
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Transform number 
formats

#<width, fracwidth>
#<width, fracwidth, padding>
#<textformats, width, fracwidth>
#<textformats, width, fracwidth, padding>
0width

# can be one of the following characters to define the desired number type.
n: generic number
N: generic number with sign
p: percentage number
P: percentage number with sign
c: currency number
C: currency number with sign

The value range or precision of the number is limited by the operating system. 
The valid number range is 1.7E ±308 (15 digits).

#<width, fracwidth> — used to format a number that has at most, width 
number of characters and at most, fracwidth characters after the decimal.

width defines the total number of digits to be included in the output string.

• If width is a positive number, the output text will be right-aligned with the 
padding character (if any) on the left.

• If width is a negative number, the output text will be left-aligned with the 
padding character (if any) on the right.

fracwidth defines the number of digits to be displayed to the right of the 
decimal point.

The number 0 is used to show no decimal point.

The * character is used to show a default of 6 digits to the right of the decimal 
point.

Examples
n<20,2>
Description — a generic number with a maximum width of 20 characters and 2 
digits after the decimal point. The string will be right aligned.
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Examples
 “324.5”  “ 324.50”
“abcd”  “ 0.00”

p<-20, 2>
Description — a number expressed as a percentage with a total width of 20 
characters and 2 digits after the decimal point. The string will be left aligned.

Examples
 “0.12abc”  “12.00% “
“-43” ”-4300.00% “

c<20, 0>
Description — a number expressed as currency with a total width of 20 
characters and no decimal point. The string will be right aligned.

Examples
 “12345.6”  “ 12,346”
“-12345.6”  “ –12,346”

C<20, 2>
Description — a number expressed as signed currency with a total of 20 
characters and 2 digits after the decimal point. The string will be right aligned.

Examples
 “12345.6”  “ +12,345.60”
“-12345.6”  “ –12,345.60”
“abc”  “ +0.00”
“-0.001”  “ –0.00”
“-0.00”  “ +0.00”

#<width, fracwidth, padding> — used to format a number that will be padded 
with the padding character, to the specified width, including fracwidth 
characters after the decimal point. 

padding defines the character to fill the space if the formatted text is less that 
the width defined.

Example
P<20, 3, ‘#’>
Description — a number expressed as a signed percentage with a total width 
of 20 characters, 3 digits after the decimal point and padded with the character 
‘#’.

Examples
 “0.12abc”  “############+12.0000%”
“-43”  “##########-4300.000%”

#<textformats, width, fracwidth> — used to format a number that is 
extracted from a string using textformats.

textformats specifies how to extract the number from the original index string. 
See the Output formats section.

Example
N<[2], 20, 3>
Description — a signed number with a total width of 20 characters and 3 digits 
after the decimal point. The number will be extracted starting at the 2nd 
character in the original string.
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Examples
“A12345.6”  ” +12345.600”
“-12345.6”  “ +12345.600”
“TT9000”  “ +0.000”
“—9999”  “ –9999.000”

N<[2, ‘^’], 20, 3>
Description — a signed number with a total of 20 characters and 3 digits after 
the decimal point. The number will be extracted from the 2 element in the 
string, where the elements are separated by the character ‘^’.

Example
“12345.6^45678.9”  “ +45678.900”

#<textformats, width, fracwidth, padding> — used to format a number that 
is extracted from a string using textformats and padded with the specified 
character.

This format is a extension of the format #<textformats, width, fracwidth> where 
the output string will be padded with the specified character.

0width — used to zero-fill a number to the minimum specified width.

Examples
 010 
Description — a zero-filled number with a total width of 10 characters.

Examples

“123”  “0000000123”
“0”  “0000000000”

03
Description — a zero-filled number with a total width of 3 characters.

Example
“1”  “001”
“1234”  “1234”
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Transform time formats #

# — may be one or any combination of the following formats:

When using time formats, you must specify an Input Time format to define the 
contents of the string that is to be formatted for output.

Examples
ddMMyyyy
Description — a date in day, month, year format.

Examples
Input Format: T<yyyyMMdd> the string “20051026”  “26102005”
Input Format: T<yyyyMM> the string “102005”  “102005”

yyyy year (1900-2099)
yy year (00-99)
y year
MM month (01-12)
M month (1-12)
dd day of month (01-31)
d day of month (1-31)
D day of week (1: Sunday, 2: Monday, etc.)
DDD day of year (001-365)
HH hour (00-23)
H hour (0-23)
hh hour (01-12)
h hour (1-12)
mm minute (00-59)
m minute (0-59)
ss second (00-59)
s second (0-59)
TT AM/PM
T A/P
tt am/pm
t a/p
ww week of year (01-53)
w week of year (1-53)
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Fixed string formats text”

text is any text string. Because the start and end of the text string is defined by 
the character “ (double quote), the double quote character is not allowed in the 
text string. A text string format is normally used in combination with other input 
formats.

Examples
"ID-"[*]"-XX"
Description — output fixed text string of "ID".

Examples 
"20051026" ==> "ID-20051026-XX"

Combining Transform 
formats

A Transform Expression can consist of multiple formats that are used in 
combination. To use multiple formats to define a Transform Expression simply 
connect the format expressions together with or without a blank space.

Examples
"Revenue"c<20, 2>
Description — combination with formats "Revenue" and c<20, 2>.

Examples
"123456" ==> "Revenue 123,456.00"

yyyy"/"MM"/"dd"-"HH":"mm":"ss
Description — combined with formats: yyyy, "/", MM, "/", dd, "-", HH, ":", mm, ":" 
and ss.

Examples
"20051026080405PM" ==> "2005/10/26-20:04:05"
Input Format: T<yyyyMMddhhmmssTT>

Output formats An Output Format is a text expression to format the data of a particular index 
field into an output value. Transform Expressions are used to define the output 
format for an index field. 

Output format: when a batch is output, the index data for the batch and for 
each document in the batch will be reformatted based on the output format. 
For instance, a date index with a value of MMddyy can be reformatted to: 
MM/dd/yyyy.

The syntax can be one or a combination of the following formats:

• Text formats — see Transform Expression, Text formats

• Number formats — see Transform Expression, Number formats

• Time formats — see Transform Expression, Time formats

• Fixed string formats — see Transform Expression, Fixed string formats

• Combination formats — see Transform Expression, Combining Transform 
formats
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Index tab — Database 
Lookup

Database Lookup can be used to populate or validate batch and document 
index fields from ODBC (Open Database Connectivity) compliant data 
sources. A configuration wizard is used to specify the data source, define how 
the lookup is performed and what data is used to populate index files or 
validate the contents of index fields. A Job Setup may contain more than one 
Lookup. Each Lookup may be to a different data source and may be used to 
populate or validate selected index fields. Lookups may occur during scanning 
when the index value used for the Lookup is a result of a barcode reader or an 
OCR action. Each Lookup takes the form: SELECT <table column 1>, <table 
column 2>, ... <table column n> FROM <data source> WHERE <table column 
x> = <index field value>.

Configuring Database 
Lookup

Configuring Database Lookup starts with defining the batch and document 
index fields that will be used by the Lookup. Database Lookups are configured 
for each job.

NOTE: Defining of index fields in Job Setup has not changed from previous 
versions of Kodak Capture Pro Software.

To add or edit a new lookup:

1. Click File>Job Setup. The Job Setup dialog box will be displayed.

2. Select a job setup from the Job Name drop-down list. The settings for the 
job setup will be displayed.

3. Select the Index tab.

4. Select the Database Lookup tab. The Lookups table will be displayed with 
the following fields: Name, Input Index Field, Output Index Field (Batch) 
and Output Index Field (Document) for each Lookup. 
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5. Click Add. The Database Lookup wizard will be displayed.

6. Enter the name of your Lookup in the Lookup name field.

7. Click Browse to open the Select Data Source dialog box.

• Select an existing File Data Source or Machine Data Source, or click 
New to create a new data source. Depending on the type of data source 
you have selected, you will be prompted for additional information. 

• Click OK after all required information has been entered.

8. Select the table or file from the Database table drop-down list that contains 
the data that will be used to populate or validate the index fields.
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9. Click Next to define how you want to do the data lookup.

10. Select Validate index fields from Lookup results if you want to verify 
one or more index field values match data in your data source. 

11. Select Populate index fields from Lookup results if you want to fill in 
one or more index fields from the Lookup.

12. Select the index field to be used by the Lookup as a key to find matching 
values in the selected database from the Lookup index field drop-down list. 
This list contains all defined document and batch index fields.

13. Select the table column to be searched for values matching the selected 
Lookup index field from the Lookup table column drop-down list. This list 
contains all table column names from the selected database table.

14. For each batch or document index field that you want to populate or 
validate, select the database column that contains the desired data. Click 
in the column to the right of the index field name and select the database 
column from the drop-down list.
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15. Click Next to choose the database lookup options.

16. Select the desired Lookup options:

• Disable Lookup: when checked, Lookups will not be performed during 
scanning. This may improve performance with large or remote 
databases. Lookups will continue to occur in Edit Index mode and when 
the batch is output.

• Disable multiple lookup results if there is more than one result: 
when checked, the Multiple Lookup Results table will not be displayed 
during scanning. Multiple Lookup results will be resolved in Edit Index 
mode, allowing scanning to continue uninterrupted.

• Lookup will overwrite existing index value: when checked, the 
Lookup will always populate an index field with the lookup value in the 
database, as long as the database entry has a value (i.e., is not empty 
or null). If you want users to be able to manually enter data into an index 
field that Database Lookup is populating, then this option should be 
unchecked or disabled.

NOTE: Database Lookup will never overwrite data when the batch is 
output. 

• Disable Lookup during Output: when checked, no Lookup (populate 
or validate) will occur during output. If unchecked, empty fields will be 
populated and missing or multiple records will be ignored. Validation will 
fail if no matching record is found.
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17. Click Next to test the Lookup.

18. Click Test Query. The Test Query dialog box will be displayed.

19. Enter a valid value for the parameter that is used to perform the Lookup. If 
you leave the value blank, the first 25 records in the data table will be 
displayed.

20. Click OK
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Using Database Lookup After configuring a job to do a Database Lookup, it is important to understand 
when the Lookup will be performed. The following are the common scenarios:

During Scanning - Populating index fields

When Disable Lookup during capture has not been checked, Lookups will 
occur on-the-fly during scanning.

The Lookup will only take place when the index field that is being used for the 
Lookup has a value that was populated during scanning (e.g., as a result of a 
bar code or zonal OCR read).

During Scanning - Validating index fields

When Disable Lookup during capture has not been checked, Lookups 
configured for index field validation only will also occur on-the-fly during 
scanning.

The Lookup Validation will only take place when the index field that is being 
validated has a value that was populated during scanning (e.g., as a result of a 
bar code or zonal OCR read).

NOTE: When Disable Lookup is not checked, Database Lookups will always 
be performed during scanning. Even if the Index Field setup option 
Check field during scanning is disabled, the database lookup validation 
will still be performed.
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Edit Index mode After scanning has been performed and the user enters Index mode 
(Index>Edit Index Fields), the Lookup will always be performed on a 
document whenever the document is navigated to while in indexing mode.

If the index field that is being used for the Lookup already has a value (e.g., 
from bar code or zonal OCR) then the Lookup for a document will be 
performed automatically when navigating to the document.

If data is manually being entered in the index field, then the Lookup will be 
performed when the user leaves the index field. If the Tab key is used to 
navigate away from the index field just entered, the results of populating the 
other index fields will be displayed for verification. If the Enter key is used or 
one of the other indexing mode function keys (i.e., F9, F10, F11) to navigate to 
another document, then the Lookup will be performed and the other index 
fields will be populated. However, you will not see the results of the Lookup as 
that document is no longer being displayed in indexing mode.

If the Lookup index field is populated using Drag n’ Drop OCR, then the 
Lookup will be performed immediately and the results of populating the other 
index fields will be displayed for verification.

Batch Output Database Lookup only occurs on output if the Disable Lookup on Output 
option is not checked. When you click the Output tool, as part of Index field 
validation, Database Lookup for populating and validating index fields is 
performed immediately before the batch is queued for output processing. If a 
Database Lookup is populating index fields, errors will be ignored. If no record 
is found or multiple records are found, the current value in the index field will 
be unchanged or left empty. If a Database Lookup is validating index fields, an 
error will occur if no matching record is found. The batch will not be submitted 
for output and the error must be corrected before the batch can be 
successfully output.

If a batch is output from the Batch Manager screen or is automatically output 
from Job Setup, Database Lookup is performed immediately as part of the 
background batch processing. If a Lookup fails, the batch will be put into Index 
Error status.

When the batch is opened to correct the error, the document that had the 
Lookup failure will be automatically displayed and you can go into Index mode 
to correct the indexing problem and re-submit the batch for output processing.
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Job Setup:
Output tab

The Output tab is where you set up your output options for your job setup.

• Destination — allows you to make settings for the format of the output, 
where to send the output, and how to index it. The Destination options are:

- File (1) and File (2): allows you to select your file format (TIFF, JPEG, 
PDF, etc.) and type of output (e.g., black and white, color/grayscale).

- System (1) and System (2):allows you to select the Batch Output 
Format for your job setup.

- E-mail: allows you to setup up the software to automatically e-mail the 
output. 

- Print: allows you to setup up the software to automatically print the 
output.

• Advanced Options — allows you to apply Kodak Capture Pro Software 
image processing options to the output. 

• Invoke Other Program — allows you to use another software application 
on your output. 

Destination options: 
File (1) and File (2) 

File (1) option — select a file format (TIFF, PDF, JPEG, etc.) for your output. 
Your choice of formats will depend upon your type of output:
• All (black and white and color/grayscale)
• Black and white
• Color/grayscale

NOTE: For a description of the file format dialog boxes see the section 
entitled, “Setup options for File (1) and File (2)” later in this chapter. 
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• Location — shows the output location for File (1). To change settings, click 
Setup to open the Location Setup dialog box. For more information about 
the Location Setup dialog box, see the section entitled, “Building location 
and filename formulas using the Location Setup dialog box” later in this 
chapter.

• File Name — shows the file name for File (1).

File (2) option — same as File (1). You can choose different settings for File 
(2) or use the same settings as in File (1).

Under the File (1) or File (2) options, you can select the Index option. The 
following indexing options will be displayed. 
• Batch Index file
• Document Index file
• Image Index file

Setup options for File (1) 
and File (2) 

When you select a file format (TIFF, PDF, JPEG, etc.) for your output, your 
choice of formats will depend on how you configure the setup for that file 
format.

• Click Options for the file format you want to configure. 

When the Options button is selected, a dialog box for the file format you 
selected will be displayed.
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Selecting PDF as your file format: 
If you select PDF as your file format to process your output, the PDF Setup 
dialog box will be displayed.

1. Select either Single-Page or Multi-Page as the way to group your image 
files in output. Every input (scanned) image file will be a separate output 
file.

• If you select Single-Page, every image you scan is a separate image 
file in output. Therefore, if you scan a page, you will have two separate 
image files in output (one for the front and one for the back). If you are 
scanning dual stream, you will have four image files in output.

• If you select Multi-Page, the For each drop-down list becomes 
available.

- For each: Page — every image for every page scanned becomes one 
file. When you open the file, there will be two images, one for the front 
and one for the back. If you are scanning dual stream, you will have four 
images.

- For each: Document — every page scanned into one document will 
become the contents of one file. There may be several (or many) 
images in one file.

- For each: Batch — all images scanned into the batch will become one 
output file. There may be many images in the output file.

2. Select a PDF format from the drop-down list: PDF, PDF/A, PDF-MRC, or 
PDF-A&PDF-MRC.

3. If you selected PDF-MRC or PDF-A&PDF-MRC as your PDF format, 
select the desired Image quality: Draft or Better.

4. When finished, click OK.
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Selecting TIFF as your file format: 
If you select TIFF as your file format to process your output, the TIFF Setup 
dialog box will be displayed.

1. Select either Single-Page or Multi-Page as the way to group your image 
files in output. Every input (scanned) image file will be a separate output 
file.

• If you select Single-Page, every image you scan is a separate image 
file in output. Therefore, if you scan a page, you will have two separate 
image files in output (one for the front and one for the back). If you are 
scanning dual stream, you will have four image files in output.

• If you select Multi-Page, the For each drop-down list becomes 
available.

- For each: Page — every image for every page scanned becomes one 
file. When you open the file, there will be two images, one for the front 
and one for the back. If you are scanning dual stream, you will have four 
images.

- For each: Document — every page scanned into one document will 
become the contents of one file. There may be several (or many) 
images in one file.

- For each: Batch — all images scanned into the batch will become one 
output file. There may be many images in the output file.

2. If your output includes black and white images, the Black & White 
compression option is available. Select Group-4 or (none) from the drop-
down list.

3. If your output includes color or grayscale images, the Color/Grayscale 
compression and Color quality options are available.

• Color/Grayscale compression: select JPEG (TIFF 6), or (none).

• Color quality: select one of the following settings from the drop-down 
list: Same as scanned, Draft, Good, Better, Best, or Superior. Same 
as scanned is recommended.

4. If you want to have a digital signature, click Apply Digital Signature. 
Checking this option provides the recipient with some confidence that the 
image data has not been changed.

5. When finished, click OK.
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Selecting Searchable PDF as your file format: 

If you select Searchable PDF as your file format to process your output, the 
Searchable PDF Setup dialog box will be displayed.

1. Select either Single-Page or Multi-Page as the way to group your image 
files in output. Every input (scanned) image file will be a separate output 
file.

• If you select Single-Page, every image you scan is a separate image 
file in output. Therefore, if you scan a page, you will have two separate 
image files in output (one for the front and one for the back). If you are 
scanning dual stream, you will have four image files in output.

• If you select Multi-Page, the For each drop-down list becomes 
available.

- For each: Page — every image for every page scanned becomes one 
file. When you open the file, there will be two images, one for the front 
and one for the back. If you are scanning dual stream, you will have four 
images.

- For each: Document — every page scanned into one document will 
become the contents of one file. There may be several (or many) 
images in one file.

- For each: Batch — all images scanned into the batch will become one 
output file. There may be many images in the output file.

2. Select one of the following formats from the drop-down list: PDF, PDF/A, 
PDF-MRC or PDF/A&PDF-MRC.

3. Select the desired image quality.

4. OCR will be performed to provide a capability to search for specific text in 
the output files. Select the OCR language that your scanned documents 
will contain, for the most accurate character recognition.

5. When finished, click OK.
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Selecting JPEG or JEPG2000 as your file format (if your output type is 
Color/Grayscale): 
If you select JPEG2000 as your file format to process your output, the 
JPEG2000 Setup dialog box will be displayed.

1. Select Good, Better or Best color quality.

NOTE: If you select JPEG as your file format, the additional color quality 
options are available: Same as scanned, Draft and Superior. 
Same as scanned is recommended.

2. When finished, click OK.
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Index options for File (1) 
and File (2)

Index options for the File (1) and File (2) output destinations are setup via the 
Output tab. 

You can create a Batch Index file, a Document Index file and an Image 
Index file.

Each index file (e.g., Batch, Document and Image) provides an Options 
button, a Setup button and a Content button.

Options — displays the available index file type:

• Capture Software 6.x — no property setup is required. 
• HVCS 16-bit Format — this option is not available for a Batch index file. 

HVCS 16-bit Format allows you to define the Client number (1-999) and 
Application number (1-9).

• Text (delimited) — allows you to select an ASCII or Unicode text file 
format.

• XML — no property setup is required.

Setup — displays the Location Setup dialog box which allows you to create an 
index file. For more information about this dialog box, see the section entitled, 
“Building location and filename formulas using the Location Setup dialog box” 
later in this chapter. 

Content — displays the Index Content Setup dialog box which allows you to 
define the index content. For more information about this dialog box, see the 
section entitled, “Using the Index Content Setup dialog box” later in this 
chapter.
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Batch Index file To set up a Batch Index file: 

1. Select Batch Index file.

2. Select the desired index file type.

• If you selected Text (delimited), click Options and click either ASCII or 
Unicode, then click OK.

3. If desired, click Setup to display the Location Setup dialog box to create a 
path for your outputted batch index file. See the section entitled, “Building 
location and filename formulas using the Location Setup dialog box” later 
in this chapter.

4. If desired, click Content to display the Index Content Setup dialog box and 
define the index content. By default, the batch index file will contain only 
the batch indexes defined for this job. Use the Content button to add or 
remove index values or to reorder indexes in output. See the section 
entitled, “Using the Index Content Setup dialog box” later in this chapter.

5. When finished, click OK.

Document Index File To set up a Document Index file: 

1. Select Document Index file.

2. Select the desired index file type.

• If you selected Text (delimited), click Options and click either ASCII or 
Unicode, then click OK.

• If you selected HVCS 16-bit Format, click Options and enter the 
Client number (1-999) and Application number (1-9), then click OK.

3. If desired, click Setup to display the Location Setup dialog box to create a 
path for your outputted document index file. See the section entitled, 
“Building location and filename formulas using the Location Setup dialog 
box” later in this chapter.

4. If desired, click Content to display the Index Content Setup dialog box and 
define the index content. By default, the document index file will contain 
only the document indexes defined for this job. Use the Content button to 
add or remove index values or to reorder indexes in output. See the 
section entitled, “Using the Index Content Setup dialog box” later in this 
chapter.

5. When finished, click OK.
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Image Index File To set up an Image Index file: 

1. Select Image Index file.

2. Select the desired index file type.

• If you selected Text (delimited), click Options and click either ASCII or 
Unicode, then click OK.

• If you selected HVCS 16-bit Format, click Options and enter the 
Client number (1-999) and Application number (1-9), then click OK.

3. If desired, click Setup to display the Location Setup dialog box to create a 
path for your outputted image index file. See the section entitled, “Building 
location and filename formulas using the Location Setup dialog box” later 
in this chapter.

4. If desired, click Content to display the Index Content Setup dialog box and 
define the index content. By default, the image index file will contain only 
the image indexes defined for this job. Use the Content button to add or 
remove index values or to reorder indexes in output. See the section 
entitled, “Using the Index Content Setup dialog box” later in this chapter.

5. When finished, click OK.
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Building location and 
filename formulas using 
the Location Setup 
dialog box

The Location Setup dialog box provides a listing of predefined values and your 
previously setup index values which allow you to store your output files in 
uniquely named folders that can be easily sorted.

When you click Setup on the Output tab - Destination\File1 or 
Destination\File2, the Location Setup dialog box will be displayed. Use this 
dialog box to build a formula which Kodak Capture Pro Software will use when 
creating and storing output.

• To build location formulas, open the Location tab.

• To build file name formulas, open the File name tab (if it appears on this 
dialog box). 

Procedures for creating Location formulas and File name formulas are the 
same.

1. Select a predefined value from the list on the left side of this dialog box. 
The formula currently in use is in the Filename Formula field on the right 
side of the dialog box.

2. Click Add Item to add the predefined value to the end of the formula. 
When specifying a path name, the limit is 248 characters in length.
NOTES:
• Clicking Delete Item will delete the predefined value at the end of the 

formula.
• Clicking Delete formula will delete the formula.

3. If you want to define digits of sequential numbers and add zeroes to the left 
side of your sequence number, check Add Leading zeros. This option is 
only available with number values.
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4. If you checked Add Leading zeros, use the Number Length box to 
indicate the number of digits (including any leading zeros) for the sequence 
number.

5. If you add <Image-side label> to the Filename Formula field, the Front 
Color/Grayscale, Front Black & White, Back Color/Grayscale, or Back 
Black & White text boxes become active. If desired, enter text labels in 
these fields.

6. The Duplicate file handling area provides two options. Select one of 
these options:

• Report an error and abort the output processing: generates an error 
message and stops outputting the batch.

• Add a sequence number to the name: appends a sequence number 
(e.g., -001, -002) and continues outputting the batch.

7. If you select Page Sequence Number or Image Sequence Number the 
Reset Feature is available. Set the sequence numbering behavior for 
page and/or image numbers.

• Start at 1 for every batch (available only with Page Sequence Number 
and Image Sequence Number).

• Start at 1 for every document (available only with Image Sequence 
Number).

• Continuous image numbering from (available only with Image 
Sequence Number).

8. Click OK to save your output formula.

NOTE: Multi-page Formulas: if you selected multi-page output for TIFF, PDF 
or Searchable PDF, you cannot add a Page Sequence Number, 
Image Sequence Number or Image-side label into the Location 
formula or File name formula. Similarly, if you choose multi-page 
output at the batch level, you cannot name the output file with any 
more detailed information than batch-level information.
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Using the Index Content 
Setup dialog box

1. Click Content to define index content for the output index file. The Index 
Content Setup dialog box will be displayed.

If you are defining index content for the Text (delimited) index type only, select 
an entry in the following fields:

The following options only apply to the Text (delimited) index type:

2. Select (tab) or (space) from the Field delimiter drop-down list. You can 
also manually input other characters as the custom delimiter. 

3. Select (none), single quote (') or double quote (") from the Item delimiter 
drop-down list.

4. Check the Include header record option if you want to include image file 
header information in the output index file. 

If you are defining index content for the Text (delimited) index type and XML 
index type, you can apply the following option: 

5. Select any item from the Available Indexes list and click Add to add it into 
the Current Indexes list.

NOTES: 

• Click Remove to delete the selected index item from the Current Indexes 
list. 

• Click Add All to move all the index items from the Available Indexes list to 
the Current Indexes list. 

• Click Remove All to delete all the index items from the Current Indexes list. 

• Click Move Up/Move Down to move the selected index item one step up/
down in the Current indexes list. 

6. When finished, click OK.



4-58 A-61635  July 2009
 

System (1) and System 
(2) options

The System (1) and System (2) options allow you to select a Batch Output 
plug-in to output a batch with the required file structure and file format for many 
popular Enterprise Content Management systems.

System (1) option — if selected, check the Send to check box and then 
select a system (Batch Output Format) from the drop-down list. 

To change the system settings, click Setup and a specific dialog box for the 
selected batch output format will be displayed. For additional information about 
these dialog boxes, see the Batch Output Formats guide (A-61638).

To change the output root path, click Setup and the Location Setup dialog box 
will be displayed. For more information, see the section entitled, “Building 
location and filename formulas using the Location Setup dialog box” earlier in 
this chapter.

Select a file format (TIFF, PDF, JPEG, etc.) for your output. Your choice of file 
formats will depend upon the Send to output type you selected. 

NOTE: The All, Black & White and Color/Grayscale options may not be 
available for the batch output format you selected. If that is the case, 
click the Setup button to select your setup options.

System (2) option — if selected, follow the same instructions as for System 
(1).

More Output Formats — provides a complete listing and links to Kodak and 
third-party System Output Formats that are available from the Kodak website.
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Setting up your e-mail 
options

The E-mail option on the Output tab allows you set up the software to 
automatically e-mail output batches, with or without index data.

1. Open the Job Setup dialog box and click the Output tab.

2. Click the E-mail option. The Destination\E-mail: dialog box will be 
displayed.

3. Select an e-mail software application to send e-mails from the Default e-
mail application drop-down list.

4. Enter the information you want to appear as the subject line of the e-mail in 
the Default title of e-mail field. You can select a predefined value to this 
subject line (e.g., date, name, etc.) by clicking Setup. The Default Title of 
e-mail Text Field Value Setup dialog box will be displayed in which you can 
select additional items to add to the e-mail title. 

• Select the values you want to add to the e-mail title from the Predefined 
values list. With each addition, click Add Item.

• Click OK when finished.

NOTE: If you want to delete the last value, click Delete Item. To 
delete the entire formula, click Delete Formula.
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5. Enter the maximum size allowed for an e-mail attachment (in MB) in the 
Max size of attachments field.

6. Check Interactive if you want a confirmation before the e-mail is sent.

NOTE: If you are using Outlook Express as your e-mail client, you must check 
this option, otherwise the e-mail will not be sent.

7. Enter one or more e-mail addresses in the To field, cc field and bcc as 
applicable. The e-mail address(es) must be enclosed in double quotes 
(e.g., “John Smith@aol.com”).

8. If desired, click Setup to add predefined values to your e-mail recipient 
names. 

9. If you are including an attachment, you can enter a name of the attachment 
and/or select predefined values by clicking Setup. The attachment name 
must be enclosed in double quotes (e.g., “Patient file”).

10. Check Include associated document index data if you want data to 
automatically be displayed in the E-mail body field. To change this data, 
click Setup and the E-mail Body Text Field Value Setup dialog box will be 
displayed.

• Enter any text you want to appear in the e-mail. The information you 
enter must be enclosed in double quotes (“ “). You can also select any 
values from the Predefined values list and click Add Item. 

• Click OK when finished.

11. Check Save images to disk if you want to save the output image files to 
your hard drive in addition to sending the email output.

12. Click OK when finished.

NOTE: If you check Image under the E-mail option on the left side of the 
Output tab, you can check destination options (TIFF, PDF, JPEG, etc.) 
depending on your type of output. 
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Setting up your Print 
options

The Print option allows you to print your output.

1. Click Print on the Job Setup - Output tab.

2. Select the desired printer from the Printer name drop-down box.

3. If you want to change the printer properties, click Properties. The 
properties for the selected printer will be displayed.

4. Change the printer properties as desired and click OK.

5. Select the number of copies you want to print from the drop-down list and 
click OK.
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Advanced options When you select Advanced Options the following options are available: 

Auto-Deletion — deletes a front or back image when the image size is lower 
than the values specified on the Auto-Deletion dialog box.

Auto-Orientation — analyzes the content of your documents and orients each 
document so it is right-reading. 

Background Color Smoothing — using this option for documents or forms 
with a background color will help produce images with a uniform background 
color.

Image Edge Fill — fills unwanted black or white edges on an image, thus 
producing a cleaner image.

Image Stamping — stamps the image number on the front and/or back sides 
of each page. 

Rotate — rotates all images in a batch 0, 90, 180 or 270 degrees as selected.

Stitch — merges all images of a document into a single output file.

Split — converts the front and rear image into multiple images. Images must 
be the same type (color/grayscale or black and white).

To access the image processing options:

1. Click Image Processing under Advanced Options on the Output tab. 

2. Select the desired image processing option and configure as desired. 

NOTE: The sections that follow provide detailed information about each 
option.
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Auto-Deletion The Auto-Deletion option allows you to set options for automatically deleting 
an image with no content or very busy pages (e.g., the back of a form which 
has a lot of explanatory text on it). Auto deletion settings are specified 
independently for front and back images. 

If you are scanning both color/grayscale and black and white image types, 
auto deletion settings are also set independently. Therefore, you can choose 
to delete one type of image or both.

When using Auto-Deletion, it is recommended that you scan some 
representative documents which you consider to be blank or almost blank, by 
using the Test option. The results of the Test option will help you determine if 
you should set the auto delete values using the Image size (byte) is option or 
the Image content (%) option. 

• Image size (byte) is Above — select this option if you want to delete pages 
with a lot of busy, explanatory content on them. For example, if you are 
scanning documents with similar content (e.g. insurance forms) on the front 
and back page, and the front page has content you need to keep, but the 
back page contains instructions on how to file a claim (that you do not need 
to keep), enter the number of bytes that you want Capture Pro Software to 
delete any image file greater than that amount. Any image that is more than 
this value will be considered too large and will be deleted. 

• Image size (byte) is Below — select this option if you want to delete pages 
with no content or very little content. Enter the number of bytes that Capture 
Pro Software will consider the image size to be blank. Any image that is less 
than this value will be considered blank and will be deleted.

• Image content (%) is Above — this option is similar to the Image size 
(byte) Above option except that you enter a percentage value that Capture 
Pro Software will consider the image to have too much content. Any image 
more than this will be deleted. 
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• Image content (%) is Below — this option is similar to the Image size 
(byte) Below option except that you enter a percentage value that Capture 
Pro Software will consider the image to be blank or too little content. Any 
image that is less than this value will be considered blank and will be 
deleted. Use this setting when there are blank pages. 

NOTES:

• When selecting the Image size (byte) option, other factors such as 
resolution, compression, etc., will impact the image size. 

• The Image content (%) option only looks at the percentage of information 
on the image and therefore, is a more consistent and dependable option to 
use when images may vary in size, resolution, compression, etc.

Never — click Never, if you do not want to delete any images.

Auto-orientation This option analyzes the content of your documents and orients each 
document so it is right-reading. 

Auto orientation does not work with all character sets. It is recommended that 
you scan some test documents to ensure the document will be oriented 
correctly.

• You can select Enable auto-orientation on front or Enable auto-
orientation on back.

NOTE: Auto-orientation will be performed during the output creation 
process.
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Background color smoothing This option can be used for documents or forms with a background color to 
help produce images with a uniform background color. 

The smoothing options can be applied to the front and/or back of a page.

You can select a smoothing type of:

None — no background smoothing will be performed; image will not be 
changed.

Automatic — the background color(s) will be selected and smoothed 
automatically.

Change to White — identifies up to three background colors and substitutes 
each one with white. If you select this option, the Apply to drop-down box will 
be available allowing you to select:

• Predominant: only the most common background color will be changed to 
white.

• Neutral: only the neutral background color(s) will be changed to white.

• All: the background color(s) will be changed to white.

Aggressiveness — controls the amount of variability that can be corrected in 
the background color(s). Select a value from 1 to 20.

Before Background Color 
Smoothing

After Background Color 
Smoothing
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Preview — opens the Background Color Smoothing Preview dialog box, which 
allows you to compare the original image against the changed image and alter 
your settings.

Image Edge Fill This option allows you to fill and clean up the unwanted edges on a scanned 
image by covering the area in Black or White (as selected). This option can be 
applied to the front and/or back of an image.

You may want to use this option if you have pages with punch holes or ragged 
images that you want to clean up.

•  Select a value in the Top, Left/Right and/or Bottom area(s) from each side 
of the scanned image to be filled in 1/100ths of an inch, or select All sides 
match to fill in the same amount on all sides.

NOTE: When using Image Edge Fill, be careful not to enter a value too large 
as it could fill in image data that you want to keep. 

Original: 3-hole punch without 
Image Edge Fill

Image with 37/100th of an inch: 
fills half of the hole. Value is 

not enough.

Image with 62/100th of an inch: 
fills the entire hole and keeps 

all text. Value is good.

Image with 150: fills the entire 
hole AND fills some text. Value 

is too large. 
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Image Stamping This option will stamp the image number of document on the front and/or back 
of your image. 

Stamp image number of document — check this box to enable this option on 
the Front and/or Back of an image.

Location: Top or Bottom — places the image number on the top or bottom of 
the image as selected. 

Location: Left, Middle or Right — places the image number on the left, 
middle or right of the image as selected.

Margin — select a margin size in 1/100ths of an inch to indicate how far from 
the Top, Bottom, Left or Right margin you want the number to be stamped.

Font size — select the font size of the number to be stamped; 16 or 18 point.

Bold — enable this checkbox for bold print.

Rotate This option allows you to select the desired rotation of 0, 90, 180 or 270 
degrees. The degree of rotation applies to all images in the batch.
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Stitch When this option is selected, all the images of the document will be merged 
into a single, continuous file.

Split When this option is selected, the front and rear image will be converted into 
multiple (up to 6) images. Images must be the same type (color/grayscale or 
black and white). 

Split Page or Image — enable this checkbox to activate the Split option.

Number of resultant images — choose from 2 to 6 images that you want to 
split from the drop-down list.

Split image if width is between — use the two drop-down lists to select a 
range of widths for the page or image. If the page width falls within this range, 
it will be split. If either the front or back side falls outside the range, neither side 
will be split.
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Front and/or Back — enable this checkbox for Front and/or Back to activate 
the split. A graphic will be displayed showing your selection. For example, if 
you enable both checkboxes, the two book icons will appear with a red "X" on 
each page:

NOTE: When using a simplex-only scanner, selecting both Front and Back 
will result in no split. Select Front only to cause a split.

Output order — the page order will be displayed in this field. Click on each 
image segment in the order you want the images to be output. As you click on 
an image segment, the red "X" disappears.

Any image segment that is still marked with a red "X" will be deleted and not 
sent to output. This option might be useful for the last page of a pamphlet that 
is always blank.

Reset Order — any order that you originally specified will be deleted and you 
can reorder your images.
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Invoke Other 
Program option

The Invoke Other Program option on the Output tab allows you to use an 
application other than Kodak Capture Pro Software to make changes to your 
output. Select the checkbox to enable this option.

Program Name — enter the application name. If needed, click Browse to 
search for the application.

Parameters — enter any operational parameters from the other application. 
Place a blank space between each parameter you enter (i.e., 1 2 3) in this 
field. If entering names with spaces, use quotation marks to mark the names 
and put a blank space between the names (i.e., "John Doe" "Jane Doe").

OK — saves your settings and closes the dialog box.
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Job Setup:
Scanner-specific 
settings

Not all scanners have scanner-specific settings. This section applies only to 
scanners that have image addressing, batch, patch and imprinting capabilities. 
If your scanner requires scanner-specific settings, a KODAK Scanner: iXXX 
option will be displayed on the left side of the Output tab. 

Kodak i1800 Series 
Scanners

This section provides information that is specific to Kodak i1800 Series 
Scanners.

The Scanner Options box allows you to access the TWAIN Datasource and 
setup Message Configuration and Image Addressing options.

New batch starts with counter equal to — enter the number you want to 
start a new batch with.

When you click this icon, the TWAIN Datasource will be displayed 
allowing you to configure your Imprinter, Image Address, Batch and 
Patch options. For information and procedures on using the TWAIN 
Datasource, refer to the on-line help for the TWAIN Datasource.
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Message Configuration — displays the Message Configuration dialog box. 
This dialog box allows you to specify custom text to be included in your print 
string. A maximum of 20 characters is allowed. You can have up to six unique 
messages per string. The Printer option in the TWAIN Datasource must be 
enabled and configured before configuring custom messages in Kodak 
Capture Pro Software.

NOTE: The printer configuration that you set up in Capture Pro Software will 
override any printer configuration setup in the TWAIN Datasource.

1. Click Message Configuration. The Message Configuration dialog box will 
be displayed.

2. Click Setup for each message you want to configure. The Message Setup 
dialog box will be displayed 

3. Select a value from the Predefined values list and click Add Item.

4. Click OK when finished.

NOTE: Click Delete Item to remove the last value in the formula, or Delete 
Formula to delete the entire formula.
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Image Address Options — you can enable the following options:

• Delete level 3 pages: this counter is associated with the numeric portion of 
the batch name. Whenever a Level 3 page is scanned, Capture Pro 
Software will automatically create a new batch and discard the Level 3 page. 

• Delete level 2 pages: this counter is associated with the document number 
of the current batch. Whenever a Level 2 page is scanned, Capture Pro 
Software will automatically create a new document. 

• Set image address on new batch: sets the image address value when a 
new batch is manually created in Capture Pro Software. This option does 
not affect the image address when batches are automatically created in 
Capture Pro Software (e.g., blank page separation, bar code separation). By 
default, the image address default value for a new batch will be as follows: 

- Fixed field: the default value as defined in this dialog box.
- Level 3: the batch number portion of the Capture Pro Software batch 

name (e.g., a value of 19 if the batch name is Batch019). 
- Level 2: Capture Pro Software document number for the first document 

in the batch. 
- Level 1: 0 if the image address format is Level 2 or Level 3. 1 if the 

image address format is Level 1. 
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• Set image address on scanner start: automatically resynchronizes the 
scanner image address with the current scan batch in Capture Pro Software 
every time the scanner is started. The image address value is set to what 
the image address should be for the next scanned page. This option is only 
available when Set image address on new batch is enabled.

When the scanner image address is resynchronized, the image address 
fields will be set to the following: 

- Fixed field: will not change from the current scanner value. 

- Level 3: the batch number portion of the Kodak Capture Pro Software 
batch name. 

- Level 2: the current Capture Pro Software document number.

- Level 1: the number of pages in the current document if the image 
address format is Level 2 or Level 3. Number of pages in the current 
document + 1 if the image address format is Level 1.

NOTE: When dual-stream scanning, Set image address at scanner 
start is not recommended. This is because the number of pages 
in the current document is not correctly maintained by Capture 
Pro Software when dual-stream scanning. As a result, the Level 1 
portion of the image address can easily get out of sync.

Fixed field value — this is a static field containing ASCII text that does not 
increment or change during scanning. Enter the text in the field or click Setup, 
which displays the Fixed Field Value Configuration dialog box. 

OK — saves your settings and closes the Job Setup dialog box.
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Kodak i600/i700/i1400 
Series Scanners

This section provides information that is specific to Kodak i600 Series 
Scanners, Kodak i700 Series Scanners and Kodak i1400 Series Scanners.

The Imprinter tab provides the following options.

Enable imprinter — check this box to enable the imprinting function. 

NOTE: The Counter is the document count for the scan session. This value is 
incremented sequentially by the scanner and returned in the image 
header.

Counter length — allows you to configure the length of the counter from 1 - 9. 
However, if for example, you only have six characters left in the print string, 
then the length would be limited to 6.

Counter format — allows you to configure the format of the counter when the 
width of the value is less than the field width. Select one of the following 
formats from the drop-down list:
• Display leading zeros (e.g., “004)
• Suppress leading zeros (e.g., “  4”)
• Compress leading zeros (e.g., (“4”)

Date Delimiter — select a separator setting from the drop-down list: None, 
Forward Slash (2006/08/24), Hyphen (2006-08-24), Period (2006.08.24), or 
Blank (2006 08 24).

Font — from the drop-down list, select Large comic, Large cine, Large 
comic 180, Large cine 180, Small comic, Small cine, Small comic 180, or 
Small cine 180.

Position — select a value to determine how far the printed information will 
appear from the leading edge of the document. 
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Message Configuration— displays the Message Configuration dialog box for 
your scanner. This dialog box allows you to specify custom text to be included 
in your print string. A maximum of 20 characters is allowed. You can have up to 
six unique messages per string.

Print string — enter a print string or click Setup to open the Formula 
Configuration dialog box and set up your print string using predefined values.

New batch starts with counter equal to — enter the number you want to 
start a new batch with.

Kodak i200 and i100 
Series Scanners

This section provides information that is specific to Kodak i200 Series 
Scanners and Kodak i100 Series Scanners.

The Imprinter tab provides the following options. 

Enable imprinter — check this box to enable the imprinting function.

NOTE: The Counter is the document count for the scan session. This value is 
incremented sequentially by the scanner and returned in the image 
header.

Counter length — allows you to configure the length of the counter from 1 - 9. 
However, if for example, you only have six characters left in the print string, 
then the length would be limited to 6.

Counter format — allows you to configure the format of the counter when the 
width of the value is less than the field width. Select one of the following 
formats from the drop-down list:
• Display leading zeros (e.g., “004)
• Suppress leading zeros (e.g., “  4”)
• Compress leading zeros (e.g., (“4”)

Date Delimiter — select a separator setting from the drop-down list: None, 
Forward slash (2006/08/24), Hyphen (2006-08-24), Period (2006.08.24), or 
Space (2006 08 24).
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Font — use the drop-down list to select Large comic, Large cine, Small 
comic or Small cine.

Position — select a value to determine how far the printed information will 
appear from the leading edge of the document.

Message — enter a message or click Setup to display the Message 
Configuration dialog box. This dialog box allows you to specify custom text to 
be included in your print string. A maximum of 20 characters is allowed. You 
can have up to six unique messages per string.

Print string — enter a print string or click Setup to open the Formula 
Configuration dialog box and set up your print string using predefined values.

New batch starts with counter equal to — enter the number you want to 
start a new batch with.
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Kodak i800 Series 
Scanners

This section provides scanner-specific information for the Kodak i810, i820, 
i830 and i840 Scanners.

Imprinter tab Enable imprinter— enables the print functionality.

Font — two different character sizes, referred to as Large and Small, are 
available. Information is printed on each document in one of the two 
orientations: Comic or Cinema. You can choose:
• Large Comic
• Large Cinema
• Small Comic
• Small Cinema
• Large Comic 180
• Large Cinema 180
• Small Comic 180
• Small Cinema 180

Counter format — allows you to configure the format of the counter when the 
width of the value is less than the field width. Select one of the following 
formats from the drop-down list:
• Display leading zeroes "004"
• Do Not Display: "4"
• Display As Spaces: "  4"
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Date Delimiter — select a separator setting from the drop-down list: None, 
Slash (2008/08/24), Hyphen (2008-08-24), Period (2008.08.24), or Space 
(2008 08 24).

Position — select a value from 0.35 to 33.5 inches to determine how far the 
printed information will appear from the leading edge of the document. 

• Printing automatically stops 6.3 mm (1/4-inch) from the trailing edge of the 
document even if the information has not been completely printed. 

• The horizontal print position is set manually on the scanner. See the User’s 
Guide for information on changing the horizontal print position.

Counter length — allows you to configure the length of the counter from 1 - 9. 
However, if for example, you only have six characters left in the print string, 
then the length would be limited to 6.

Date format — select one of the following formats: MMDDYYYY, DDMMYYYY 
or YYYYMMDD.

Print string — allows you to define your print string. The maximum amount of 
characters for the print string is 40 characters (including spaces). 

Select the level of the document that you want the specified print string to be 
printed on: Level 1, Level 2 or Level 3. For example, if you use three level 
image addressing, you can print the date on your level 3 document, nothing on 
level 2 and document count on level 1.

Message Configuration — displays the Message Configuration dialog box for 
your scanner. This dialog box allows you to specify custom text to be included 
in your print string. A maximum of 20 characters is allowed. You can have up to 
six unique messages per messages. 

Use uniform print string — click this if you want the print string to be the 
same on all levels.

NOTE: For information on the Image Address Options see the next section 
entitled, “Image Address tab”. 
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Image address tab Image addressing allows you to create counters within your job setup for each 
batch, document, and page. These counters will create a unique image 
address for each image as it is being scanned. Depending on your settings, 
the image address will contain an identification of its batch, its document, and 
its own number within the batch, along with a fixed value, such as a date or 
location name.

Template — up to four fields can be defined. The maximum length for each 
image address field is 9. The combined length of all image address fields 
cannot exceed 27 characters. This results in a maximum image address length 
of 30 characters (with a period (.) delimiter between each field). Enter a width 
value of 0 to disable an image address field. The default setting of all image 
fields widths set to 0 will disable image addressing in the scanner.
The i800 Series Scanners have more options available for image addressing 
schemes with the following guidelines:
• Only one field may be assigned to a level. You are only allowed one level 1 

field, one level 2 field, and one level 3 field.
• There is no requirement to have any level field.

Field width — there are four image address fields that make up the image 
address format: 

• Fixed — a static field containing ASCII text that does not increment or 
change during scanning. 

• Level 3 — a counter that is associated with the numeric portion of the batch 
name within Capture Pro Software. Whenever a Level 3 page is scanned, 
Capture Pro Software will automatically create a new batch and discard the 
Level 3 page. 

• Level 2 — a counter that is associated with the document number of the 
current batch in Capture Pro Software. Whenever a Level 2 page is 
scanned, Capture Pro Software will automatically create a new document. 
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• Level 1 — a counter that is associated with the page number of the current 
document in Capture Pro Software. Whenever a Level 1 page is scanned, 
Capture Pro Software will attach the images for the page to the current 
document. 

After Level 3, After Level 2, After Level 1 — for each image address level, 
specify the image level that will be assigned to the next scanned page. 
Possible values are Level 1, Level 2, and Level 3. Level 1 is the default. 

For example: 

For health claim processing, every page scanned (the claim form) is its own 
document. There is, however, the occasional claim form that will be 
accompanied by some form of correspondence or supporting documentation. 
For this application, you would define a Level 2 image address with the 
following rules: 

• Level 2 followed by Level 2 
• Level 1 followed by Level 1 

This will effectively create a new document in Capture Pro Software for every 
page scanned. When the exception claim form needs to be scanned, the 
scanner operator presses the Level key on the scanner control panel to set 
the image address level to Level 1 after scanning the claim form. Then the 
correspondence pages are scanned. Once complete, the Level key is pressed 
again to set the image address level back to Level 2 for regular scanning.

Image Address format — the image address can be printed on the original 
documents as they are transported through the system. You can define the 
format in which the image address is printed. Select one of the following 
formats:
• Display leading zeros (e.g., 004.003.002.001)
• Suppress leading zeros (e.g., 004. 3. 2. 1)
• Compress leading zeros (e.g., 004.3.2.1)

Image Address options The Image Address Options appear on all tabs. You can enable the following 
options:

• Delete level 3 pages: this counter is associated with the numeric portion of 
the batch name. Whenever a Level 3 page is scanned, Capture Pro 
Software will automatically create a new batch and discard the Level 3 page. 

• Delete level 2 pages: this counter is associated with the document number 
of the current batch. Whenever a Level 2 page is scanned, Capture Pro 
Software will automatically create a new document.

• New batch starts with counter equal to: sets the Sequential Counter 
inside the scanner whenever a batch is manually created in Capture Pro 
Software. This option does not affect the Sequential Counter when batches 
are automatically created in Capture Pro Software (e.g., blank page 
separation, bar code separation). When enabled, specify the starting value.
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• Set image address on new batch: sets the image address value when a 
new batch is manually created in Capture Pro Software. This option does 
not affect the image address when batches are automatically created in 
Capture Pro Software (e.g., blank page separation, bar code separation). By 
default, the image address default value for a new batch will be as follows: 

- Fixed field: the default value as defined in this dialog box.
- Level 3: the batch number portion of the Capture Pro Software batch 

name (e.g., a value of 19 if the batch name is Batch019). 
- Level 2: Capture Pro Software document number for the first document 

in the batch. 
- Level 1: 0 if the image address format is Level 2 or Level 3. 1 if the 

image address format is Level 1.

In addition, with sufficient privileges, the user will have the opportunity to 
override the default image address value when the batch is created. 

• Set image address on scanner start: automatically resynchronizes the 
scanner image address with the current scan batch in Capture Pro Software 
every time the scanner is started. The image address value is set to what 
the image address should be for the next scanned page. This option is only 
available when Set image address on new batch is enabled.

When the scanner image address is resynchronized, the image address 
fields will be set to the following: 

- Fixed field: will not change from the current scanner value. 

- Level 3: the batch number portion of the Kodak Capture Pro Software 
batch name. 

- Level 2: the current Capture Pro Software document number.

- Level 1: the number of pages in the current document if the image 
address format is Level 2 or Level 3. Number of pages in the current 
document + 1 if the image address format is Level 1.

NOTE: When simultaneous scanning, Set image address at scanner 
start is not recommended. This is because the number of pages in 
the current document is not correctly maintained by Capture Pro 
Software when simultaneous scanning. As a result, the Level 1 
portion of the image address can easily get out of sync.
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Fixed field value — specifies the default value for the Fixed field portion of the 
image address. You can either type in the Fixed field value (enclosed in double 
quotes “”) or select Setup to access the Fixed Field Value Configuration dialog 
box.

The left side of the dialog box contains a list of pre-defined values that you can 
use to build the Fixed Field formula. The Fixed field value can consist of one or 
more pre-defined values as specified in the formula. The total number of 
characters in the formula cannot exceed the defined length for the Fixed field. 

To set up a Fixed field formula: 

1. Select a pre-defined value from the list box. 

2. Click Add Item. 

3. Repeat Steps 1 and 2 until the formula is complete. 

Select Delete Item to delete the last pre-defined value that was added. Delete 
Formula deletes the entire Fixed field formula. You can also use a special 
substring syntax, enclosed within square brackets, to retain a certain portion of 
a pre-defined value (e.g., [1,4]). 
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Batch tab Batching is the operation of counting pages or documents. This tab is only 
available when the scanner is in Image Address mode.

Enable batch — enables batching and the other options on this tab.

Level — sets the level to count. The options are Level 1, Level 2, and Level 
3. The level you want to count must exist in the image address template as 
defined on the Image Address tab. 

Size — define the number of documents to be counted prior to beginning the 
action to take place when the count has been reached.

Start function — defines the action to be taken prior to processing the first 
document in a batch. Options are Level 1, Level 2, Level 3 and None.

End function — select an option of what you want the scanner to do at the 
end of a batch:
• Stop feeder and transport
• Continue scan and start new batch

Image Address Options — these options appear on all the tabs. For detailed 
information about these options, see the section “Image Address options” 
previously in this section.
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Patch tab The Patch tab provides choices of what patch type to recognize. One or more 
patches can be selected at a time. The type of patch recognized is returned in 
the image header. See the Kodak publication A-61599, Patch Code 
Information for Kodak Document Scanners for complete information.

Enable patch — enables the patch code reader. Must be checked to enable 
any other options on this tab.

Level 2 patch — creates a new document (whether it reads your document 
with a patch on it or a Level 2 patch sheet).

Level 3 patch — creates a new batch (whether it reads your document with a 
patch on it or a Level 3 patch sheet).

Transfer patch — assigns a patch level to the next document (after the 
Transfer patch sheet). Select one of the following options from the drop-down 
list: Level 2 or Level 3. The Transfer patch will be treated as Level 0.

Feature patch — Patch Types 1, 4 and 6 can be used by the scanning 
application for post-scan image control (they are not used for image 
addressing). For example, use these patch types for workflow control or 
changing between black and white and color/grayscale imaging.

Toggle patch — use the drop-down list to select which patch heads/readers 
you would like to use. Each patch head/reader can be turned on and off 
independently. The default is for all patch heads/readers to be turned on. This 
option is only available when the scanner is in Image Address mode. The 
options are: Disabled, Both sides, and Front side.

Patch Confirmation Tone — the confirmation tone signals that the scanner 
has recognized a patch. The default is no confirmation tone.

Image Address Options — these options appear on all the tabs. For detailed 
information about these options, see the section “Image Address options” 
previously in this section.
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Kodak Digital 
Science 3520 
Scanner

This topic provides information on setting up printing in Kodak Capture Pro 
Software using the Kodak Digital Science 3520 Scanner. For more information 
on your scanner, consult your scanner User Guide.

The Kodak 3520 page of the Capture tab on the Job Setup dialog box allows 
you to create your printer settings.
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5   Patch Setup

Contents About Patch Codes ....................................................................................5-1
Setting up patch codes...............................................................................5-2

Patch 2, 3 or T code separation.............................................................5-2
Creating an attachment with a patch code.............................................5-3
Separating batches or documents with patch codes .............................5-4

About patch codes Kodak Capture Pro Software allows you to separate pages and documents on 
your scanner with pages containing patch codes. It also allows you to create 
attachments to your documents. Before you can use patch code separators, 
you must set your job setup to recognize patch codes.

Capture Pro Software supports three types of patch codes: 

You can define the separation method for each patch code. This is useful for 
existing jobs where Patch 2 codes were used as document separator pages 
instead of Patch T codes. You can also define a patch code to create an 
attachment. For new jobs and for compatibility reasons, it is recommended that 
you use patch codes the way they were designed to be used.

• For information on patch code reading when color or grayscale scanning, 
see the section entitled, “Using separators when color scanning” in Chapter 
6.

• For information on using patch codes on Kodak i800 and i1800 Series 
Scanners, see the section entitled, “Job Setup: Scanner-specific settings” in 
Chapter 4. When patch code reading is enabled on a Kodak i800/i1800 
Series Scanner,  patch code reading with Kodak Capture Pro Software is not 
allowed. Conversely, when patch code reading is enabled with Kodak 
Capture Pro Software, patch code reading on Kodak i800/i1800 Series 
Scanners is not allowed.

Patch Type Function Patch kept?
Patch 2 Separates pages into documents yes
Patch 3 Separates documents into batches no
Patch T 
(programmable)

Separates pages into documents
Separates documents into batches
Creates an attachment 

no
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Setting up patch 
codes
Patch 2, 3, or T code 
separation 

The Patch 2, 3 or T separation settings under the Capture tab on the Job 
Setup dialog box allow you to set up Kodak Capture Pro Software to recognize 
patch codes as separators between batches or documents on your scanner. 
Each patch has its separate window, but the commands are the same in all 
three windows. You can set up the system to recognize all three patch codes 
or just certain ones.

Detect Patch — when checked, enables the Detect Patch option.

NOTES: 

• If the Detect Patch check boxes are disabled in all three Patch Code 
windows, the patch reader is disabled.

• If you have checked Detect Patch on any of the Separation by Patch dialog 
boxes, Kodak Capture Pro Software checks each page for the type of patch 
code you selected.

Alternatively search on 180° rotated images — if patch code reading is 
unsuccessful, this option rotates the image and searches for the patch code 
again. This option helps prevents a patch code read failure because a page 
was scanned upside down.

NOTE: The software always searches for patch codes in the first 4 inches
(10 cm) of the top of the image after rotation, deskew, and cropping (if 
any). If a patch is vertical, the image should be rotated with the 
Software rotation option defined on the Page Setup dialog box. 

Alternatively search on back — if patch code reading is unsuccessful, this 
option searches the back side of the document for the patch. If the software 
detects a patch code on the front side, it will not look for a patch code on the 
back side.
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What to do if patch code is detected — select one of these options:

• Batch separation: creates a new batch with a patch code.

- Patch 3 is normally used to create a new batch.

- Typically the page containing a patch code for batch separation should not 
have any content. Therefore, the software discards the patch code page; 
the next page scanned becomes the first page of the first document in the 
batch.

• Document separation: creates a new document with a patch code.

- Patch 2 is normally used to create a new document and keep the image of 
the page containing the patch code.

- Patch T is normally used to create a new document and delete the image 
of the page containing the patch code.

• Create attachment: creates an attachment with a patch code.

• Delete page: deletes the page containing the patch code that started the 
new document or attachment. This option is important when you use inserts 
used for document separation purposes that do not contain any other 
information.

• Rotate document based on patch: rotates the image containing the patch 
code so the patch code is located horizontally on top of the page. All images 
in the document will be rotated. This option only works when the 
Alternatively search on 180° rotated images option is enabled. 

- The Rotate document based on patch option does not work when the 
patch code separator page is discarded. 

OK — closes the dialog box and saves your settings.

Creating an attachment 
with a patch code

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select the job from the Job Name drop-down list that requires patch code 
separation.

3. Open the Capture tab and select Separation>Patch Code. 

4. Select the patch type that you want to define: Patch 2, Patch 3, or Patch 
T. The Patch Code window will be displayed.

5. Click Detect Patch.

6. Under What to do if a patch code is selected, check the Create 
Attachment.

7. Check all other desired options in the Patch Code window. 

8. Click OK. 
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Separating batches or 
documents with patch 
codes

Kodak Capture Pro Software can recognize patch codes as separators 
between batches or documents on your scanner. 

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select the job from the Job Name drop-down list that requires patch code 
separation.

3. Open the Capture tab and select Separation>By Patch Code. 

4. Select the patch type you want to define: Patch 2, Patch 3 or Patch T. The 
Patch Code window will be displayed. You can enable as many of the 
patch code types as you need.

5. Click Detect Patch.

6. If desired, check one or both of the following options: Alternatively search 
on 180 rotated images and/or Alternatively search on back. 

7. Under What to do if a patch code is selected, check either the 
Document Separation or Batch Separation.

8. Check any other desired options. 

9. Click OK. 
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Overview To use bar codes or OCR for separation or indexing in your job setup, you 
must do the following:

• Select the Page Setup that will be used when scanning into this kind of job.

• Edit the job setup.

• Scan a page to use as a template for defining your bar code or OCR.

• Define where on the template image the bar code or OCR zone will be 
found.

• Specify how a correct bar code or OCR value will be recognized.

• Set up the actions connected to that bar code or OCR zone (e.g., create a 
new batch, create a new document in the current batch or populate one or 
more index fields).

This chapter explains these steps, except for populating index fields. 
Populating index fields can be found in Chapter 4, Job Setup.
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Using bar codes Bar coding is a method of encoding data in a machine-readable code 
consisting of a parallel arrangement of dark and light elements. The light 
elements are referred to as “spaces” and the dark elements as “bars.” The 
bars and spaces are either wide or narrow. The combination of wide and 
narrow bars and spaces is a bar code. Each bar code begins with a “start” 
character and ends with a “stop” character. The industry uses bar codes to 
provide more accurate and efficient data input than is possible using manual 
data entry.

Bar code setup allows you to define the:
• name of the bar code
• data mask or syntax
• physical location where to find the bar code (in a zone or anywhere on the 

image)
• bar code type (width, height, quality and confidence level)
• level where you can find the bar code (batch, document or page level)

Follow these tips to maximize the performance of Kodak Capture Pro 
Software:

• Choose the Page Setup name that you will use for scanning before you 
define a bar code zone.

• Make sure that all glass surfaces (the glass guides or glass over the camera 
area) within the scanner transport are clean. Dirty surfaces cause poor read 
rates.

• Use a higher resolution to obtain better read rates (300 vs. 200 dpi).

• Check the positioning of the zone around the bar code; it can affect the 
confidence level of a bar code. Leave at least a 1/4-inch of space around a 
bar code to guarantee that the full bar code will always fall within the zone. 
Move the zone around the bar code until the highest confidence rate is 
achieved.

• The minimum bar code height specification is 40 pixels. At 200 dpi, 40 pixels 
is 20/100ths of an inch; at 300 dpi, 40 pixels is 13/100ths of an inch. For bar 
codes smaller than 40 pixels in height, specify a bar code height in the Bar 
Code Zone Setup dialog box.

• Verify that the correct bar code type and bar code orientation are selected in 
the Bar Code Zone Setup dialog box.

• If bar codes are on documents with color backgrounds, you may need to 
lower the threshold value in the Bar Code Zone Setup dialog box for 
improved read rates.

• If possible, use medium or low density bar codes. High density bar codes 
may require a lower Threshold value in the Bar Code Zone Setup dialog 
box.

• To achieve better read rates on more difficult bar codes, lower the Quality 
level in the Bar Code Zone Setup dialog box.

• When using Anywhere bar code zones, use a PC with a 2.8 GHz processor 
or higher. This will ensure Kodak Capture Pro Software’s ability to scan at 
scanner rated speeds when bar code reading is enabled.
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Bar Code & OCR 
window

The Bar Code & OCR window allows you to scan and manipulate an image 
and create a bar code zone or OCR zone.

To access the Bar Code & OCR window:

1. Open the Job Setup dialog box.

2. Click Bar Code & OCR on the Capture tab.

NOTE: Setting eight or more bar code zones for a job may adversely affect 
your scanning speed.

Image — if desired, select a pre-existing image from the drop-down list. The 
Image drop-down list contains all the images that have been scanned for bar 
code setup. You must have at least one image in this list before you can define 
a bar code or OCR zone.

For typical job setups using bar code zones or OCR zones, a single image is 
all that is required. Multiple images are needed for job setups that have batch 
and document header sheets, each containing bar code or OCR information. 

Zones — displays the name of a bar code or OCR zone. When you click on 
one of the zones listed, the image in the display area will highlight where the 
zone is located on the image. Any bar code or OCR zone that you defined will 
be displayed on the current image, even if you defined those zones using a 
different image.
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Icons

OK — closes the dialog box and saves your settings.

Start/Scan — opens the Scan Image dialog box, which allows 
you to enter an Image name and scan an image containing bar 
codes or OCR text segments.
NOTE: Capture Pro Software will use whatever Page Setup is 

currently selected when Start/Scan is selected.
Draw region — allows you to draw a rectangle around a bar 
code or OCR text segment on the scanned image and then 
displays the Bar Code Zone Setup dialog box or the OCR Zone 
Setup dialog box.
Magnify — enlarges a portion of the image. You can enlarge 
any area on the image where you place the Magnify tool and 
click and hold.
Pan — allows you to move the image around the viewer when 
the image is larger than the Bar Code & OCR window.

Zoom in — zooms in on the image.

Zoom out — zooms out on the image.

Fit window — changes the image display so the image fits the 
Bar Code & OCR window.

Actual size — displays the image at the actual size. One 
scanned pixel equals one pixel on the Bar Code & OCR window.

Test selected bar code or OCR zone — opens the Bar Code 
and OCR Values dialog box, which allows you to view test 
results on a selected bar code or OCR zone.
Test all selected bar codes or OCR zones — opens the Bar 
Code and OCR Values dialog box, which allows you to view test 
results on all selected bar code or OCR zones.
Create barcode — enables you to create a bar code zone from 
the displayed image in the Bar Code & OCR window.

Create OCR zone — enables you to create an OCR zone from 
the displayed image in the Bar Code & OCR window.

Zone properties — opens either the Bar Code Zone Setup 
dialog box or the OCR Zone Setup dialog box, which allows you 
to view the properties of the selected bar code or OCR zone.
Delete selected zone — allows you to delete a bar code or 
OCR zone. A confirmation box will be displayed to verify your 
choice.
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Bar code and OCR 
windows context-
sensitive menu

When you right-click on an image in the Bar Code window or OCR window, a 
context-sensitive menu will be displayed. If no bar code or OCR zones are 
selected, a more limited menu will be displayed.

Cut — removes the selected bar code or OCR zone to paste into another 
image. It is not necessary to cut and paste a bar code zone or OCR zone to 
another location on the same image; just left-click on the zone and drag it to 
the new location.

Copy — copies the selected bar code or OCR zone. Copy is also useful when 
several bar code/OCR zones of the exact same properties (except for location) 
are required. After defining the first zone, use the Paste option to duplicate it. 
After creating each duplicate zone, move it by left-clicking on the zone and 
dragging it to its proper location. 

Paste — pastes a copied or cut bar code or OCR zone into the current image. 
The Paste option appears on this menu only if you have copied an image or 
text string into the clipboard. When pasting a bar code or OCR zone, the zone 
coordinates from the saved zone are used in determining the location of the 
zone. If the pasted zone is in the wrong location, you can left-click on the zone 
and move it to its proper location.

Paste is useful in conjunction with Copy when copying bar code zone 
properties to another image containing bar codes in the job.
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Test Zone and Test All Zones — attempts to read all or the selected bar code 
or OCR zones for a value. The Bar Code and OCR Values dialog box will be 
displayed. 

This dialog box provides the following information:

• Label of the bar code or OCR zone.
• Type of bar code found in the zone. If the zone is an OCR zone, the Type 

will be OCR.
• Confidence level (in a percentage) of the bar code value found.
• Orientation of the bar code or OCR zone (with 0 degrees representing a 

horizontal and right-side-up bar code or OCR).
• Value of the bar code or OCR zone.
• X and Y coordinates of the upper left corner of the bar code or OCR zone. 

The coordinates are in 1/100ths of an inch and represent the distance of the 
zone from the upper-left corner of the image.

• Width and Height of the bar code or OCR zone in units of 1/100ths of an 
inch.

NOTE: If a bar code or OCR value cannot be found for a zone, the zone is still 
included in the value list with only the label and zone coordinates 
displayed.

Zone Properties — allows you to define the properties for the currently 
selected bar code or OCR zone. The Bar Code Zone Setup dialog box or the 
OCR Zone Setup dialog box will be displayed. See the sections entitled, “Bar 
Code Zone Setup dialog box” and “OCR Zone Setup dialog box” later in this 
chapter for more information.

General Properties — allows you define properties that will apply to all bar 
code and OCR zones. This option is useful when using bar code header 
sheets for document separation and indexing that has less content than the 
rest of the pages of the document. This option can increase the performance 
of scanning into the bar code/OCR application. 

When you select this option, the General Bar Code and OCR Properties dialog 
box will be displayed. 

1. Select the Extract bar codes/OCRs from image between checkbox to 
activate this option. 

2. Enter a value in the minimum bytes field (default 1000 bytes) and the 
maximum bytes field (default 100,000 bytes). The values entered in these 
fields limit the images from which bar codes or OCR text will be read to 
only those whose size falls between these values.

3. Click OK.
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Rename Image — prompts you to rename the currently displayed image. 
When naming or renaming an image, choose an image name that is unique to 
Kodak Capture Pro Software. A file extension is not required.

NOTE: Special characters such as: “ ? * . < > \ / are not allowed in the image 
name.

Delete Image — removes the current image from the job. Before your image is 
deleted, a confirmation box will be displayed to verify your choice. If other 
images remain in the image list, then the image preceding the deleted image 
will be displayed in its place. 

Bar code and OCR zone definitions are not affected when you delete an image 
as long as you have other images on the image list. However, if the image to 
be deleted is the last image in the image list, the following message will be 
displayed: This is the last image. Deleting this image also deletes all bar 
code and OCR zones. Do you want to delete this image?

If you click Yes, all your bar code and OCR zone definitions for the job will also 
be deleted. An image must exist in the image list in order to define bar code 
and OCR zones. If you delete the last image, you also delete all the bar code 
and OCR zones.

Delete Zone — deletes the selected bar code or OCR zone. A confirmation 
box will be displayed before the zone is deleted.

Delete All Zones — deletes all the bar code and OCR zones that you defined 
for this job. A confirmation box will be displayed before the zones are deleted. 
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Scanning an image 
for bar code setup

Kodak Capture Pro Software allows you to separate pages and documents on 
your scanner with pages containing bar codes. It also allows you to create 
attachments to your documents using these bar code separators. 

Before you can use bar codes as separators, you must:

• Scan an image containing the bar codes into Capture Pro Software.

• Draw and select the bar code zones. 

• Set up your job for bar code zone separation.

Kodak Capture Pro Software allows you to scan bar code images directly into 
the Bar Code window for viewing, defining, and editing.

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select a job setup from the Job Name drop-down list.

3. Open the Capture tab and select Separation>By Bar Code Zones. The 
Bar Code window will be displayed.

4. Select the green Start/Scan button. The Scan Image dialog box will be 
displayed.
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5. Position the original in the feeder and click Start/Scan. The image will be 
displayed in the dialog box. Scan the image as straight as possible. Your 
scanner will use the parameters of the current Kodak Capture Pro 
Software page setup.

NOTES: 

• Any auto-rotation, auto-cropping and deskew settings from the current 
template will also be applied to the scanned image before it appears.

• If the image is acceptable, enter a name in the Image Name field. The 
image name should not contain any of the following special characters:
 : “? * . < > \ / . 

• To discard the image, click Cancel.

6. Click OK to save the image. 

NOTES:

• Before you can define a bar code, you must save at least one image in the 
Image drop-down list.

• You can also transfer an image from the Image Viewer to the Bar Code 
window. See the section entitled, “Transferring an image to the Bar Code 
window” later in this chapter.
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Creating and selecting a 
bar code zone

Before you can use a bar code image for indexing or separation to separate 
documents or batches, you need to create and select a bar code zone. Bar 
code zones are created to indicate where to look for a bar code that satisfies 
your bar code zone properties.

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select a job setup from the Job Name drop-down list.

3. Open the Capture tab and select Separation>By Bar Code Zones 
settings. The Bar Code window will be displayed.

4. Select an image from the Image drop-down list. If you need to scan the 
image, click the green Start/Scan icon on the Bar Code window. 

NOTES:

• Place the mouse cursor at the top-left corner of the area of the image 
where you want to define the location for this bar code zone.

• Bar code zones are specific to a particular job; not a specific image. 
Therefore, when you create a new image, Kodak Capture Pro Software 
will display the zones that you defined using previous images.

• When drawing the location for a bar code zone, leave a border area of 
approximately 1/4-inch around the bar code. This border is often 
necessary for successful bar code reading. Bar code zone locations can 
overlap.

5. Click the left mouse button and drag the cursor to draw a rectangle around 
the area of the bar code. Bar codes defined with the Zone position 
selected on the Bar Code Zone Setup dialog box will be enclosed in a red 
box while those defined with Anywhere will be enclosed in a blue box. 
After you draw the rectangle and release it, the Bar Code Zone Setup 
dialog box will be displayed. 

6. In the Zone name field, enter a name for the new bar code zone. You must 
create a name in order to save the zone.

7. After entering your other settings, click OK to close the dialog box and 
return to the Bar Code window. See the next section, “Bar Code Zone 
Setup dialog box” for field descriptions.

8. Click OK to save your settings and close the Job Setup dialog box. 
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Bar Code Zone Setup 
dialog box

Use this box to name your bar code zone and describe how to recognize a 
valid bar code for this zone, and specify any separation to be done by this bar 
code.

Zone name — enter the name for your new bar code zone. This name 
identifies the bar code and appears in Index setup as BC_[zonename] in the 
list of default values. The bar code Label does not define or identify a Kodak 
Capture Pro Software Index field.

Side: Front or Back — select whether the bar code is located on the front or 
back of an image.

Keep bar codes with mask — use this option when one or more Anywhere 
bar code zones are defined. The bar code value is only retained for the defined 
zone when it complies with the mask specified in the Keep bar codes with 
mask field. This ensures that the bar code values read on a page are assigned 
to the correct bar code zone.

This option is also useful when more than one bar code zone is in the same 
physical location on a page but have different values and meanings (e.g., a 
zone defined for a batch header sheet versus a zone defined for a document 
header sheet). To comply with a specified mask, each character of the bar 
code value must match the mask syntax for that character’s position in the 
mask. 

For example, a mask of A<8> will retain a bar code value of up to, but not 
exceeding, eight alphabetic characters:

Bar Code Value Retained?
SURGERY Yes
ADMISSION No

if applicable, enter a mask value.
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Minimum length — enter a number for the minimum length of the bar code 
value. By default, this option is set to the length of the tested bar code value. If 
a value is not found or the value is equal to or greater than six characters, the 
default will be set to “6.” It is recommended that the minimum length parameter 
be set at six characters or fewer to allow Kodak Capture Pro Software to retain 
bar code values in cases of a partial reading.

If the Partial Reading option is not required or enabled, then the mask and 
minimum length settings can be used in combination to restrict even further the 
bar code values that are retained. 
For example:
Mask: 9(10)
Minimum bytes: 6

retains bar code values between six and ten digits, while

Mask: 9(10)
Minimum length: 10

retains bar code values only if they are exactly ten digits. 

Bar code width and Bar code height — if the bar code has a fixed length or 
height, enter these values in 1/100ths of an inch. An entry in one or both of 
these fields increases the performance of bar code reading. If one of the 
dimensions is variable, enter 0. The default is 0.

Bar code dimensions can vary depending on the amount of skew. Therefore, it 
is recommended that you enter these values only when you are sure of the 
dimensions of the bar code.

NOTE: You must specify a bar code height for bar codes that are smaller than 
40 pixels high (e.g., at 200 dpi, 40 pixels is 20/100ths of an inch).

When specifying a bar code width and/or height, the tolerance is ±10% 
(e.g., if you specify 20/100ths of an inch for the bar code height, any bar code 
between 18/100ths of an inch and 22/100ths on an inch will be detected). 

Type — you may also select additional bar code types that will be considered 
valid for this bar code zone. Although it is unusual that more than one bar code 
type would be found within a zone, it is possible to select multiple bar code 
types. For more information on bar code types, see the section entitled, “Bar 
Code types” later in this chapter. 

The more bar code types you select, the slower your scanning performance. 

When you draw a bar code location, Kodak Capture Pro Software searches 
the location for all bar code types. When successful, the software sets the bar 
code type to the one found. Otherwise, a bar code type is not selected. There 
are two exceptions:

• For Code 39 Extended and Code 39 HIBC bar codes, Capture Pro Software 
may set the bar code type to Code 39. As a result, you may need to 
manually select Code 39 Extended and Code 39 HIBC.

• For MSIPH bar codes, Capture Pro Software may set the bar code type to 
MSI. As a result, you may need to manually select MSIPH.
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Bar code zone dialog box 
(continued)

Verify checksum — check this box if the bar code contains a checksum 
character. Checksum characters help ensure the accuracy of bar code 
reading. Not all bar code types support checksum verification. Bar code types 
that optionally support checksum verification include:

Code 3 of 9
CODABAR
Interleaved 2 of 5

Some bar code types like PDF417, UPC and EAN have a built-in checksum 
routine that cannot be disabled.

If you disable Verify checksum for bar codes containing a checksum, the 
checksum value (usually the last character of the bar code) will appear in the 
bar code value; otherwise, the check digit will remain hidden.

If checksum verification fails during scanning, a bar code value is not 
generated, causing Kodak Capture Pro Software index field audits to fail. 
Some bar code types, such as Code 128, have mandatory checksum 
characters. The code is always present and must be correct for the value to be 
read. Other codes such, as Code 39, have optional checksum characters 
which then add an additional code when present. 

To read invalid Code 128 symbols, you can select the Minimum partial read 
characters option. It will report the data characters even if checksum fails. The 
invalid checksum will not be returned. When the bar code has an optional 
checksum, it will not be validated by the software. It will operate based on the 
bar code specification. 

Selecting Minimum partial read characters for a bar code with an optional 
checksum will return what it finds, whether it is good or bad. There will be 
occasions when the bar code returns the correct result but the checksum itself 
fails. Since the checksum is implicit, it is not returned and cannot be directly 
tested.

Minimum partial read characters — check this box when you want Capture 
Pro Software to generate a bar code value, even if a bar code is incomplete. If 
this option is checked, enter the minimum number of characters that will be 
allowed for a partial read. This is useful for bar codes that are only used for 
document or batch separation where the absolute value is less critical.

For indexing purposes, it is recommended that you define field masks and 
minimum lengths. Kodak Capture Pro Software will not produce any bar code 
value if the bar code is incomplete and the Minimum partial read characters 
field is disabled.

Minimum partial read characters should not be used when Verify 
checksum is enabled, as this may result in a bar code value being generated 
when checksum verification fails. 
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Bar code zone dialog box 
(continued)

Orientation — select an orientation option from the drop-down list. If your bar 
codes all share the same orientation (e.g., all horizontal or all vertical), it is 
recommended that you indicate the specific orientation; this will increase bar 
code read and scanning performance.

If your bar codes are predominantly in the same orientation (e.g., horizontal) 
but may have an occasional bar code in the opposite direction (e.g., vertical) it 
is recommended that you use the appropriate "and" orientation (e.g., 
Horizontal and Vertical). 

When the bar code zone is first created, Kodak Capture Pro Software 
automatically sets the orientation to the orientation of the bar code, if found. 
Horizontal is the default. 

Confidence — enter a confidence ratio number to restrict what Kodak Capture 
Pro Software considers a successful bar code read. For example, the higher 
the value you enter, the chance of misreading bar codes will be reduced.

Quality — select a quality setting between Worst and Best. The highest 
quality bar codes are printed by a laser printer or pre-printed with an offset 
printer. Lower quality bar codes are printed with inkjet or dot-matrix technology. 

Depending on the quality of bar codes being scanned, set the Quality level 
accordingly. The higher the quality setting, the faster the bar code read 
performance.

Position — select Anywhere or Zone. 

• Anywhere: when creating a zone for an Anywhere bar code, draw a 
location around one bar code somewhere on the page, and select the 
Anywhere option. This situation often occurs when bar codes may be found 
at unpredictable locations on documents. When looking for Anywhere bar 
codes, Kodak Capture Pro Software searches the image from top to bottom 
for horizontal and vertical bar codes. This search order is important to 
understand if you have more than one Anywhere bar code on a page or 
zone. 

• Zone: increases bar code reading and scanning performance and is the 
default setting. 

Alternatively search on the reverse side — checking this option increases 
document/batch separation and indexing accuracy when pages are 
accidentally reversed before scanning.

Alternatively search on 180° rotated images —can only be used when the 
Zone option is enabled. When bar code reading is unsuccessful, Kodak 
Capture Pro Software will also look for the zone after rotating an image 180 
degrees. This slows down bar code reading and scanning, but prevents a bar 
code read failure because a page was scanned upside down. The image is not 
permanently rotated unless the Rotate based on bar code option is selected. 

Rotate based on bar code — Kodak Capture Pro Software can determine if a 
bar code is rotated 180 degrees and will rotate the bar code page 180 degrees 
to display it in the correct orientation. This option is used for document 
separation, all of the pages of the document will be rotated in the same 
manner as the lead page containing the bar code zone. If required, only one 
bar code zone should have the Rotate based on bar code option enabled. 

Kodak Capture Pro Software can determine if a bar code is rotated 180 
degrees and will rotate the bar code page 180 degrees to display it in the 
correct orientation.

NOTE: Batch rotation is not supported in Capture Pro Software.
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Separation — the following options are available:

• Create a new batch — all images after the separation go into a new 
document in a new batch.

• Create a new document — all images after separation go into a new 
document in the current batch.

• Next page stays in current document — the next page after the 
separation remains in the current document.

• Only separate when change in value — the software separates by a 
document or batch only if a value changes.

• No separation — select Batch level or Document level for the bar code 
zones:

- Batch level: bar codes that are located on the Batch level or that separate 
batches are available for Batch and Document indexing. Batch level bar 
codes are only read when they are present on a Batch Header page. A 
Batch Header page exists whenever batch separation is defined using 
patch codes or bar codes (at least one bar code zone in the job is 
configured for batch separation). 

- Document level: bar codes that are located on the Document level or that 
separate documents are available for Document indexing. They are not 
available for Batch indexing.

• Delete Page — select this option to delete the page containing the bar code 
that started the new document. This is important when inserts are used for 
the purpose of document separation and do not contain any significant 
information. The bar code, however, is still available for Document level 
indexing.
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Separating documents 
with bar code zones

Kodak Capture Pro Software allows you to separate documents with bar code 
zones within a batch:

1. Select File>Job Setup and select a job and batch. 

2. Open the Capture tab and select Separation>By Bar Code Zones. The 
Separation by Bar Code Zone window will be displayed.

3. Select an existing bar code zone or define a new bar code zone. 

4. Right-click the mouse button to display the context-sensitive menu and 
click Zone Properties. The Bar Code Zone Setup dialog box will be 
displayed.

5. Under Separation, select Create a new document.

6. Check the Delete page option if you want to delete the page containing the 
bar code that started the new document.

7. Fill in the Keep bar codes with mask and/or Minimum length fields if you 
want to restrict document separation to a specific bar code value or mask.

8. Select Rotate based on bar code if you want to rotate all pages in the 
document in the same orientation as the orientation of the bar code on the 
Document Header. Rotating the document based on the bar code does not 
work when the bar code separator page is deleted.

For example: 

Mask = ”ER”9(8)”-”999 Minimum length = 14: Only bar code values with a 
length of 14 characters, starting with the string “ER” followed by eight 
numeric characters, a hyphen and three numeric characters start a new 
document. 

For instance, the patient number bar code on the cover sheet of a folder 
starts a new document. The patient number can, in that case, also be used 
as a document index. If a bar code in the same zone creates a batch with a 
certain value and a document with another value, two zones must be drawn 
on top of each other. 

9. After entering your other settings, click OK to close the dialog box and 
return to the Separation by Bar Code window.

10. Click OK to save your settings and exit the Job Setup dialog box. 
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Separating batches with 
bar code zones

To separate batches with bar code zones:

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select a job setup from the Job Name drop-down list and open the Capture 
tab.

3. Select Separation>By Bar Code Zone. The Separation by Bar Code 
Zone window will be displayed.

4. Select an existing bar code zone or define a new bar code zone.

5. Right-click the mouse button to display the context-sensitive menu and 
click Zone Properties. The Bar Code Zone Setup dialog box will be 
displayed.

6. Under Separation, select Create a new batch.

7. Click OK to exit the dialog box and return to the Separation by Bar Code 
window.

8. Click OK to save your settings and exit the Job Setup dialog box.

NOTES:
• Bar code zones to be used for batch level indexing are only read when they 

are present on a Batch Header page.

• A Batch Header page exists whenever batch separation is defined using 
patch codes, bar codes, or OCR zones (at least one zone in the job is 
configured for Batch separation).

Editing a bar code 
zone

To edit an existing bar code zone: 

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select a job setup from the Job Name drop-down list.

3. Open the Capture tab and select Separation>By Bar Code Zones. The 
Separation by Bar Code Zone window will be displayed.

4. Click on the bar code zone that you want to change, or click on the bar 
code zone name in the list on the right side of the Separation by Bar Code 
Zone window. 

5. Right-click the mouse button to display the context-sensitive menu and 
click Zone Properties. The Bar Code Zone Setup dialog box will be 
displayed.

6. After you change your settings, click OK to close the dialog box.

7. Click OK to save your settings and close the Job Setup dialog box. 

8. After editing a bar code zone, test the bar code to verify that it is still 
readable. 
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Deleting a bar code 
zone

To delete an existing bar code zone: 

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select a job setup from the Job Name drop-down list.

3. Open the Capture tab and select Separation>By Bar Code Zones. The 
Separation by Bar Code Zone window will be displayed.

4. Click on the bar code zone that you want to delete. You can also click on 
the bar code zone name in the list on the left side of the Bar Code window. 
The zone is highlighted.

5. Click Delete. 

6. Click OK to save your setting and close the Job Setup dialog box. 

Transferring an 
image to the bar code 
window

Kodak Capture Pro Software allows you to transfer an image containing bar 
codes from the Image Viewer into the Bar Code window for creating bar code 
zones. 

To transfer a bar code image:

1. In the Main window, scan your image containing the bar code.

2. Locate and right-click on the image you want to transfer in the Image 
Viewer.

3. Select Copy Image to Job Setup. The Copy Image to Job Setup dialog 
box will be displayed.

4. Enter the new image name in the Save image as dialog box.

5. Click OK. You can now view the image in the Bar Code window and use it 
to create a bar code zone.

You can also directly scan bar code images into the Bar Code window. See the 
section entitled, “Scanning an image for bar code setup” earlier in this chapter.
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Setting the range for 
bar code image size

When you define bar code zones, every page you scan will be checked to see 
if it contains those bar codes. This checking can slow scanning performance. If 
your bar code pages always have about the same byte count size, and if that 
size is different from other pages you scan, you can indicate to the software 
that only images within a particular size (byte count) range need to be checked 
for bar codes. That setting can speed up scanning performance.

To set an image range for bar code images: 

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select a job setup from the Job Name drop-down list and open the Capture 
tab.

3. Select Separation>By Bar Codes. The Bar Code window will be 
displayed.

4. Select any image and right-click on a bar code zone. The General Bar 
Code and OCR Zone Properties dialog box will be displayed.

NOTE: If a bar code zone does not exist, this option will not be available 
until a bar code zone is defined.

5. Set a range for minimum and maximum image size.

6. After you make your settings, click OK to close the dialog box and return to 
the Bar Code window.

7. Click OK to save your settings and close the Job Setup dialog box. The 
new image range is now saved.

8. After editing a bar code zone test the bar code zone to verify that it is still 
readable. 

NOTE: When scanning both color/grayscale and black and white images, 
specify the range of the black and white image.
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Creating an 
attachment with bar 
code zones

To create an attachment with a bar code:

1. Select File>Job Setup and select a job and open the Capture tab. 

2. Select Separation>By Bar Code Zones. The Bar Code window will be 
displayed.

3. Select an existing bar code zone or define a new bar code zone. 

4. Right-click the mouse button to display the context-sensitive menu and 
click Zone Properties. The Bar Code Zone Setup dialog box will be 
displayed.

5. Under Separation, select Next page stays in current document. This 
option is only valid for one attachment page. If multiple attachments are 
required, then an attachment bar code must be applied to each 
attachment. The bar code on the attachment page is not available for 
indexing.

6. Check the Delete page option to delete the page (both front and rear) 
containing the bar code and to use the next page as the attachment. This is 
useful when inserts are applied indicating whether the next page is an 
attachment. Any rotation will apply to the next page.

7. Fill in the Keep bar codes with mask and/or Minimum length fields if you 
want to restrict attachments to a specific bar code value or mask.

8. Select the Rotate based on bar code checkbox if you want to rotate the 
attachment (both front and rear) in the same orientation as the orientation 
of the bar code on the page.

9. Click OK to save your settings and close the dialog box.

Testing bar code 
zones 

When you define a new bar code zone from an image, Kodak Capture Pro 
Software automatically checks your zone to verify that it is readable. However, 
if you edit the bar code zone or change its properties later, it may no longer be 
readable. You can manually test your bar code zones to verify that Capture Pro 
Software can still read them.

To test an individual bar code or all the bar codes zones in a job setup:

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select a job setup from the Job Name drop-down list and open the Capture 
tab.

3. Select Separation>By Bar Code Zones. The Bar Code window will be 
displayed.

4. Click the Test All Bar Code and OCR Zones icon to test all bar codes or 
click Test Selected Bar Code or OCR Zone icon to test an individual bar 
code zone. The Bar Code and OCR Values dialog box will be displayed.

5. After viewing the values in this box, click OK to return to the Bar Code 
window.

6. Click OK to save your settings and exit the Job Setup dialog box. All your 
bar code zones have now been tested. If you make any changes to the bar 
code settings, test them again.
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Bar code types Kodak Capture Pro Software supports the following bar code types:
• Airline 2 of 5
• Barcode 32
• CODABAR
• Code 128
• Code 2 of 5 — mutually exclusive with Interleaved 2 of 5
• Code 3 of 9
• Code 39 (no stop start)
• Code 39 Extended
• Code 39 HIBC
• Code 93
• Data Matrix
• EAN 13
• EAN 8
• Interleaved of 2 of 5 — mutually exclusive with Code 2 of 5 
• MSI
• MSIPH
• PDF417 — a high-density, two-dimensional bar code type that can contain 

up to 1250 bytes of information in a few square inches. With this kind of 
density, all index data for a document can be contained in a single bar code.

• Planet (US Post Office Code)
• PostNet (Postal): cannot be selected with any other bar code type. 
• UCC Code 128
• UPC-A
• UPC-E

Special syntax for two-
dimensional bar codes

When using two-dimensional bar codes, a single bar code can be used to 
contain all the index data for a document or batch. To facilitate indexing with 
two-dimensional bar codes, a special substring syntax has been added: 

<barcode.zonename:[start;length]>
<barcode.zonename:[start;end]>
<barcode.zonename:[# of data elements, delimiter (in single quotes)]>

The delimiter can either be the actual character symbol or its ASCII decimal 
numeric value (for symbols that cannot be printed or typed). The delimiter must 
be contained in double quotes (“ “). 

For example, if a PDF417 bar code contains the following data: 
12345678*NURSERY*11/19/1962 the following could be used as default 
values for the three index fields of data: 

Default Value Actual Value
<BC.PDF417:[1, '*']> 12345678
Returns the 1st element of the bar code string delimited by an asterisk.
<BC.PDF417:[2, '42']> NURSERY
Returns the 2nd element of the bar code string delimited by an asterisk 
(42 is the ASCII decimal value for asterisk).
<BC.PDF417:[3, '*']> 11/19/1962
Returns the 3rd element of the bar code string delimited by an asterisk.
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Using OCR zones OCR (Optical Character Recognition) is the mechanical or electronic 
translation of images of typewritten or printed text (usually captured by a 
scanner) into machine-editable text.

OCR setup allows you to define:

• the name of the OCR zone
• the physical location where you find the text (zone location on the image)
• the level where you can find the text (batch or document level)

Use the Bar Code and OCR Setup function on the Capture tab on the Job 
Setup dialog box to set up the bar code reader to read one or more bar codes 
or OCR parameters for one or more OCR zones.

The OCR zone separation setting on the Capture tab in the Job Setup dialog 
box allows you to scan an image into the OCR window and define zones and 
OCR zone-specific properties. 

NOTE: The components of the Bar Code and OCR window, icons and context-
sensitive menu are described in detail in the sections entitled, “Bar 
Code & OCR window” and “Bar Code and OCR windows - context-
sensitive menu” earlier in this chapter.

OCR indexing uses local language lexicons and allows reading of 
alphanumeric text at high speed (1000 characters/second). It is zonal (similar 
to bar code reading) and is processed during scanning. 

Capture Pro Software supports the following text information for OCR:
- Ligatures (“joined” characters)
- Broken characters
- Degraded characters
- Text from 200-600 dpi resolution
- Text fonts from 8-72 points
- Numbers from 0-9
- Letters from A-Z and a-z
- Symbols ! " $ % & ( ) * + , - . / :, ; < = > ? @ [ \ ] { } £ • ß ´ ª

• For best results, use 300 dpi resolution and 12-point sans serif font (or 
larger if using resolutions lower than 300 dpi). Do not use skewed 
documents.
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• Kodak Capture Pro Software supports a wide range of languages for OCR 
indexing. To view a list of these languages:

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select a job setup from the Job Name drop-down list and open the 
Capture tab.

3. Select Separation>By OCR Zones. The OCR window will be 
displayed.

4. Click on any OCR zone and click Zone Properties. The OCR Zone 
Setup dialog box will be displayed.

5. Select the language of your text from the available languages on the 
Language drop-down list.
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Scanning an image for 
OCR setup

Kodak Capture Pro Software allows you to separate scanned pages into 
batches and documents based on OCR zones. These OCR zones also allow 
you to create attachments to your documents. 

Before you can use OCR text as separators, you must:

1. Scan an image containing the OCR text into Capture Pro Software. 

2. Create and define the OCR zones. 

3. Set up your job for OCR zone separation.

To scan an image directly into the OCR window:

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select a job setup from the Job Name drop-down list and open the Capture 
tab.

3. Select Separation>By OCR Zones. The OCR window will be displayed. 

4. Position the original in the feeder and click Start/Scan. The image will be 
displayed in the dialog box. Scan the image as straight as possible. Your 
scanner will use the parameters of the current Kodak Capture Pro 
Software page setup. 

NOTES:

• Any settings from the current job setup will also be applied to the 
scanned image before it appears.

• If the image is acceptable, enter a name in the Image Name field. The 
image name should not contain any of the following special characters:
: “ ? * . < > \ / . 

• To discard the image, click Cancel.

• Before you can define an OCR zone, you must have at least one image 
in the Image drop-down list.

• You can transfer an image from the Image Viewer to the OCR window. 
For more information, see the section entitled, “Transferring an image to 
the OCR window” later in this chapter.

5. Click OK.
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Creating and selecting 
an OCR zone

Before you can use an OCR image to separate documents or batches, you 
need to create and select an OCR zone. 

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select a job setup from the Job Name drop-down list and open the Capture 
tab.

3. Select Separation>By OCR Zones setting. The OCR window will be 
displayed.

4. Select an image from the Image drop-down list. If you need to scan the 
image, click the green Start/Scan icon on the OCR window. 

NOTE: Place the mouse cursor at the top-left corner of the area of the 
displayed image where you want to define the location for this OCR 
zone. For variable length and height OCR indexing, make sure that 
you draw the zone large enough to capture all the indexing data. At 
the same time, be careful not to draw the zone so large that stray 
data (e.g., lines on a form) are accidentally captured.

OCR zones are job-specific as opposed to image-specific. 
Therefore, displaying a new image will continue to display the zones 
you defined using earlier images.

5. Click the left mouse button and drag the cursor until a rectangle is drawn 
around the text area. After you release the cursor, the OCR Zone Setup 
dialog box will be displayed.

6. In the Zone name field, enter a name for the new OCR zone. You must 
create a name in order to save the zone.

7. After entering your other settings, click OK to close the dialog box and 
return to the OCR window.

8. Click OK to save your settings and close the Job Setup dialog box. 
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OCR Zone Setup dialog 
box

OCR zones provide Kodak Capture Pro Software with information such as 
dimensions of the zone. After you draw an OCR zone, Capture Pro Software 
attempts to read the information in the zone and automatically displays the 
OCR Zone Properties window with whatever text the software could read in the 
zone.

NOTE: The OCR function has difficulty reading italic and underlined 
characters on Asian character sets. To increase the OCR reliability, it is 
recommended that you use black and white images.

Zone name — enter a name for the OCR zone. You must name the OCR zone 
in order to save it. 

Side: Front or Back — select whether the OCR zone is located on the front or 
back of an image.

Keep OCR with mask — if applicable, enter a mask value. 

Language — ensures that Kodak Capture Pro Software properly OCR’s 
special language-specific characters (e.g., ç or ü). Use the drop-down list to 
display a list of supported languages.

Separation — the following options are available:

• Create a new batch: all images after the separation go into a new 
document in a new batch.

• Create a new document: all images after separation go into a new 
document in the current batch.

• Next page stays in current document: the next page after the separation 
remains in the current document.

• Only separate when change in value: system separates by document or 
batch only if a value changes.

No separation — select Batch level or Document level.

• Batch level: OCR zones located on the Batch level and OCR zones that 
separate batches are available for both batch and document indexing. 

• Document level: OCR zones located on the Document level and OCR 
zones that separate documents are available for document indexing. 
However, they are not available for batch indexing.

OK — closes the dialog box and returns to the OCR window.
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Separating documents 
with OCR zones

To separate documents with OCR zones:

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select a job setup from the Job Name drop-down list and open the Capture 
tab.

3. Select Separation>By OCR Zones. The OCR window will be displayed.

4. Select an image from the Image drop-down list. If you need to scan the 
image, click the green Start/Scan icon on the OCR window.

NOTE: Use your mouse to draw the OCR zone and then release it. The 
OCR Zone Setup dialog box will be displayed.

5. Under Separation, click the Create a new document option.

6. Click OK to exit the dialog box and return to the OCR window.

7. Click OK to save your settings and exit the Job Setup dialog box. 

NOTE: A Batch Header page exists whenever batch separation is defined 
using patch codes, bar codes, or OCR zones (at least one zone in 
the job setup is configured for Batch separation).

Separating batches with 
OCR zones

To separate batches with OCR zones:

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select a job setup from the Job Name drop-down list and open the Capture 
tab.

3. Select Separation>By OCR Zones. The OCR window will be displayed.

4. Select an image from the Image drop-down list. If you need to scan the 
image, click the green Start/Scan icon on the OCR window.

5. Use your mouse to draw the OCR zone and then release it. The OCR Zone 
Setup dialog box will be displayed. If you define an area on an image for 
OCR batch separation, that area should remain blank on all the other 
pages in the batch. 

6. Under Separation, click the Create a new batch option.

7. Click OK to exit the dialog box and return to the OCR window.

8. Click OK to save your settings and exit the Job Setup dialog box. 

NOTE: Batch level OCR zones are only read when they are present on a 
Batch Header page. A Batch Header page exists whenever batch 
separation is defined using patch codes, bar codes or OCR zones (at 
least one zone in the job setup is configured for Batch separation). 

For information about separating batches with color/grayscale scanning, see 
“Using separators when color scanning” later in the chapter.
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Editing OCR zone 
properties

To edit or change an existing OCR zone: 

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select a job name from the Job Name drop-down list and open the Capture 
tab.

3. Select Separation>By OCR Zones. The OCR window will be displayed. 

4. Click on the OCR zone that you want to change, or click on the OCR zone 
name in the list on the left side of the OCR window.

5. Right-click the mouse button to display the context-sensitive menu and 
click Zone Properties. The OCR Zone Setup dialog box will be displayed.

6. After you change your settings, click OK to close the dialog box and return 
to the OCR window.

7. Click OK to save your settings and exit the Job Setup dialog box.

After editing an OCR zone, test the OCR zone to verify that it is still readable.

Deleting an OCR 
zone

To delete an existing OCR zone: 

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select a job setup from the Job Name drop-down list and open the Capture 
tab.

3. Select Separation>By OCR Zones. The OCR window will be displayed.

4. Click on the OCR zone that you want to delete. You can also click on the 
OCR zone name in the list on the left side of the OCR window. The zone is 
highlighted.

5. Click Delete. 

6. Click OK. 

Transferring an 
image to the OCR 
window

You can scan an image containing text for OCR directly into the Image Viewer 
and then transfer it to the OCR window to create an OCR zone.

1. Scan your image containing the OCR text.

2. Locate the image in the Image Viewer and right-click on it.

3. Select Copy image to job setup. The Copy Image to Job Setup dialog 
box will be displayed.

4. Enter the new image name in the Save image as field.

5. Click OK.
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Setting the range for 
OCR image size

Sometimes an OCR image is too small to be a readable image. You can set an 
image range size to exclude images that are too small.

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select a job setup from the Job Name drop-down list and open the Capture 
tab.

3. Select Separation>By OCR. The OCR window will be displayed.

4. Select any image and right-click on the OCR zone. The General Bar Code 
and OCR Zone Properties dialog box will be displayed.

NOTE: If an OCR zone does not exist, this option will not be available until a 
OCR zone is defined.

5. Set a range for the minimum and maximum image size and click OK.

6. Click OK on the Job Setup dialog box.

7. After editing an OCR zone, test your OCR zone to verify that it is still 
readable. 

Creating an 
attachment with OCR 
zones

Creating attachments is useful in jobs where typically every page is a 
document (e.g., transaction documents, such as; checks, airline tickets, 
invoices, etc.), but there is occasionally a page (such as a corresponding 
memo) that needs to be appended to a document.

To append an attachment manually to a document:

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select a job name from the Job Name drop-down list and open the Capture 
tab.

3. Select Separation>By OCR Zones. The OCR window will be displayed.

4. Select an image from the Image drop-down list. If you need to scan the 
image, click the green Start/Scan icon on the OCR window. 

5. Using the cursor, define the OCR zone on the image where you expect to 
find the OCR text. The area defined for the OCR attachment should be 
blank on all other pages in the batch. The OCR Zone Setup dialog box will 
be displayed.

6. Under Separation, select Next page stays in current document. This 
option is only valid for one attachment page. If multiple attachments are 
required, then an attachment OCR zone must be applied to each 
attachment. The OCR zone on the attachment page is not available for 
indexing.

7. Check Delete page to delete the page (both front and rear) containing the 
OCR zone and to use the next page as the attachment. This is useful when 
inserts are applied indicating whether the next page is an attachment.

8. Click OK to save your settings and close the dialog box.
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Testing OCR zones When you define a new OCR zone from an image, Kodak Capture Pro 
Software automatically checks your zone to verify that it is readable. However, 
if you edit the OCR zone or change its properties later, it may no longer be 
readable. You can manually test your OCR zones to verify they are still 
readable.

1. Select File>Job Setup. The Job Setup dialog box will be displayed.

2. Select a job setup from the Job Name drop-down list and open the Capture 
tab.

3. Select Separation>By OCR Zones. The OCR window will be displayed. 

4. Click the Test All Bar Code and OCR Zones icon to test all OCR zones or 
click Test Selected Bar Code or OCR Zone to test an individual OCR 
zone. The Bar Code and OCR Values dialog box will be displayed.

5. After viewing the values in this box, click OK to return to the OCR window.

6. Click OK. If you make any changes to the OCR zone settings, test them 
again.

Using separators 
when color scanning

Kodak Capture Pro Software can scan color, grayscale, and black and white 
images with separators (bar code zones, OCR zones or patch codes). Images 
can be separated or mixed together. To separate these color/grayscale images 
quickly and reliably, Capture Pro Software uses their duplicate black and white 
images for reading the separators.

When scanning both color/grayscale and black and white images and the 
software detects a bar code zone, patch code, or OCR zone, the software 
either deletes all four page images (color front, color back, black and white 
front, and black and white back) or attaches them to the new or current 
document or batch. This action will be determined by the settings in the Bar 
Zone Code Setup dialog box, Patch Code setup, or OCR Zone Setup dialog 
box.

When you are scanning only color/grayscale images, the software reads the 
duplicate black and white images. While these black and white images are 
never displayed or outputted, they are used for bar code reading, patch code 
reading, and OCR indexing.



6-32 A-61635   July 2009 

Setting up a color 
image for bar code/
OCR zones 

Kodak Capture Pro Software is capable of using color or grayscale images as 
a source for bar codes or OCR text. However, the performance and reliability 
of Capture Pro Software will be enhanced if you use a black and white image 
instead as a source.

To capture a black and white image for the creation of bar code zones or OCR 
zones:

1. Select Capture>Page Setup List. The Page Setup List dialog box will be 
displayed.

2. Select a simultaneous scanning page setup from the list (e.g., Color and 
Black & White - 200 DPI - Delete Blanks).

3. Place the color/grayscale original in the scanner and click the green Start/
Scan icon. The images will be displayed in the Image Viewer.

4. Select the black and white image containing bar codes and OCR zones 
and click the right mouse button to display the Image context-sensitive 
menu.

5. Select Edit>Copy Image to Bar Code/OCR setup. The Copy Image to Job 
Setup dialog box will be displayed.

6. Enter the new image name in the text box and click OK.

7. Click File>Job Setup. The Job Setup dialog box will be displayed.

8. Open the Capture tab and select either Separation>By Bar Code Zones 
or Separation By OCR Zones. Depending on your selection, the Bar 
Code or OCR window will be displayed.

9. The new image name will be displayed in the Image drop-down box. 
Follow the procedures for defining a bar code zone or OCR zone described 
in the previous chapter. 

10. Click OK.
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Bar Code and OCR 
Disclaimers

Copyright 2000-2007, AllMyPapers, All Rights Reserved.

This product includes OmniPage/-E OCR software © 1994-2006 Nuance 
Communications, Inc. All Rights Reserved.

The following OCR and bar code-related disclaimer conditions apply to Kodak 
Capture Pro Software.

Although the product uses state-of-the-art OCR and bar code technology, 
accurate recognition under all conditions cannot be guaranteed. All software 
and documentation are delivered as such without any express or implied 
warranty of OCR and bar code recognition accuracy.

Kodak and its suppliers shall not be liable for any direct or indirect misuses and 
or damages subsequent to illegal use or infringement caused by the user in 
modifying, copying, reproducing, or translating any part of information 
retrieved with OCR and bar code recognition technologies in Kodak Capture 
Pro Software.
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7  Page Setup 
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Page Setup dialog 
box

Use the Page Setup dialog box to define image scanning parameters, 
automatically delete images, split images or merge images.

To access Page Setup click File>Page Setup.

Page Setup Name — select an existing Page Setup from the drop-down list.

Icons
Add: displays the Save As dialog box, which allows you to add a 
new page setup.

Rename: displays the Rename dialog box which allows you to 
rename the currently selected page setup. 

Delete: displays a confirmation box which allows you to delete 
the selected page setup. 



7-2 A-61635   July 2009 

Image tab — allows you to define the way images will be displayed after 
scanning.

Auto Delete tab — allows you to automatically delete a scanned image if it 
exceeds the settings entered on this tab.

Split tab — allows you to automatically split a scanned image if it exceeds a 
certain width. 

Merge tab — allows you to merge the front and back images of a scanned 
page into a single image. 

OK — saves your settings and closes the dialog box.

Cancel — closes the dialog box without saving any changes. 

Apply — accepts the changes made in the dialog box without closing the 
dialog box.

Image tab The Image tab allows you to set up scanning parameters and make changes to 
your images before they are stored.

Settings — when you click Settings, the TWAIN Datasource will be displayed 
allowing you to configure your scan settings. For more specific scanner 
information, see the User’s Guide for your scanner. 

Display settings prior to scanning — opens the TWAIN Datasource after 
you click the green Start/Scan icon.

Flatbed delay — sets a timed delay between scans so the operator can open 
a different page on a book or magazine and place it back on the flatbed. Select 
the number of seconds for the delay from the drop-down list.

Software rotation — automatically rotates the image after scanning. Select 
None, 90, 180, or 270 degrees. As you enter a different setting, the icon will 
display how the image would look after rotation. Setting up this rotation in the 
TWAIN Datasource may give better scanning performance than using software 
rotation.
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2-sided mode — select Classic or Calendar mode from the drop-down list for 
two-sided scanning and the corresponding icon will be displayed. Compare 
your original image with the icon to determine if it has a classic or calendar 
layout.

• Classic: typically used for multi-page reports. The 2-sided mode option 
only influences the way the front image is rotated in relation with the back 
image. It does not set the overall rotation of the document (0°, 90°, 180° or 
270°).
When using Classic: 2-sided mode, the front and rear images correspond 
as follows:

A 0° rotated front results in a 0° rotated back.
A 180° rotated front results in a 180° rotated back.
A 90° rotated front results in a 270° rotated back. 
A 270° rotated front results in a 90° rotated back.

• Calendar: typically used for presentation handouts, financial reports, wall 
calendars, etc. The 2-sided mode option only influences the way the front 
image is rotated in relation with the back image. It does not set the overall 
rotation of the document (0°, 90°, 180°, or 270°).

• When using the Calendar: 2-sided mode, the front and rear images 
correspond as follows: 

A 0° rotated front results in a 180° rotated back.
A 180° rotated front results in a 0° rotated back.
A 90° rotated front results in a 90° rotated back. 
A 270° rotated front results in a 270° rotated back.

Image order — select an image and use Move Up or Move Down to change 
the image order listed in the box.

Overcrop — enable this checkbox to trim all edges of the image by the 
amount you specify in 1/100ths of an inch.

OK — saves your settings and closes the dialog box.

Cancel — closes the dialog box. Your entries are not saved. 

Apply — accepts the changes made in the dialog box.
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Auto Delete tab The Auto Delete tab allows you to set options for automatically deleting an 
image. You may want to delete images with no content, or possibly very busy 
pages (e.g., the back of a form which has a lot of explanatory text on it). Auto 
deletion settings are specified independently for front and back images. 

If you are doing simultaneous scanning of both color/grayscale and black and 
white image types, auto deletion settings are also set independently. 
Therefore, you can choose to delete one type of image or both.

When using Auto Delete, it is recommended that you scan some 
representative documents which you would want to delete by using the Test 
option. The results of the Test option will help you determine if you should set 
the auto delete values using the Image size (byte) is option or the Image 
content (%) option. For more information see the next section “Testing your 
settings”. 

• Image size (byte) is Above — select this option if you want to delete pages 
with a lot of busy, explanatory content on them. For example, if you are 
scanning documents with similar content (e.g. insurance forms) on the front 
and back page, and the front page has content you need to keep, but the 
back page contains instructions on how to file a claim (that you do not need 
to keep), enter the number of bytes that you want Capture Pro Software to 
delete any image file greater than that amount. Any image that is more than 
this value will be considered too large and will be deleted. 

• Image size (byte) is Below — select this option if you want to delete pages 
with no content or very little content. Enter the number of bytes that Capture 
Pro Software will consider the image size to be blank. Any image that is less 
than this value will be considered blank and will be deleted.
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• Image content (%) is Above — this option is similar to the Image size 
(byte) Above option except that you enter a percentage value that Capture 
Pro Software will consider the image to have too much content. Any image 
more than this will be deleted. 

• Image content (%) is Below — this option is similar to the Image size 
(byte) Below option except that you enter a percentage value that Capture 
Pro Software will consider the image to be blank or too little content. Any 
image that is less than this value will be considered blank and will be 
deleted. Use this setting when there are blank pages. 

NOTE: When selecting the Image size (byte) option, other factors such as 
resolution, compression, etc., will impact the image size. 

The Image content (%) option only looks at the percentage of 
information on the image and therefore, is a more consistent and 
dependable option to use when images may vary in size, resolution, 
compression, etc.

Never — click Never, if you do not want the software to delete any images 
automatically.

Apply deletion to both images of a side — deletes both the black and white 
and color/grayscale images.

Test — displays the Test Image dialog box, which allows you scan a sample 
image and test your settings.

OK — saves your settings and closes the dialog box.

Cancel — closes the dialog box. Your entries are not saved. 

Apply — accepts the changes made in the dialog box.

Testing your settings The Test Image dialog box allows you to test your images to determine 
whether or not they meet your deletion settings. It is highly recommended that 
you test your settings to be sure that the images you want to be deleted are 
deleted and that you keep the images you want to keep.

1. Click Test on the Auto Delete tab to display the Test Image dialog box.

2. Place some documents in the scanner that are representative of the 
documents you want to test for auto deletion.
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3. Before you scan a page, select Black and White - Front, Black and 
White - Back, Color - Front, or Color - Back from the drop-down list.

NOTE: The options that are displayed in the drop-down list are dependent 
upon your Page Setup.

4. Click the Start/Scan icon. The results will be displayed in the Test result 
box.
• The image is: indicates if the image is Blank or Not Blank.
• Image size is - (bytes): the size of the test image in bytes.
• Content is - %: the percentage of content in the test image.

5. Evaluate the values displayed in the Image size is - (bytes) and/or 
Content is - % Test results box.

NOTE: Based on the value displayed in the Test results box you may want 
to enter a value slightly lower or slightly higher than the displayed 
value depending on the desired output. For example, if your 
representative image byte size of blank images is 799 bytes and 
almost blank images is 900 bytes, you may want to enter a value of 
850 bytes in the Image size is - (bytes) field on the Auto Delete tab.

6. Click OK.

NOTE: During the test image scan, options to Split and Merge will be ignored.

Splitting images Splitting images is frequently used in forms processing. When scanning folded 
forms, you may want them to be split in several smaller images to make forms 
registration and verification more reliable. Kodak Capture Pro Software splits 
the images, sorts the images, and extracts data from the images in the correct 
sequence.

The split occurs only on pages that comply with a minimum and maximum 
width expressed in 1/100ths of an inch. The split operation is a vertical split, 
meaning that the page is divided into equal left, middle, and right portions (if 
splitting three ways). The split occurs after rotation. When scanning large 
forms that cannot be scanned in landscape mode because they are wider than 
the scanner transport, rotation is required.

Set the Software rotation option on the Image tab of the Page Setup dialog 
box depending on how you scan the document.

After the split, odd-numbered images will be considered front images and 
even-numbered images will be considered rear images. Because Capture Pro 
Software immediately shows the result after merging or splitting, you can test 
your page setup and make changes if necessary.

If you are scanning one-sided images (or when you are scanning from the 
flatbed), the split will occur only on the front image.
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Splitting an image To split images during scanner:

7. Click the Split Page or Image checkbox.

NOTE: The Merge and Split options cannot be active at the same time. To 
disable the Merge option, open the Merge tab and uncheck the 
Merge front and back into one single image checkbox.

8. Choose from 2 to 12 images in the Number of resultant images drop-down 
list.

9. Select a range of widths for the page or image from the Split image if width 
is between field. If the page width falls within this range, it will be split. If 
either the front or back side falls outside the range, neither side will be split.

10. Select Front and/or Back to activate a split. A graphic will be displayed 
showing your selection. For example, if you enable both checkboxes, the 
icons will appear with a red "X" on each page.

Click on each image segment in the order you want the images to be 
output. As you click on an image segment, the red "X" disappears.

Any image segment that is still marked with a red "X" will be deleted and 
not sent to output. This option might be useful for the last page of a 
pamphlet that is always blank.

NOTE: When using a simplex-only scanner, selecting both Front and 
Back will result in no split. Select Front only to cause a split.

11. If desired, click Reset order to delete the output order and start again.

12. Click OK to save your settings and close the Page Setup dialog box. 



7-8 A-61635   July 2009 

Merge tab To merge images during scanning:

1. Click the Merge front and back image into one single image checkbox.

NOTE: The Merge and Split options cannot be active at the same time. To 
disable the Split option, open the Split tab and uncheck the Split 
Page or Image checkbox.

2. Set the minimum and maximum image widths and heights in 1/100ths of 
an inch for front and back images to be merged in the if width is between 
and the if height is between fields. Capture Pro Software merges only the 
images that meet these parameters. Any other images are not merged. 

3. Click Horizontal or Vertical for the desired orientation on the merged 
image.

4. Click Front, Back or Back, Front for the desired order of the front and 
back on the merged image.

5. Click OK to save your settings and close the Page Setup dialog box. 
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8   Productivity Shortcuts

Contents Shortcut Setup dialog box..........................................................................8-1
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Shortcut Setup 
dialog box

This dialog box allows you to create a job shortcut name. You can also use this 
dialog box to select or change the page and job setups associated with it.

Job Shortcut — select a job shortcut name from the drop-down list. You can 
also use the icons to add, rename, or delete a job shortcut.

• Add: displays the Save As dialog box which allows you to add a new job 
shortcut.

• Rename: displays the Rename dialog box which allows you to rename the 
currently selected job shortcut.

• Delete: displays a confirmation box which allows you to delete the selected 
job shortcut.

Page Setup — select from the list of available page setups or click Setup to 
display the Page Setup dilaog box and create a new page setup.

Job Setup —  select from the list of available job setups or click Setup to 
display the Job Setup dilaog box and create a new job setup.

OK — closes the dialog box and saves your changes.

Cancel — closes the dialox box without saving your changes.

Apply — saves your changes without closing the dialog box.

Button Manager When scanning shortcuts have been created, you can assign each shortcut 
name to a particular value for the Scanner button (if your scanner has buttons). 
You can assign up to 9 buttons.

Button 1 through 9 — select the action you want the scanner to take from the 
drop-down list. The default is no action.

Shortcut Setup — displays the Shortcut Setup dialog box which allows you to 
assign a Job Shortcut name, Page Setup and Job Setup.

OK — closes the dialog box. All the entries you made are saved.

Cancel — closes the dialog box. Your entries are not saved.

To launch the Button Manager:

• Right-click on the Kodak Capture Pro Software icon located in the system 
tray and select Button Setup.
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User Setup dialog 
box

The User Setup dialog box allows an administrator to set up and manage 
users of Kodak Capture Pro Software. The user setup functions can only be 
set by individuals with Capture Pro Software administrator access.

To access User Setup, select File>User Setup. The User Setup dialog box will 
be displayed.

The User Setup dialog box has three tabs: General, User and Group.

General tab The General tab allows you bypass the login function for a user by checking 
the Windows user ID login checkbox. 
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User tab Users and user groups can be configured in Capture Pro Software to limit 
access to specific jobs and Capture Pro Software functions.

Adding a new user To add a new user: 

1. Select File>User Setup.

2. Open the User tab.

3. Click New. The New User dialog box will be displayed.

4. Enter the name of the user in the User name field.

5. Enter a password for this user in the Password field.

6. Re-enter the password and click Create. This user is automatically added 
to the list.

NOTE: The user can change this password by selecting File>Change 
Password.
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Adding a user to a group To add a user to group:

1. Select File>User Setup and open the User tab. The User Setup dialog 
box will be displayed.

2. Select a user name from the User name drop-down list.

3. Select a group name from the Add to Group drop-down list.

4. Check Allow automatic login if you want to bypass the login function for 
Capture Pro Software and automatically login this user when Capture Pro 
Software is launched.

NOTE: If you want to login as another user, select File>Logout and then 
login as the new user.

5. Click OK. 

Deleting a user To delete a user:

1. Select File>User Setup and open the User tab. The User Setup dialog 
box will be displayed.

2. Select the user you want to delete from the User name drop-down list.

3. Click Delete. A confirmation box will be displayed.

4. Click Yes to complete the deletion. 

5. Click OK.

Resetting a password To reset a password for a user:

1. Select File>User Setup and open the User tab. The User Setup dialog 
box will be displayed.

2. Select the user you want to reset a password for from the drop-down list.

3. Click Reset Password. The Change Password -sysadmin dialog box will 
be displayed.

4. Enter a new password in the New password field.

5. Re-enter the password in the Confirm password field.

6. Click OK. 

NOTE: The user can change this password by selecting File>Change 
Password.
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Group tab Use the Group tab to add and delete user groups as well as add and remove 
job privileges.

Setting up a user group To set up a user group: 

1. Select File>User Setup and open the Group tab. The Group tab of the 
User Setup dialog box will be displayed.

2. Click the Add icon. The Save as dialog box will be displayed.

3. Enter a new group name and click OK. The new group name will be 
displayed in the Group Name drop down list. You can also add notes about 
the group in the Description field.

NOTE: When creating a new group, you must create the group first and 
then go to the User tab to add members to the group. 

4. Use the Add, Remove, Add All, Remove All buttons in the Members 
boxes to move users in or out of the selected group. The Members boxes 
contain all users who are eligible to be added to the group. When creating 
a new group, the Not in group and In group fields will be blank.
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5. Under Privileges: Features, select the Capture Pro Software functions, 
toolbars, and menus that you want available for members of this group. 
You can use Select All or Deselect All to make global changes. The 
default settings allow the group total access to all the software features 
and job setups.

6. Under Privileges: Jobs, select the job setups that you want available for 
members of this group. You can use Select All or Deselect All to make 
global changes.

7. Click OK.

Deleting a group To delete a user group:

1. Select File>User Setup and open the Group tab. The Group tab of the 
User Setup dialog box will be displayed.

2. Select the group that you want to delete from the Group Name drop-down 
list. 

3. Click the Delete icon. A confirmation box will be displayed. Click Yes to 
delete the group. 

NOTE: When you delete a group, the users in that group are removed 
from the group and returned to the Members: Not in Group list.

Renaming a group To rename a user group:

1. Select File>User Setup and open the Group tab. The Group tab of the 
User Setup dialog box will be displayed.

2. Select the group that you want to rename from the Group Name drop-down 
list. 

3. Click the Rename icon. The Rename dialog box will be displayed.

4. Enter the new group name and click OK.
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10   Auto Import
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Overview Auto Import allows you to import images into Capture Pro Software without 
the use of a local scanner or manual intervention. It does this by observing 
special directories called “watch folders”. Files to be imported will be copied 
into subfolders within a watch folder which are called Auto Import or AI batch 
folders. Auto import extracts images from these files and streams them into the 
Capture Pro Software workstation just as if they had originated from a local 
scanner.

To auto import files create an AI batch folder in a watch folder. The processing 
instructions for this AI batch folder have been defined in the Auto Import Setup 
process and associated with the watch folder that the AI batch folder is 
contained within. A countdown timer will then be started on the new AI batch. 
The user will copy files (which may be contained in nested subfolders) into the 
AI batch folder. Every time a new file appears anywhere in the AI batch folder 
or its subfolders, the countdown timer will be reset to its initial value and the 
countdown will begin again. If the timer expires, the AI batch folder will be 
locked and added to the end of an auto import capture queue for processing 
(see the section entitled, “Auto Import operation” for additional details 
regarding AI batch timers and processing flow).

Special batch separation rules can be specified for auto import so new batches 
can optionally be created for each new AI batch. Aside from that, processing 
will occur as in any other scan job according the job and page setup rules. 
Every AI batch will be completely processed before moving to the next.
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Auto Import Setup 1. Select Auto Import Setup from the Capture menu. The Auto Import Setup 
dialog box will be displayed.

NOTE: The settings you make on this dialog box apply to any AI batches 
created within the specified auto import location (watch folder).

2. Enter a name for this auto import setup. The name is just a user-friendly 
reference and does not refer to a folder name or any other specific 
reference.

3. Select a location for the auto import “watch folder” associated with this 
particular auto import configuration. Auto import will monitor this folder for 
the creation of new AI batch folders within it and will process the AI batch 
after the timeout interval has expired (see the section entitled, “Auto Import 
operation” for more information).
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There are several conditions that apply to the watch folder. 

• The watch folder must have Read / Write access to any user running 
Capture Pro Software. 

• The watch folder needs to be writeable from any intended image source. 
If it will be accessed from a network, the administrator needs to confirm 
that network sharing is setup to allow Write access from any users, 
network scanners or other devices which copy files into the watch folder. 

• Capture Pro Software will not attempt to configure any file share or set 
user access privileges on the watch folder. Configuration and file 
sharing is the responsibility of the administrator. 

4. Select an auto import timeout interval. This interval should be based on the 
maximum delay expected from any source which sends files to the watch 
folder. This can vary a great deal depending on the operation. For 
example:

• Network Scanner — a user has set up a Scan Station 500 to send 
images directly to a watch folder over a network. The operation consists 
of scanning a stack of paper, removing it from the scanner, picking up 
the next stack, and resuming the scan operation. There is a 60-second 
delay required to make this transition. The watch folder has been 
configured with a 120-second delay in order to allow the user to pick up 
the next stack without timing out and closing the AI batch.

• Copy images from network folder — a user has a set of files that were 
captured using another scanner (or another input source). Transferring 
them to the Capture Pro Software workstation for auto import requires a 
“copy” operation. The local network delivers images at one-second 
intervals. The timeout interval is set at 10 seconds.

Refer to the section entitled, “Auto Import operation” for more information

5. Select Create new batch when new subfolder is imported to 
automatically insert a batch separator into the input stream whenever a 
new AI batch folder is processed. 

6. Select or create a job setup to be associated with this watch folder.
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7. Select or create a page setup to be associated with this watch folder. Page 
setup options are restricted to those shown below.
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8. Select Backup the files to and specify a backup location if you want to 
archive the contents of the AI batch when auto import is complete. 

Archive will copy the entire content of an AI batch to the specified archive 
location including any unprocessed files (such as spreadsheets or word 
processing documents) in their original form along with the original image 
files. 

• A single archive location can be used for multiple watch folders. 

• You do not have to create a unique archive folder for every auto import 
setup.

9. Specify the number of errors that are allowed before auto import 
processing is interrupted. Errors occur when an image file cannot be 
properly read. These errors do not apply to indexing errors or anything else 
other than the ability to open and read the contents of a supported image 
file. If the value in Maximum allowed errors is exceeded, processing will 
stop and a dialog box will be displayed allowing the user to retry the bad 
image, skip the bad image, or abort the auto import. See the section 
entitled, “Error handling” for more information regarding error handling and 
recovery. 

10. Specify a location for unreadable files to be copied to. During auto import 
processing, if a supported file cannot be opened, a “place holder” image 
will be substituted and the erroneous image will be copied into the error 
cache.

Auto Import 
operation

NOTE: Special icons have been added to some of the folders in the following 
examples for clarity. These icons will not appear on the actual folders 
in a real auto import setup.

Following the AIDemo1 auto import setup previously described the directories 
will look like this:

To start Auto Import, the user will select Capture>Auto Import Images. This 
disables all scanners and scanner-specific setups. They will then select Start 
as if they were starting a scanner. Auto import will begin watching all 
previously defined watch folders for incoming files, actively monitors all watch 
folders and processes any new AI batch jobs in first-in, first-out order until 
Stop is selected. To resume normal scanning operations, deselect Auto 
Import Images.

NOTE: If an auto import setup becomes obsolete, it should be deleted before 
related folders are manually removed to avoid error messages.
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To create a new AI batch, a new AI batch folder will be created in the watch 
folder. 

The timer will begin to count down. After 5 seconds, no new files have been 
added to the AI batch folder (06112009_AIBatch) and the counter is now at 5.

Whenever a file appears in the AI batch folder, or any subfolder of the AI batch 
folder, the timer is reset. 
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Subfolders within the AI batch folders can be nested. The timer on the parent 
AI batch folder will be reset. Additions to nested subfolders within 
06112009_AIBatch will reset this timer. Nested subfolders do not have their 
own timers. There is only one timer for the 06112009_AIBatch.

NOTE: Paths that exceed 256 characters may not be supported by the 
Windows operating system. It is recommended that subfolders and file 
names be kept within this limit.

A new AI batch folder can appear in the watch folder at any time. It will get its 
own timer and operate independently of other AI batches.
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When a timer expires, the AI batch folder is locked, and inserted into the auto 
import processing queue.

Other jobs will be inserted into the processing queue as their timers expire.

The Auto Import Processing Queue will be processed in first-in, first-out order. 
In this example, the entire contents of 06112009_AIBatch will be processed 
followed by 06112009_AIBatch2. Since these two AI batches have the same 
job setup (they came from the same watch folder), a batch separator will be 
inserted between the two AI batches according to the AIDemo1 job setup. 

Files within an AI batch will be processed by recursively iterating through files 
and subfolders and processing their contents in alphanumeric order.
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However, since ALL AI batches share the same Auto Import Processing 
Queue, if an AI batch from a different watch folder were to be next in the 
queue, a batch separator would be inserted regardless of auto import setup 
options.

AI batches in the Auto Import Processing Queue will be processed in first-in, 
first-out order. There is no management facility for this queue. All AI batches 
will be processed in their entirety, in sequence barring errors (see Error 
handling, below).

When the entire batch has been processed, the original files will optionally be 
copied into the archive.

Error handling When a batch is being processed, if a supported image file cannot be opened: 

• the bad file will be copied into the error cache, 

• a generic “error” image will substituted, and 

• the error count for the AI batch will be incremented.

If the error threshold defined in the batch setup has been reached, processing 
of the batch will stop. A dialog box will be displayed with the following options:

- Ignore: move ahead to the next image. The batch will resume processing 
until the next bad image is encountered.

- Abort: the remaining files in the batch will be copied into the error cache 
and auto import will stop. Following an abort, when restarted, auto import 
proceeds with the next batch in the queue. There is no automated recovery 
procedure for batches copied into the error cache. The user will have to 
locate and correct the bad files and manually reinsert the batch into the 
watch folder.
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11   Troubleshooting

Contents Problem solving ....................................................................................... 11-1
Clearing errors ......................................................................................... 11-2
Common messages ................................................................................. 11-3
Technical support ..................................................................................... 11-3

Problem solving Occasionally you may encounter a situation with Kodak Capture Pro Software. 
Use the chart below as a guide to check possible solutions to help you resolve 
the situation before calling Technical Support. 

Problem Possible Solution
Conflict found that will prevent OCR 
functions and PDF output from working

The conflict is likely caused by an older version of the OmniPage SDK 
Toolkit (from Nuance/ScanSoft), Version 12 or earlier, that was installed 
on your PC. If the following Nuance DLL files are present in the 
Windows\System32 directory on your PC, then this is the cause of the 
conflict:

Formatter.dll

Lecsomgr.dll

Prerendering.dll

RecDiag.dll

Rnapi.dll

To resolve the conflict, remove these DLL files from the System32 
directory and restart Capture Pro Software.

More recent versions of ScanSoft/Nuance applications (such as 
PaperPort and OmniPage) no longer install their DLL files in the 
System32 directory, so removing these files should not impact any other 
applications that you may be running on your PC.

Cannot open batch If you try to open a batch and this message is displayed, verify that you 
have read-write access to the scanned image folder. 

System is running slow Depending on your scanning resolution and feature set, there may be 
some modes that do not drive your scanner at full rated speed using the 
minimum system hardware requirements. It is recommended that you 
increase your CPU speed and system memory.
For optimum performance: 
• Pentium IV, 2.8 GHz (or equivalent) CPU
• 2 GB system memory (or higher)
• Hard disk: at least 40 GB (7200 rpm)

Conflict found or installation problem 
that prevents patch code (or bar code) 
functions from working

The conflict may be caused by an older version of an AMP release or 
toolkit (from All My Papers) that was installed on your PC. If any of the 
following AMP DLL files are present in the Windows\System32 directory 
on your PC, then this is the cause of the conflict:
amplm.dll
amplib.dll
ampPX.dll
To resolve the conflict, remove these DLL files from the System32 
directory and restart Capture Pro Software.
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Clearing errors The Kodak Capture Pro Batch Status window provides information on batches 
that you are preparing for output from Kodak Capture Pro Software.

To view the Batch Status window:

• Select Batch>View Batch Output Status.

To clear the errors:

• Click on the Job Name to Clear All Errors or Clear Selected Errors.

Problem Possible Solution
Newly developed System Batch Output 
Formats do not appear in the Job 
Setup>Output>System "Send to" 
drop-down list

This may be caused by a missing Microsoft Windows component which 
is required for newer Batch Output Formats to run properly.
To resolve the issue, visit the appropriate Microsoft link below, and follow 
the instructions for download and installation:
http://www.microsoft.com/downloads/details.aspx?familyid=200B2FD9-
AE1A-4A14-984D-389C36F85647&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=A5C84275-
3B97-4AB7-A40D-3802B2AF5FC2&displaylang=en
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Common messages Following is a list of messages and corrective actions you can take if one of the 
following messages is encountered.

Technical support Support for Kodak Capture Pro Software can be found on the Kodak website: 
www.kodak.com/go/CaptureProSupport. The support pages provide product-
specific information such as access to product upgrade downloads, drivers, 
accessories and access to the FAQs (Frequently Asked Questions) and details 
of the support options available for Capture Pro Software available in your 
country/region.

Messages Probable Cause/Remedy
License code verification code 
failed because no hardware key 
could be detected.

Kodak Capture Pro Software could not detect a hardware (WIBU) key. 
• Be sure the WIBU key is securely inserted into the USB port of your PC.

The batch cannot be opened 
because it is currently in use by 
another user.

If you are scanning in a multiple-scanner environment and the batch has 
already been opened by another workstation, Kodak Capture Pro Software 
will not allow you to open the batch until the batch is closed by the other user.

Recognition of bar codes, patch 
codes, and OCR is possible with 
color (or grayscale) images, but 
scanning performance may be 
improved if your Page Setup scans 
both color (grayscale) and black 
and white images, then deletes the 
black and white images.

Information. You can use color or grayscale setups for barcode, but it is not 
recommended. Click OK on the Information message, close all windows and 
select a black and white Page Setup, then go back to the Bar Code Setup and 
scan the image. 
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Appendix A Glossary

Attachment — when scanning a multi-page document, an attachment refers 
to those pages that are in addition to the lead or first page of the document. 
For instance, when scanning a 3-page document, pages 2 and 3 are 
considered attachments. 

Auto Crop — automatically removes the border of an image.

Auto Deskew — automatically straightens the image.

Bar code zone — a bar code zone is a section of an image defined as the 
location that may contain a barcode. Multiple different locations and 
characteristics (e.g., bar code type) may be set up on an image. The bar codes 
within these zones may be used for separation or indexing.

Batch — a collection of documents. A job can be used as the basis for 
creating many batches (each up to 999999999 documents; essentially 
unlimited). Processing a batch means converting the batch to a specific output 
format (i.e., single-page TIFF, PDF, LaserFiche, etc.) and sending it to a batch 
destination folder/subdirectory. Batches can be processed one by one 
or together.

Batch Output Format — determines the image format (e.g., TIFF, PDF, 
JPEG) and output destination for a batch that is processed. Included are the 
name and output directory structure for image files and index files.

Document — a paper document is a collection of pages; an electronic 
document is also a collection of pages, each of which is represented by one or 
more images. A document containing many pages is called a multi-page 
document (e.g., a file folder or article). 

Document index — the document index links search fields (up to 10 search 
fields) with the document number of each document. The document index can 
be built manually or automatically with bar codes, OCR values or default 
values. 

Dual Stream —  also referred to as simulataneous scanning — is the 
scanner’s ability to produce both color/grayscale and black and white images 
simultaneously without any further processing required by the host computer.

File format — a bit-mapped graphic file format that is usable for color, 
grayscale and black and white images.

Grayscale — a range of gray tones that cover the entire visible light spectrum 
from white to black.
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Image — the scanner converts sides to images. Every image belongs to a 
document with a unique document number. Capture Pro Software gives every 
image a sequential number inside its document. One document can contain 
up to 999999999 (e.g., essentially unlimited) images. Capture Pro Software 
distinguishes between an image coming from the front or rear side of a 
page. This allows Capture Pro Software to perform side-specific processing 
(e.g., deletion of blank rear sides) where appropriate. 

Capture Pro Software also distinguishes between color, grayscale, and black 
and white images and can perform color/grayscale versus black and white 
specific processing.
Example: Document 250 contains two double-sided pages and produces an 
electronic document number 250, which contains four images (1-4).

Index file audit — the verifying system that ensures all index values comply 
with the input/output format.

Job — Kodak Capture Pro Software is “job” based. A job is a configuration that 
defines what to do with a set of documents that you want to scan. For 
example, you may use a job to scan all the pages in the scanner’s feeder and 
create a single PDF file with the option to type in a name for the PDF file (a 
default job supplied with Capture Pro Software called “Scan to PDF”). 

A job contains all of the settings related to document capture and can be either 
general settings for “any” type of document or specifically set for a particular 
document type (i.e., invoices or personnel records). These settings can include 
bar code settings, document or batch separation, index definitions, OCR 
settings as well as settings related to the output files you want to create (JPEG, 
TIFF, PDF, Searchable PDF, etc.), or the document management system you 
will send the documents to (Microsoft SharePoint, LaserFiche, etc.).

To scan documents in a job, you need to create a batch to hold the scanned 
documents, images and data before you output them.

Kodak Capture Pro Software is shipped with three pre-defined jobs.

• Ready to Scan: a simple job setup allowing you to get familiar with Capture 
Pro Software and start scanning right away.

• Scan to PDF: similar to Ready to Scan, this job will scan a document and 
display the first page and prompt the user to enter a filename. The filename 
is used when you output the documents.

• Scan to e-mail: similar to Scan to PDF. When the PDF file is created, your 
email account will automatically be opened with the PDF attached and ready 
to send to an email recipient.

JPEG (Joint Photographic Experts Group)— a popular standard for 
compressing color still images.

ODBC (Open DataBase Connectivity) — a standard database access method 
developed by the SQL Access group. This method makes it possible to access 
any data from any application, regardless of which database management 
system (DBMS) is handling the data. 

OCR (Optical Character Recognition) — the process of recognizing printed 
characters by a software application.
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Output — the processing of the scanned images and delivering them, with any 
index data, to the next stage in the document’s lifecycle. Other software 
applications may call this the Release process whereby the scanned 
documents are “released” to the next step.

Page — a page in paper form is part of a paper document. A page can 
produce one image (single-sided page), two images (double-sided page), or 
four images (both color and black and white) after scanning. An electronic 
page associates all the images produced when the paper page was scanned.

Page Setup (Scanner Settings Profiles) — page setups hold all of the settings 
used to tell the scanner how to capture images. These include scan settings 
(e.g., Black & White, Grayscale or Color, one-sided or two-sided scanning) and 
imaging settings (i.e., rotation, resolution, etc.) 

Kodak Capture Pro is installed with many pre-defined settings to capture 
images or you can easily create your own custom profiles.

Page setup is a two-stage process:

• First, setup a scanner-specific “scanner profile” in the scanner’s driver which 
contains the physical scanning settings. This tells the scanner how to 
capture the images (i.e., resolution, front/back, scanner imaging 
enhancements, etc.).

• Second, setup a Capture Pro Software Page Setup that contains the 
“scanner profile” to use when scanning and any software-related settings for 
scanned pages. These include any image rotation (if not supported by the 
scanner), blank page removal, image merging (join both front/rear of a 
check into a single image file) or image splitting (split an A3 into two A4 
images), etc.

Scan Cache — the location where images are stored after being scanned into 
a batch and before the batch is processed. By default, the scan cache is 
defined to be on the local hard drive (e.g., C:\) of the scanning PC.

Side — one page has two sides, front and rear. With single-sided pages, the 
rear is blank. 

Simultaneous scanning — see dual stream.

TIFF (Tagged Image File Format) — a bitmapped graphic file format that is 
usable for color, grayscale and black and white images.
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Appendix B System Requirements

Contents Recommended software and hardware .....................................................B-1
Certified operating systems .......................................................................B-1
Certified scanners ......................................................................................B-1

For a successful installation of Kodak Capture Pro Software, review the 
following to be sure your system is equipped with the minimum software and 
hardware requirements. 

Recommended software 
and hardware

Minimum hardware requirements:

• 2.8 GHz processor with at least 1 GB of memory

NOTE: If you are producing Searchable PDF output on the same PC while 
scanning into new batches, it is recommended that your PC has a 
dual-core processor.

To ensure optimal performance, the following is recommended:
• Dual core processor 
• Memory: 4 GB or higher
• Hard disk: at least 40 GB (7200 rpm)
• Monitor resolution: Minimum 1024 x 768 
• DVD-ROM drive

NOTE: Depending on your scanning resolution and feature set, there may be 
some modes that do not drive your scanner at full rated speed using 
the minimum system hardware requirements. It is recommended that 
you increase your CPU speed and system memory.

Certified operating 
systems

Kodak Capture Pro Software is certified on the following Microsoft Windows 
operating systems:
• Windows XP Professional, SP2 (32-bit)
• Windows Vista (32-bit)

To use Kodak Capture Pro Software with Windows Vista, your scanner must 
have a Vista certified driver. Check with the manufacturer to confirm that your 
scanner will work with Windows Vista.

Certified scanners Kodak Capture Pro Software is certified with more than 150 scanners from a 
wide range of manufacturers. For a full list of the scanners currently supported 
go to www.kodak.com/go/kcsscannersupport.
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Appendix C Terminology Changes from Capture 6.x Software

If you had Kodak Capture Software before Kodak Capture Pro Software, some 
of the terminology has changed. Use this chart to help associate old terms with 
new ones.

Kodak Capture 6.x Software 
Old terminology

Kodak Capture Pro Software 
New terminology

Application Job
Application Setup dialog box Job Setup dialog box
Dual stream images Black and white and color/grayscale images, 

both front and back sides
Bi-tonal images Black and white images, both front and back 

sides
Button bar Replaced by six separate toolbars
Duplex Two-sided
Simplex One-sided
OCR indexing Indexing (using bar code zones and OCR 

zones)
Processing batches Outputting batches
Buttons (on Button Bar) Icons (on tool bars)
Display Mode button Image Viewer Display icon
Image Display Area Image Viewer
Toolbar Replaced by six separate toolbars
Scroll image Pan image
Zoom image Magnify image
Rear side of image Back side of image
Bar Code and OCR Setup 
window

This window still exists. However, you can use 
separate Bar Code or OCR windows. The 
functions are identical.

Hand icon means "Move" Hand icon means "Pan"
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